summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2023.11.29.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 3de77b939153..635f26312441 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,2 +1 @@
-DIST trove-classifiers-2023.11.29.tar.gz 15918 BLAKE2B 3e216aa24a458f5c65a20b2589dff34c382c3e1ccba5274377b09bcc254fafb077dfd3f82b0f1c998a9c34b20f35eca27bd7d8103b631a03eb87a9c1525c057e SHA512 fdeb6bbddbb3ad640112827b55f4b0a2201c79e2a4013d2d621bf0a6168d87861ad1802b0805747fc7d9e8be7e1954d58b83fd4fde6f3394cec2fa3aa88f0dca
DIST trove-classifiers-2024.1.8.tar.gz 15943 BLAKE2B f0a4ec5439415d53d81297001aac2b4ffc3da0e2c5492acb9a3ed23fba9e7c7ea1407cfa2f8291ab0b8ea7f1dd985cdd86a1b82e71b0223c88ae73bcc7ce63cd SHA512 3a86f54fd432b7d176cc7740a6a171eb9cdef339633b023ab81f5f8e68a7bae5ebb2d49c82aaec53f0f865c84234ac9506de45f76c3b9be18d57f5fcfe3afe73
diff --git a/dev-python/trove-classifiers/trove-classifiers-2023.11.29.ebuild b/dev-python/trove-classifiers/trove-classifiers-2023.11.29.ebuild
deleted file mode 100644
index 66a6ca8b4872..000000000000
--- a/dev-python/trove-classifiers/trove-classifiers-2023.11.29.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
-HOMEPAGE="
- https://github.com/pypa/trove-classifiers/
- https://pypi.org/project/trove-classifiers/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-
-distutils_enable_tests pytest
-
-src_configure() {
- grep -q 'build-backend = "setuptools' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease hatchling bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "trove-classifiers"
- version = "${PV}"
- description = "Canonical source for classifiers on PyPI (pypi.org)."
- EOF
-}
-
-python_test() {
- epytest
- "${EPYTHON}" -m tests.lib || die
-}