summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/lsat/Manifest1
-rw-r--r--app-admin/lsat/files/lsat-0.9.7.1-gentoo.patch42
-rw-r--r--app-admin/lsat/files/lsat-0.9.7.1-segfault-fix.patch45
-rw-r--r--app-admin/lsat/lsat-0.9.7.1-r2.ebuild54
-rw-r--r--app-admin/lsat/metadata.xml15
-rw-r--r--profiles/package.mask11
6 files changed, 0 insertions, 168 deletions
diff --git a/app-admin/lsat/Manifest b/app-admin/lsat/Manifest
deleted file mode 100644
index 9ff51998af98..000000000000
--- a/app-admin/lsat/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lsat-0.9.7.1.tgz 86077 BLAKE2B 609eb2a3345d147f03d03eea31fc34834ab2c0f95cf8b348ae0289020e092a991ab215160dcb1bee06ec07186fc2b9ee61af59dcff140dbda0fa91ebc7f8574e SHA512 fa67b5ebb03d11e3ee023c921977ddb64ea1fafca1d4cdb4b0fc5dbfa6edf46d57e488e9702175afbbde360a63d02ee5839fdf6576d974354a3b1d57f8860ffb
diff --git a/app-admin/lsat/files/lsat-0.9.7.1-gentoo.patch b/app-admin/lsat/files/lsat-0.9.7.1-gentoo.patch
deleted file mode 100644
index 631dcd7322f7..000000000000
--- a/app-admin/lsat/files/lsat-0.9.7.1-gentoo.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -Naur lsat-0.9.6.orig/Makefile.in lsat-0.9.6/Makefile.in
---- lsat-0.9.6.orig/Makefile.in 2007-05-22 11:38:28.000000000 +0900
-+++ lsat-0.9.6/Makefile.in 2007-05-25 18:55:25.000000000 +0900
-@@ -12,6 +12,7 @@
- PROGRAM= lsat
- INSTALL = /usr/bin/install -c
- prefix = @prefix@
-+exec_prefix = @exec_prefix@
- BINDIR = @bindir@
- DATADIR = @datadir@
- MANDIR = @mandir@
-@@ -38,9 +39,7 @@
- rm -f $(PROGRAM) $(OBJECTS) Makefile config.* lsat.old lsatmd5.out lsatmd5.old
-
- manpage:
-- pod2man $(PROGRAM).pod > $(PROGRAM).tmp
-- sed 's/perl v5.6.1/LSAT/g' $(PROGRAM).tmp| \
--sed 's/Perl/LSAT/g'\
-+ pod2man $(PROGRAM).pod -r LSAT -c 'User Contributed LSAT Documentation' \
- > $(PROGRAM).1
- rm -f $(PROGRAM).tmp
- # cp -vf $(PROGRAM).1 debian/manpage.1.ex
-diff -Naur lsat-0.9.6.orig/checkpkgs.c lsat-0.9.6/checkpkgs.c
---- lsat-0.9.6.orig/checkpkgs.c 2007-04-27 00:48:31.000000000 +0900
-+++ lsat-0.9.6/checkpkgs.c 2007-05-25 18:46:00.000000000 +0900
-@@ -113,14 +113,14 @@
- }
-
-
-- /* if distro = gentoo, use pkglist */
-+ /* if distro = gentoo, use qpkg */
- if (distribution == 4)
- {
- if (verbose > 0)
- {
- printf(" Generating list of pkgs on system.\n");
- }
-- shellcode = "/usr/lib/portage/bin/pkglist 2>/dev/null >>/tmp/lsat1.lsat";
-+ shellcode = "/usr/bin/qpkg -I -nc 2>/dev/null >>/tmp/lsat1.lsat";
- if ((dostuff(tempfile, 0, shellcode, 0, html)) < 0)
- {
- /* rhut-rho...something bad happened */
diff --git a/app-admin/lsat/files/lsat-0.9.7.1-segfault-fix.patch b/app-admin/lsat/files/lsat-0.9.7.1-segfault-fix.patch
deleted file mode 100644
index 558c8de60321..000000000000
--- a/app-admin/lsat/files/lsat-0.9.7.1-segfault-fix.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- lsat-0.9.7.1/lsatmain.c.orig 2008-12-29 11:09:04.000000000 -0500
-+++ lsat-0.9.7.1/lsatmain.c 2008-12-29 13:31:00.000000000 -0500
-@@ -232,7 +232,7 @@ int versions(char release[], char kernel
- } /* end while (fgets...) */
- close(fileval);
- /* clean up even though we will rm it */
-- close(infile);
-+ close((int)infile);
-
- if ( (system("rm -f /tmp/lsat1.lsat")) < 0)
- {
-@@ -308,9 +308,9 @@ int main(int argc, char *argv[])
- */
- char release[50]; /* array for release level */
- char kernel[50]; /* what kernel user is running */
-- static char *man_distro; /* if the user specifies a distribution */
-+ static char man_distro[10]; /* if the user specifies a distribution */
- const char * header =NULL; /* to print out the header */
-- static char *out_file = "lsat.out"; /* output filename var */
-+ static char out_file[255] = "lsat.out"; /* output filename var */
- char xlist[100]; /* modules to exclude */
- int xarray[33] = {0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0};
- int somethinginxlist = 0;
-@@ -350,10 +350,10 @@ int main(int argc, char *argv[])
- diff = 1;
- break;
- case 'm':
-- strcpy(man_distro, argv[i]+3);
-+ strncpy(man_distro, argv[i]+3,sizeof(man_distro));
- break;
- case 'o':
-- strcpy(out_file, argv[i]+3);
-+ strncpy(out_file, argv[i]+3,sizeof(out_file));
- break;
- case 'r':
- rpmmodule = 1;
-@@ -366,7 +366,7 @@ int main(int argc, char *argv[])
- break;
- case 'w':
- html = 1;
-- out_file="lsat.html";
-+ strcpy(out_file,"lsat.html");
- break;
- case 'x': strcpy(xlist,argv[i]+3);
- somethinginxlist = 1;
diff --git a/app-admin/lsat/lsat-0.9.7.1-r2.ebuild b/app-admin/lsat/lsat-0.9.7.1-r2.ebuild
deleted file mode 100644
index c1285e7e6de2..000000000000
--- a/app-admin/lsat/lsat-0.9.7.1-r2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="The Linux Security Auditing Tool"
-HOMEPAGE="http://usat.sourceforge.net/"
-SRC_URI="http://usat.sourceforge.net/code/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="minimal"
-
-DEPEND="dev-lang/perl" # pod2man
-RDEPEND="
- ${DEPEND}
- !minimal? (
- app-portage/portage-utils
- net-analyzer/nmap
- sys-apps/iproute2
- sys-apps/which
- sys-process/lsof
- )"
-
-PATCHES=(
- "${FILESDIR}/${P}-gentoo.patch"
- "${FILESDIR}/${P}-segfault-fix.patch"
-)
-
-HTML_DOCS=( modules.html changelog/changelog.html )
-
-src_prepare() {
- default
-
- # patch for segmentation fault see bug #184488
- sed -i Makefile.in \
- -e '/^LDFLAGS=/d' \
- -e '/^CFLAGS=/d' \
- || die "sed Makefile.in"
-}
-
-src_compile() {
- tc-export CC
- emake CFLAGS="${CFLAGS}" all manpage
-}
-
-src_install() {
- emake DESTDIR="${D}" install installman
- dodoc README* *.txt
- einstalldocs
-}
diff --git a/app-admin/lsat/metadata.xml b/app-admin/lsat/metadata.xml
deleted file mode 100644
index 301bfd358039..000000000000
--- a/app-admin/lsat/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
- Linux Security Auditing Tool (LSAT) is a post install security auditing
- tool. It is modular in design, so new features can be added quickly. It
- checks inetd entries and scans for unneeded RPM packages. It is being
- expanded to work with Linux distributions other than Red Hat, and checks
- for kernel versions.
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">usat</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 5199df0baf03..3e422e06553a 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -344,17 +344,6 @@ net-libs/farstream:0.1
# Removal in 30 days.
sec-policy/selinux-perdition
-# Michał Górny <mgorny@gentoo.org> (25 Apr 2019)
-# This programs suffers severe code quality problems and should have
-# never been added to Gentoo. It looks like a shell script badly
-# converted to a C program with a lot of system() calls with globs,
-# horribly unreadable code and broken memory management including
-# reading past end-of-string (which only recently replaced writing into
-# uninitialized memory). Auditing the program completely would probably
-# be more costly than rewriting it from scratch.
-# Removal in 30 days. Bug #684340.
-app-admin/lsat
-
# Michał Górny <mgorny@gentoo.org> (24 Apr 2019)
# Unmaintained. Vulnerable init.d script. Missing dependencies causing
# build failures (#514412, #544942). Insecure format strings (#520574).