summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libcdr/files/libcdr-0.1.1-boost-1.59.patch32
-rw-r--r--media-libs/libcdr/libcdr-0.1.0.ebuild11
-rw-r--r--media-libs/libcdr/libcdr-0.1.1.ebuild11
-rw-r--r--media-libs/libcdr/libcdr-0.1.2-r1.ebuild (renamed from media-libs/libcdr/libcdr-0.1.2.ebuild)8
-rw-r--r--media-libs/libcdr/libcdr-9999.ebuild8
5 files changed, 52 insertions, 18 deletions
diff --git a/media-libs/libcdr/files/libcdr-0.1.1-boost-1.59.patch b/media-libs/libcdr/files/libcdr-0.1.1-boost-1.59.patch
new file mode 100644
index 000000000000..e32f3fe8a668
--- /dev/null
+++ b/media-libs/libcdr/files/libcdr-0.1.1-boost-1.59.patch
@@ -0,0 +1,32 @@
+From 882a4b3f83a4b5097da53670c720a26f4e2750eb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Fridrich=20=C5=A0trba?= <fridrich.strba@bluewin.ch>
+Date: Sun, 13 Dec 2015 20:37:16 +0100
+Subject: [PATCH] Some boost 1.59 fixes
+
+Change-Id: I0054c977a6d8ff5a9b93c147578e890476365999
+---
+ src/lib/Makefile.am | 11 +++++++++--
+ 1 file changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
+index 3f00cc5..e14fa8c 100644
+--- a/src/lib/Makefile.am
++++ b/src/lib/Makefile.am
+@@ -13,8 +13,16 @@ libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_include_HEADERS = \
+ $(top_srcdir)/inc/libcdr/CDRDocument.h \
+ $(top_srcdir)/inc/libcdr/CMXDocument.h
+
+-AM_CXXFLAGS = -I$(top_srcdir)/inc $(REVENGE_CFLAGS) $(LCMS2_CFLAGS) $(ZLIB_CFLAGS) $(ICU_CFLAGS) $(DEBUG_CXXFLAGS) -DLIBCDR_BUILD=1
++AM_CXXFLAGS = -I$(top_srcdir)/inc \
++ $(REVENGE_CFLAGS) \
++ $(LCMS2_CFLAGS) \
++ $(ZLIB_CFLAGS) \
++ $(ICU_CFLAGS) \
++ $(DEBUG_CXXFLAGS) \
++ -DLIBCDR_BUILD=1 \
++ -DBOOST_ERROR_CODE_HEADER_ONLY \
++ -DBOOST_SYSTEM_NO_DEPRECATED
+
+ libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_la_LIBADD = $(REVENGE_LIBS) $(LCMS2_LIBS) $(ZLIB_LIBS) $(ICU_LIBS) @LIBCDR_WIN32_RESOURCE@
+ libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_la_DEPENDENCIES = @LIBCDR_WIN32_RESOURCE@
+ libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_la_LDFLAGS = $(version_info) -export-dynamic -no-undefined
diff --git a/media-libs/libcdr/libcdr-0.1.0.ebuild b/media-libs/libcdr/libcdr-0.1.0.ebuild
index 3484f9b3c89e..da99f3dc091e 100644
--- a/media-libs/libcdr/libcdr-0.1.0.ebuild
+++ b/media-libs/libcdr/libcdr-0.1.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-2
+inherit autotools eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
@@ -32,9 +32,10 @@ DEPEND="${RDEPEND}
"
src_prepare() {
- base_src_prepare
+ epatch "${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
+ epatch_user
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
diff --git a/media-libs/libcdr/libcdr-0.1.1.ebuild b/media-libs/libcdr/libcdr-0.1.1.ebuild
index 158c828fc6cd..c7dba09ebc06 100644
--- a/media-libs/libcdr/libcdr-0.1.1.ebuild
+++ b/media-libs/libcdr/libcdr-0.1.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-2
+inherit autotools eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
@@ -32,9 +32,10 @@ DEPEND="${RDEPEND}
"
src_prepare() {
- base_src_prepare
+ epatch "${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
+ epatch_user
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
diff --git a/media-libs/libcdr/libcdr-0.1.2.ebuild b/media-libs/libcdr/libcdr-0.1.2-r1.ebuild
index b0fd8db6ef5a..d818832699f5 100644
--- a/media-libs/libcdr/libcdr-0.1.2.ebuild
+++ b/media-libs/libcdr/libcdr-0.1.2-r1.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-2
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
"
src_prepare() {
- base_src_prepare
+ eapply_user
[[ -d m4 ]] || mkdir "m4"
[[ ${PV} == 9999 ]] && eautoreconf
}
diff --git a/media-libs/libcdr/libcdr-9999.ebuild b/media-libs/libcdr/libcdr-9999.ebuild
index b0fd8db6ef5a..d818832699f5 100644
--- a/media-libs/libcdr/libcdr-9999.ebuild
+++ b/media-libs/libcdr/libcdr-9999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-2
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
"
src_prepare() {
- base_src_prepare
+ eapply_user
[[ -d m4 ]] || mkdir "m4"
[[ ${PV} == 9999 ]] && eautoreconf
}