summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-process/xjobs/Manifest1
-rw-r--r--sys-process/xjobs/files/xjobs-20200726-command-v.patch48
-rw-r--r--sys-process/xjobs/files/xjobs-20200726-dont-page-tests.patch27
-rw-r--r--sys-process/xjobs/xjobs-20200726.ebuild32
4 files changed, 108 insertions, 0 deletions
diff --git a/sys-process/xjobs/Manifest b/sys-process/xjobs/Manifest
index 4f60511060e8..59ad731527fb 100644
--- a/sys-process/xjobs/Manifest
+++ b/sys-process/xjobs/Manifest
@@ -1 +1,2 @@
DIST xjobs-20190725.tgz 113216 BLAKE2B 079b6e104bb160101b2c4ef11e73ff040a8efa30839a39f9c91121b4928ddeefaefa43c3a94e18c9359fb6f66862ad7554598561a4e0c7f36b8f622d9a394340 SHA512 23ead9d33ebacb1b3d7a03c72c40dfb34b6254add81b0fde9e458a4be54f6298d2ce6a0b65742ac050685212eea8c5f83d48ea98b09c3928b16e36c7447a9551
+DIST xjobs-20200726.tgz 113795 BLAKE2B 4a6bfa405c6abf507ea9d0fce066b1547f1900687b04cf5797ced4862052596b4a32c2b24a89a7665e2253fe322ae83948d367c0ffc176bb322a0df9df0023a0 SHA512 52d84a957f53e894897770512271709bdfb1c45e51e1765cc16d96d9dc54901451d3f6ed16ed3a8ff4718e96b149fb2b53ee205d6ff1e1463f1de8b02b345705
diff --git a/sys-process/xjobs/files/xjobs-20200726-command-v.patch b/sys-process/xjobs/files/xjobs-20200726-command-v.patch
new file mode 100644
index 000000000000..8e233ba816c2
--- /dev/null
+++ b/sys-process/xjobs/files/xjobs-20200726-command-v.patch
@@ -0,0 +1,48 @@
+From c25bbd08331d88dc1f68806e204a091ed5693f9a Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Tue, 15 Sep 2020 20:03:06 -0400
+Subject: [PATCH 1/2] runtest1.sh,testdummy: use "command -v" instead of
+ "which".
+
+The "command -v" incantation is the POSIX-compatible version of the
+"which" command, described in
+
+ https://pubs.opengroup.org/onlinepubs/9699919799/utilities/command.html
+
+This commit changes two uses of "which" to "command -v" for maximum
+compatibility. This has a nice side effect; it eliminates the error
+output when the first of two alternatives is not found, as in
+
+ which: no gsleep in (...)
+
+before the "sleep" command is used as a fallback.
+---
+ runtest1.sh | 2 +-
+ testdummy | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/runtest1.sh b/runtest1.sh
+index 7584116..2dfadd1 100755
+--- a/runtest1.sh
++++ b/runtest1.sh
+@@ -1,4 +1,4 @@
+ #!/bin/sh
+
+-A=`which gawk || which awk`
++A="$(command -v gawk || command -v awk)"
+ $A "BEGIN{for (i=0;i<10;++i) print rand()*10}" | ./xjobs -j8 ./testdummy
+diff --git a/testdummy b/testdummy
+index 1787a46..f511806 100755
+--- a/testdummy
++++ b/testdummy
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+
+-S=`which gsleep||which sleep`
++S="$(command -v gsleep || command -v sleep)"
+ $S $1
+ expr "$1" \> "4" > /dev/null
+ if [ "$?" != "0" ]; then
+--
+2.26.2
+
diff --git a/sys-process/xjobs/files/xjobs-20200726-dont-page-tests.patch b/sys-process/xjobs/files/xjobs-20200726-dont-page-tests.patch
new file mode 100644
index 000000000000..078a0a2af5aa
--- /dev/null
+++ b/sys-process/xjobs/files/xjobs-20200726-dont-page-tests.patch
@@ -0,0 +1,27 @@
+From d8b0e6f20d3e4bfc1989e98856ab11a16851b32e Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Tue, 15 Sep 2020 20:13:44 -0400
+Subject: [PATCH 2/2] runtest1.sh: unset PAGER while running tests.
+
+There's no need to page this output, and it makes automating the test
+suite a pain in the butt. Unsetting PAGER in the test script makes
+it work normally again.
+
+Gentoo-bug: https://bugs.gentoo.org/742443
+---
+ runtest1.sh | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/runtest1.sh b/runtest1.sh
+index 2dfadd1..8d5c46d 100755
+--- a/runtest1.sh
++++ b/runtest1.sh
+@@ -1,4 +1,5 @@
+ #!/bin/sh
+
+ A="$(command -v gawk || command -v awk)"
++unset PAGER
+ $A "BEGIN{for (i=0;i<10;++i) print rand()*10}" | ./xjobs -j8 ./testdummy
+--
+2.26.2
+
diff --git a/sys-process/xjobs/xjobs-20200726.ebuild b/sys-process/xjobs/xjobs-20200726.ebuild
new file mode 100644
index 000000000000..ce8701c8d06e
--- /dev/null
+++ b/sys-process/xjobs/xjobs-20200726.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Reads commands line by line and executes them in parallel"
+HOMEPAGE="https://www.maier-komor.de/xjobs.html"
+SRC_URI="https://www.maier-komor.de/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="sys-devel/flex"
+
+# The ncurses/terminfo libraries are used to provide color and status
+# support; but, they're detected and enabled automagically by the build
+# system. Thus it would do no good to hide them behind a USE flag that
+# can't be turned off.
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/xjobs-20200726-command-v.patch"
+ "${FILESDIR}/xjobs-20200726-dont-page-tests.patch"
+)
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+}