summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-6.6.0.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index edaac9b83bcb..c1e8b141b4c8 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -2,6 +2,5 @@ DIST qtlocation-5.15.11-fix-appendChildNode.patch.xz 536 BLAKE2B f20566fb1b28cbb
DIST qtlocation-5.15.11-patchset.tar.xz 4796 BLAKE2B dcfa75bd3fb2e9069e1a530c27e2b4e9ac921fcf0ccb712f0894375b575ba25103948c6e5b85b56a8f9c9f2d7edf7df8e38501e93356e69f060b577a04c2d221 SHA512 14bd2864abc6f446dc4fbac03548cb42305685b46db757d856360780144095a021130bc0ebf1d07a516dc7991dc0cfbf733bd0ef6be58237bc15822c21af1d0b
DIST qtlocation-everywhere-opensource-src-5.15.11.tar.xz 6554216 BLAKE2B e882ecdc4f565f48874371e5235dc96769fbded9446a2a7f1afd869217f4bc75a9f42c6c34627311b55fbfc60da9a95fc7472c3ced83fca722799497b437a9d9 SHA512 d439d03ff9044fc70165d1ceb5def9ec3290beec56b3e893409a24cd355651a4317e0eadff0266d38203ff84429a5fb8659a200f094669716579b6791a1a0f6d
DIST qtlocation-everywhere-src-6.5.3.tar.xz 3032844 BLAKE2B 3b23b8d1b1a06476428879c0d32d3fc21119e50410d97ee3948c0ab7b22832f27f1e5ed2d06e62f53baf668b77630a27e5c6814b54c2e9498706a436256c4005 SHA512 6633dedba335b8de4c96f98f4709a147e225e82fee1ed741938e15e1540421ad7c3140baec75914f0844a793433abcadaf3ce72d944662b62778327d65ff7348
-DIST qtlocation-everywhere-src-6.6.0.tar.xz 3035992 BLAKE2B 9adfb9bfc91cecaac473b517b223d590bf762393c387346e55f5f1ee4a3e59b2377c0ed4de037c45ebe5fb1e2997980c400fa587fbd1f503aa6531b6438840a1 SHA512 e4e492229d961bc34630aaff030b46385708312de174c9c47f85a6010f1fcb74e198333920fd5c02153a8bbae770c83d8cd1777177d9c9d7a1d555b6619be8f2
DIST qtlocation-everywhere-src-6.6.1.tar.xz 3035980 BLAKE2B 0221f1d44ff5f0713b93e319989e46af8aaa29178bc8b77081c940c3f7d341701301ac6453f91b2febdcbb67d807ad440eedbd79e5cec5f1ec593ee0f5cef92c SHA512 aa820e84efe3576bf483cd7d64a3b930f731c88324d34cc1486312c1cb0107a726dea91dc226562f017695300f0d656228d947d97374747c3ac6ae597cda6bb5
DIST qtlocation-mapboxgl-5.15.11-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
diff --git a/dev-qt/qtlocation/qtlocation-6.6.0.ebuild b/dev-qt/qtlocation/qtlocation-6.6.0.ebuild
deleted file mode 100644
index 05a2dc329b2f..000000000000
--- a/dev-qt/qtlocation/qtlocation-6.6.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Location (places, maps, navigation) library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network]
- ~dev-qt/qtdeclarative-${PV}:6
- ~dev-qt/qtpositioning-${PV}:6[qml]
-"
-DEPEND="${RDEPEND}"
-
-CMAKE_SKIP_TESTS=(
- # ignores QML_IMPORT_PATH (unlike other tests) and looks in
- # the missing builddir/qml, skip rather than work around
- tst_declarative_ui
-)
-
-src_install() {
- qt6-build_src_install
-
- if use test; then
- local delete=( # sigh
- "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
- "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
- "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
- "${D}${QT6_QMLDIR}"/QtLocation/Test
- )
- # using -f given not tracking which tests may be skipped or not
- rm -rf -- "${delete[@]}" || die
- fi
-}