summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/tpm2-tools/Manifest1
-rw-r--r--app-crypt/tpm2-tools/metadata.xml11
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/Manifest b/app-crypt/tpm2-tools/Manifest
new file mode 100644
index 000000000000..7b96fcbbc309
--- /dev/null
+++ b/app-crypt/tpm2-tools/Manifest
@@ -0,0 +1 @@
+DIST tpm2-tools-3.1.3.tar.gz 544098 BLAKE2B 4c22ae98ed444b7d5b5f99e6a7d4cc37fcf9d46979669a2225b6f2abf8ccaaff203ccc8c816169be215c6160ce2480e4c9a0197040764013ab362dd060c29bec SHA512 37edf59e47168c42ffc66e948722753334ae3e00f3e258d9e801dffd259a763a1bf4f63b3feecf7728b4dade69ca5da15d631e1a606f68e10f7d314a1a757bdc
diff --git a/app-crypt/tpm2-tools/metadata.xml b/app-crypt/tpm2-tools/metadata.xml
new file mode 100644
index 000000000000..a1035736860b
--- /dev/null
+++ b/app-crypt/tpm2-tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tpm2-software/tpm2-tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild b/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
new file mode 100644
index 000000000000..a23c0b4d9a6a
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl test"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.0
+ net-misc/curl
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-hardening \
+ $(use_enable test unit)
+}