summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.5.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index b1359b1bce05..d514be0d26b2 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -4,3 +4,4 @@ DIST pytest-cov-2.1.0.tar.gz 25992 SHA256 6e86c3ae3be9930fa3f1402651819b00169fb5
DIST pytest-cov-2.2.0.tar.gz 29965 SHA256 2231d43f07760d6904dadceabca53ab16ef95ba58fff393861b64c0cab96c9d1 SHA512 3e6a2b648b12eff3d8f0aad12dda35a05820f6073e7f87e9c92ed6cca00fe031750da8f6c37eb81cf6ca7b2e4975dafffd7e3e901cb7b91e5c53c83b6e6b8420 WHIRLPOOL 9feff5557af5f4101e9ae508febf3479472781544b54345d5f53f0f19df5f40eb5af4ada2b44037f590445761ee9d3bffe14d729c465f880951d714eeb6ae491
DIST pytest-cov-2.2.1.tar.gz 33154 SHA256 a8b22e53e7f3b971454c35df99dffe21f4749f539491e935c55d3ff7e1b284fa SHA512 8f20cf1c42b4415c7decf8407582e64045c599aedf1970160d02e35e723f56fa095af26ee4390eabf2d32e209898b0a3dae8b7212ac81ecda64d6dbc7c83f790 WHIRLPOOL 92386bd1ff532e0c98f1dc01b3583315a626a030fb4f38e39eb4f8755e83f3901873fdcd406f9c8bc6393040fa198cc416dae5e176e88084ed6fb16264d3c056
DIST pytest-cov-2.3.1.tar.gz 35378 SHA256 fa0a212283cdf52e2eecc24dd6459bb7687cc29adb60cb84258fab73be8dda0f SHA512 79770beb53fbb43b5d68311c2efd0accbfd890ab6dad299da8c1c0b3d26b54d984807313b1507900cda7004bfb50fedc0bd4341cfcfce47849a4f24fc8184f11 WHIRLPOOL 8b0fe223f0cbae0bb9c85b3d8d7f80456e164f3565bd7ba146b0eb34c1fd06c0447405dccd2642f0a4aec1819ff74277d2eb9b076e61438fbf69b35c472755e0
+DIST pytest-cov-2.5.1.tar.gz 36201 SHA256 03aa752cf11db41d281ea1d807d954c4eda35cfa1b21d6971966cc041bbf6e2d SHA512 868131d6ea6dd28deec6d653dec23ceb7d3adccfa2c6bcc0a3126bbb11e924e71f200676461b2202f274ce6e14d1799feb0917e3081817d9e8583271c18a43de WHIRLPOOL e7084c4f55b12fab3cd2d99acebb02159f764c20b69e141c7b6779b1c4720c5d6358791559d46074a8af19f89ad3d0c8d9e722ffa7d4b217c9ab88936dece910
diff --git a/dev-python/pytest-cov/pytest-cov-2.5.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.5.1.ebuild
new file mode 100644
index 000000000000..72ead3a4d2c7
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.5.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.python.org/pypi/pytest-cov"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
+ >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ )
+ =dev-python/pytest-xdist-1.15.0[${PYTHON_USEDEP}]
+ dev-python/pytest-capturelog[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_test() {
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
+ PYTEST_PLUGINS=${PN/-/_} \
+ py.test -v -v -x || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}