summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/haml-rails/haml-rails-2.0.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/haml-rails/haml-rails-2.0.1-r1.ebuild b/dev-ruby/haml-rails/haml-rails-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..42ee8c50bef2
--- /dev/null
+++ b/dev-ruby/haml-rails/haml-rails-2.0.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides Haml generators for Rails 4"
+HOMEPAGE="https://github.com/indirect/haml-rails"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/actionpack-5.1:*
+ >=dev-ruby/activesupport-5.1:*
+ >=dev-ruby/railties-5.1:*
+ >=dev-ruby/haml-4.0.6:* <dev-ruby/haml-6:*
+ >=dev-ruby/html2haml-1.0.1"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rails-5.1 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}