summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/print-manager/Manifest1
-rw-r--r--kde-plasma/print-manager/print-manager-5.93.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-plasma/print-manager/Manifest b/kde-plasma/print-manager/Manifest
index b51813247e7c..fcc724639ed4 100644
--- a/kde-plasma/print-manager/Manifest
+++ b/kde-plasma/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-23.08.4.tar.xz 289936 BLAKE2B 904ed56a62f8e91beb7179fac171a1af4d8c6292bc86afe931dd5644ee18e0a883c3e29fc5b37dbd60eeddadb349626abc4c14a5bf2c7d32b78da77a40f063de SHA512 3c527ea57d78492a77252b9c5d22e476ef05531bb154c3bd7d986dcb0bbd87c0811b8e3e354f5da94ed58bdf4d7a119d648b80b2ad8689cabe332fb9265e78d3
DIST print-manager-5.92.0.tar.xz 333696 BLAKE2B a7875bed092ec3d038d01fb8153f57571c5374ea8b4b1a7654e7f91905755254259b7729c5e4ba8874e166a2f336d581da98a55a0a29d64f1d886e9374558d27 SHA512 929dca8934e9b8a450b0f26afac3dbcfff05ddd75edfea78e9d4a3b4a955a784a8544710e4976119ed4fc66524c865ea873525e730316ca4f665a799970f0330
+DIST print-manager-5.93.0.tar.xz 335032 BLAKE2B 817132086caffd93a574f3948f9219deb0ce403515a6f7d69e3140490bbd58eb8fa0061e16718f9ac2843990a2547ab767638ba5653481a9476dbe1c78cca437 SHA512 56a3c4ffad589df256a8e873b078fe51c4734893382e7c8c46be4f599d7e140f93ba4866a3e196e3811c9c91cd66d3169e4040110e39980423033426c35777e9
diff --git a/kde-plasma/print-manager/print-manager-5.93.0.ebuild b/kde-plasma/print-manager/print-manager-5.93.0.ebuild
new file mode 100644
index 000000000000..4fff551020a1
--- /dev/null
+++ b/kde-plasma/print-manager/print-manager-5.93.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.249.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Manage CUPS print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="+gtk"
+
+DEPEND="
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-plasma/libplasma-${PVCUT}:6
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/print-manager-23.08.5-r100:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:6
+ kde-plasma/kde-cli-tools:*
+ gtk? ( app-admin/system-config-printer )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}