summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/busybox/busybox-1.28.0.ebuild9
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/sys-apps/busybox/busybox-1.28.0.ebuild b/sys-apps/busybox/busybox-1.28.0.ebuild
index ece00db5d1c3..68000bffa174 100644
--- a/sys-apps/busybox/busybox-1.28.0.ebuild
+++ b/sys-apps/busybox/busybox-1.28.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
@@ -123,6 +123,13 @@ src_configure() {
# triming the BSS size may be dangerous
busybox_config_option n FEATURE_USE_BSS_TAIL
+ # These cause trouble with musl.
+ if use elibc_musl; then
+ busybox_config_option n FEATURE_UTMP
+ busybox_config_option n EXTRA_COMPAT
+ busybox_config_option n FEATURE_VI_REGEX_SEARCH
+ fi
+
# If these are not set and we are using a uclibc/busybox setup
# all calls to system() will fail.
busybox_config_option y ASH
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index ece00db5d1c3..68000bffa174 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
@@ -123,6 +123,13 @@ src_configure() {
# triming the BSS size may be dangerous
busybox_config_option n FEATURE_USE_BSS_TAIL
+ # These cause trouble with musl.
+ if use elibc_musl; then
+ busybox_config_option n FEATURE_UTMP
+ busybox_config_option n EXTRA_COMPAT
+ busybox_config_option n FEATURE_VI_REGEX_SEARCH
+ fi
+
# If these are not set and we are using a uclibc/busybox setup
# all calls to system() will fail.
busybox_config_option y ASH