summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-containers/catatonit/Manifest1
-rw-r--r--app-containers/catatonit/catatonit-0.1.7.ebuild23
-rw-r--r--app-containers/catatonit/metadata.xml10
3 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/catatonit/Manifest b/app-containers/catatonit/Manifest
new file mode 100644
index 000000000000..32720de2595a
--- /dev/null
+++ b/app-containers/catatonit/Manifest
@@ -0,0 +1 @@
+DIST 0.1.7.tar.gz 21720 BLAKE2B ab73198e55dd06d3d0af04e6eff17a2f1e70ab1c0f9ec35f68f9afe71ce8cd1bdc3320e9728a6d8036c2251fe95028e1aad0838d1c9f51e4cc70e482a1109c24 SHA512 7d3174c60e1c8bd1f4b95b7751ccbe01cac63265060f18914b53311f68f7b4c63c693604f348ccfac5db4a96939169f835fbbbd614803b18062053d94f7dca67
diff --git a/app-containers/catatonit/catatonit-0.1.7.ebuild b/app-containers/catatonit/catatonit-0.1.7.ebuild
new file mode 100644
index 000000000000..5beb81856a7e
--- /dev/null
+++ b/app-containers/catatonit/catatonit-0.1.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A container init that is so simple it's effectively brain-dead"
+HOMEPAGE="https://github.com/openSUSE/catatonit"
+SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+src_configure() {
+ ./autogen.sh || die
+ default
+}
+
+src_install() {
+ default
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/catatonit || die
+}
diff --git a/app-containers/catatonit/metadata.xml b/app-containers/catatonit/metadata.xml
new file mode 100644
index 000000000000..dd80ca2b54fb
--- /dev/null
+++ b/app-containers/catatonit/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">openSUSE/catatonit</remote-id>
+ </upstream>
+</pkgmetadata>