summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/fftw/Manifest3
-rw-r--r--sci-libs/fftw/fftw-2.1.5-r8.ebuild156
-rw-r--r--sci-libs/fftw/fftw-3.3.4.ebuild162
-rw-r--r--sci-libs/fftw/fftw-3.3.5-r1.ebuild193
-rw-r--r--sci-libs/fftw/fftw-3.3.5-r2.ebuild177
-rw-r--r--sci-libs/fftw/fftw-3.3.6_p1.ebuild181
6 files changed, 0 insertions, 872 deletions
diff --git a/sci-libs/fftw/Manifest b/sci-libs/fftw/Manifest
index b337988db264..971f7d9a5f89 100644
--- a/sci-libs/fftw/Manifest
+++ b/sci-libs/fftw/Manifest
@@ -1,5 +1,2 @@
DIST fftw-2.1.5.tar.gz 1256888 SHA256 f8057fae1c7df8b99116783ef3e94a6a44518d49c72e2e630c24b689c6022630 SHA512 8724a7f66aa19b271aa0ffb0e3762919f08082ac4400f52d11b50aef9b9d23a7d4fc5d6b2eae0ac166e2bb30a4d38a52c878e8bf8e24aba01ab1c3ddf5ebec15 WHIRLPOOL 2ea64d246c12e14962b93e05411c5f06dd193a887acb3fe5e7f63231a1a2f1f21b3a41f75951e18c332b25105865633c87150f2107169f5487b6b9983b968e10
-DIST fftw-3.3.4.tar.gz 3940427 SHA256 8f0cde90929bc05587c3368d2f15cd0530a60b8a9912a8e2979a72dbe5af0982 SHA512 1ee2c7bec3657f6846e63c6dfa71410563830d2b951966bf0123bd8f4f2f5d6b50f13b76d9a7b0eae70e44856f829ca6ceb3d080bb01649d1572c9f3f68e8eb1 WHIRLPOOL 2a5733f5537ff55a1830994431f1750dd790a4df3e8b3d1e9018c1afba2c5172f4e456eaee1c3427a2b170d23b6928da462e067a6f4e94792cfc7ff1cbc38938
-DIST fftw-3.3.5.tar.gz 4148447 SHA256 8ecfe1b04732ec3f5b7d279fdb8efcad536d555f9d1e8fabd027037d45ea8bcf SHA512 a81f02d884cfe4171fab479b0e5ec76eceb9c5da6d4eda1f89281b7e1efa2d8176c9ba87051595c402889eb32172d216ce40eb2bef41289c646f01002fb4ba8e WHIRLPOOL dc044c73dbb1b9fa595a0f1e71b5958d3e023c38cd6b1bb8a486adcad506fc6e411a3d8d0657a32346ff6636cf25396bd9bcdbcd720e8c799f6e40f1e04bfd65
-DIST fftw-3.3.6-pl1.tar.gz 4179807 SHA256 1ef4aa8427d9785839bc767f3eb6a84fcb5e9a37c31ed77a04e7e047519a183d SHA512 e2ed33fcb068a36a841bbd898d12ceec74f4e9a0a349e7c55959878b50224a69a0f87656347dad7d7e1448ebc50d28d8f34f6da7992c43072d26942fd97c0134 WHIRLPOOL 8ccd7a3dfc49be2053e8c3f334ea348a3455bcb6f84a636cd531f15822abd3452cfa50cd0bca4295b1dc922897e38613cf5cb865e60b83e9e357af396f2d9c99
DIST fftw-3.3.6-pl2.tar.gz 4185261 SHA256 a5de35c5c824a78a058ca54278c706cdf3d4abba1c56b63531c2cb05f5d57da2 SHA512 e130309856752a1555b6d151c4d0ce9eb4b2c208fff7e3e89282ca8ef6104718f865cbb5e9c4af4367b3615b69b0d50fd001a26d74fd5324ff2faabe14fe3472 WHIRLPOOL 92b55473e1aaca71e07869c12b5f0e9b94e21317c1d8e37c2f0ae5e4ff1bb803a7f8c8104ad52ede56211964a6374e4cb054809ca2df9b22306bb1ca89e2bfa7
diff --git a/sci-libs/fftw/fftw-2.1.5-r8.ebuild b/sci-libs/fftw/fftw-2.1.5-r8.ebuild
deleted file mode 100644
index e889eba4d768..000000000000
--- a/sci-libs/fftw/fftw-2.1.5-r8.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-FORTRAN_NEEDED=fortran
-
-inherit autotools eutils flag-o-matic fortran-2 toolchain-funcs
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-SRC_URI="http://www.fftw.org/${P}.tar.gz"
-HOMEPAGE="http://www.fftw.org"
-
-DEPEND="mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-SLOT="2.1"
-LICENSE="GPL-2+"
-IUSE="doc float fortran mpi openmp threads static-libs"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-pkg_setup() {
- use openmp && FORTRAN_NEED_OPENMP="1"
- fortran-2_pkg_setup
- # this one is reported to cause trouble on pentium4 m series
- filter-mfpmath "sse"
-
- # here I need (surprise) to increase optimization:
- # --enable-i386-hacks requires -fomit-frame-pointer to work properly
- if use x86; then
- is-flag "-fomit-frame-pointer" || append-flags "-fomit-frame-pointer"
- fi
- if use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp; then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
- ewarn "If you want to build fftw with OpenMP, abort now,"
- ewarn "and switch CC to an OpenMP capable compiler"
- ewarn "Otherwise the configure script will select POSIX threads."
- fi
- use openmp && [[ $(tc-getCC)$ == icc* ]] && append-ldflags $(no-as-needed)
-}
-
-src_prepare() {
- # doc suggests installing single and double precision versions
- # via separate compilations. will do in two separate source trees
- # since some sed'ing is done during the build
- # (?if --enable-type-prefix is set?)
-
- epatch \
- "${FILESDIR}"/${P}-as-needed.patch \
- "${FILESDIR}"/${P}-configure.in.patch \
- "${FILESDIR}"/${P}-no-test.patch \
- "${FILESDIR}"/${P}-cc.patch \
- "${FILESDIR}"/${P}-texinfo5.1.patch
-
- # fix info files
- for infofile in doc/fftw*info*; do
- cat >> ${infofile} <<-EOF
- INFO-DIR-SECTION Libraries
- START-INFO-DIR-ENTRY
- * fftw: (fftw). ${DESCRIPTION}
- END-INFO-DIR-ENTRY
- EOF
- done
-
- sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
-
- eautoreconf
-
- cd "${WORKDIR}"
- cp -R ${P} ${P}-double
- mv ${P} ${P}-single
- ln -s ${P}-single ${P}
-}
-
-src_configure() {
- local myconf="
- --enable-shared
- --enable-type-prefix
- --enable-vec-recurse
- $(use_enable fortran)
- $(use_enable mpi)
- $(use_enable static-libs static)
- $(use_enable x86 i386-hacks)"
- if use openmp; then
- myconf="${myconf}
- --enable-threads
- --with-openmp"
- elif use threads; then
- myconf="${myconf}
- --enable-threads
- --without-openmp"
- else
- myconf="${myconf}
- --disable-threads
- --without-openmp"
- fi
- cd "${S}-single"
- econf ${myconf} \
- --enable-float \
- --with-gcc=$(tc-getCC)
-
- cd "${S}-double"
- econf ${myconf} \
- --with-gcc=$(tc-getCC)
-}
-
-src_compile() {
- local dir
- for dir in "${S}-single" "${S}-double"
- do
- einfo "Running compilation in ${dir}"
- emake -C ${dir}
- done
-}
-
-src_test() {
- local dir
- for dir in "${S}-single" "${S}-double"
- do
- einfo "Running tests in ${dir}"
- emake -C ${dir} -j1 check
- done
-}
-
-src_install () {
- # both builds are installed in the same place
- # libs are distinguished by prefix (s or d), see docs for details
-
- local dir
- for dir in "${S}-single" "${S}-double"
- do
- emake DESTDIR="${D}" -C ${dir} install
- done
-
- insinto /usr/include
- doins fortran/fftw_f77.i
- dodoc AUTHORS ChangeLog NEWS TODO README README.hacks
- use doc && dohtml doc/*
-
- if use float; then
- for f in "${ED}"/usr/{include,$(get_libdir)}/*sfft*; do
- ln -s $(basename ${f}) ${f/sfft/fft}
- done
- for f in "${ED}"/usr/{include,$(get_libdir)}/*srfft*; do
- ln -s $(basename ${f}) ${f/srfft/rfft}
- done
- else
- for f in "${ED}"/usr/{include,$(get_libdir)}/*dfft*; do
- ln -s $(basename ${f}) ${f/dfft/fft}
- done
- for f in "${ED}"/usr/{include,$(get_libdir)}/*drfft*; do
- ln -s $(basename ${f}) ${f/drfft/rfft}
- done
- fi
-}
diff --git a/sci-libs/fftw/fftw-3.3.4.ebuild b/sci-libs/fftw/fftw-3.3.4.ebuild
deleted file mode 100644
index 9174c474ef42..000000000000
--- a/sci-libs/fftw/fftw-3.3.4.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-FORTRAN_NEEDED=fortran
-
-inherit autotools-multilib eutils flag-o-matic fortran-2 multibuild toolchain-funcs versionator
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-2
- EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
- KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
- AUTOTOOLS_AUTORECONF=1
-else
- SRC_URI="http://www.fftw.org/${P}.tar.gz"
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-fi
-
-LICENSE="GPL-2+"
-SLOT="3.0/3"
-IUSE="altivec cpu_flags_x86_avx doc cpu_flags_x86_fma3 cpu_flags_x86_fma4 fortran mpi neon openmp quad cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs test threads zbus"
-
-RDEPEND="
- mpi? ( virtual/mpi )
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r2
- !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/perl )"
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- FORTRAN_NEED_OPENMP=1
- fi
-
- fortran-2_pkg_setup
-
- MULTIBUILD_VARIANTS=( single double longdouble )
- if use quad; then
- if [[ $(tc-getCC) == *gcc ]] && ! version_is_at_least 4.6 $(gcc-version); then
- ewarn "quad precision only available for gcc >= 4.6"
- die "need quad precision capable gcc"
- fi
- MULTIBUILD_VARIANTS+=( quad )
- fi
-}
-
-src_prepare() {
- # fix info file for category directory
- [[ ${PV} = *9999 ]] || sed -i \
- -e 's/Texinfo documentation system/Libraries/' \
- doc/fftw3."info" || die "failed to fix info file"
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local x
-
- # filter -Os according to docs
- replace-flags -Os -O2
-
- my_configure() {
- #a bit hacky improve after #483758 is solved
- local x=${BUILD_DIR%-*}
- x=${x##*-}
- # there is no abi_x86_32 port of virtual/mpi right now
- local enable_mpi=$(use_enable mpi)
- multilib_is_native_abi || enable_mpi="--disable-mpi"
-
- #jlec reported USE=quad on abi_x86_32 has too less registers
- #stub Makefiles
- if [[ ${ABI} == x86 && ${x} == quad ]]; then
- mkdir -p "${BUILD_DIR}/tests" || die
- echo "all: ;" > "${BUILD_DIR}/Makefile" || die
- echo "install: ;" >> "${BUILD_DIR}/Makefile" || die
- echo "smallcheck: ;" > "${BUILD_DIR}/tests/Makefile" || die
- return 0
- fi
-
- local myeconfargs=(
- $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
- $(use_enable fortran)
- $(use_enable zbus mips-zbus-timer)
- $(use_enable threads)
- $(use_enable openmp)
- )
- if [[ $x == single ]]; then
- #altivec, sse, single-paired only work for single
- myeconfargs+=(
- --enable-single
- $(use_enable altivec)
- $(use_enable cpu_flags_x86_avx avx)
- $(use_enable cpu_flags_x86_sse sse)
- ${enable_mpi}
- $(use_enable neon)
- )
- elif [[ $x == double ]]; then
- myeconfargs+=(
- $(use_enable cpu_flags_x86_avx avx)
- $(use_enable cpu_flags_x86_sse2 sse2)
- ${enable_mpi}
- )
- elif [[ $x == longdouble ]]; then
- myeconfargs+=(
- --enable-long-double
- ${enable_mpi}
- )
- elif [[ $x == quad ]]; then
- #quad does not support mpi
- myeconfargs+=( --enable-quad-precision )
- else
- die "${x} precision not implemented in this ebuild"
- fi
-
- autotools-utils_src_configure
- }
-
- multibuild_foreach_variant multilib_parallel_foreach_abi my_configure
-}
-
-src_compile() {
- multibuild_foreach_variant autotools-multilib_src_compile
-}
-
-src_test () {
- # We want this to be a reasonably quick test, but that is still hard...
- ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
- # Do not increase the number of threads, it will not help your performance
- #local testbase="perl check.pl --nthreads=1 --estimate"
- # ${testbase} -${p}d || die "Failure: $n"
- multibuild_foreach_variant autotools-multilib_src_compile -C tests smallcheck
-}
-
-src_install () {
- local u x
- DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
- HTML_DOCS=( doc/html/ )
-
- multibuild_foreach_variant multilib_foreach_abi autotools-utils_src_install
-
- if use doc; then
- dodoc doc/*.pdf
- insinto /usr/share/doc/${PF}/faq
- doins -r doc/FAQ/fftw-faq.html/*
- else
- rm -r "${ED}"/usr/share/doc/${PF}/html
- fi
-
- for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
- for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
- sed -e "s|-lfftw3[flq]\?|&_$u &|" "$x" > "${x%.pc}_$u.pc" || die
- done
- done
-}
diff --git a/sci-libs/fftw/fftw-3.3.5-r1.ebuild b/sci-libs/fftw/fftw-3.3.5-r1.ebuild
deleted file mode 100644
index 8b95ce8b8ba9..000000000000
--- a/sci-libs/fftw/fftw-3.3.5-r1.ebuild
+++ /dev/null
@@ -1,193 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-
-inherit flag-o-matic fortran-2 toolchain-funcs versionator multibuild multilib-minimal
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
-else
- SRC_URI="http://www.fftw.org/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-fi
-
-LICENSE="GPL-2+"
-SLOT="3.0/3"
-IUSE="altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
-
-RDEPEND="
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/perl )"
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
- fi
-
- die "need openmp capable compiler"
- fi
- FORTRAN_NEED_OPENMP=1
- fi
-
- fortran-2_pkg_setup
-
- MULTIBUILD_VARIANTS=( single double longdouble )
- if use quad; then
- if tc-is-gcc && ! version_is_at_least 4.6 $(gcc-version); then
- ewarn "quad precision only available for gcc >= 4.6"
- die "need quad precision capable gcc"
- fi
- MULTIBUILD_VARIANTS+=( quad )
- fi
-}
-
-src_prepare() {
- default
-
- # fix info file for category directory
- if [[ ${PV} = *9999 ]]; then
- sed -i -e
- 's/Texinfo documentation system/Libraries/' \
- doc/fftw3."info" || die "failed to fix info file"
-
- eautoreconf
- fi
-}
-
-multilib_src_configure() {
- # there is no abi_x86_32 port of virtual/mpi right now, bug 519700
- local enable_mpi=$(multilib_native_use_enable mpi)
-
- # jlec reported USE=quad on abi_x86_32 has too few registers
- # stub Makefiles
- if [[ ${MULTILIB_ABI_FLAG} == abi_x86_32 && ${MULTIBUILD_ID} == quad-* ]]; then
- mkdir -p "${BUILD_DIR}/tests" || die
- echo "all: ;" > "${BUILD_DIR}/Makefile" || die
- echo "install: ;" >> "${BUILD_DIR}/Makefile" || die
- echo "smallcheck: ;" > "${BUILD_DIR}/tests/Makefile" || die
- return 0
- fi
-
- local myconf=(
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
- $(use_enable fortran)
- $(use_enable zbus mips-zbus-timer)
- $(use_enable threads)
- $(use_enable openmp)
- )
- case "${MULTIBUILD_ID}" in
- single-*)
- #altivec, sse, single-paired only work for single
- myconf+=(
- --enable-single
- $(use_enable altivec)
- $(use_enable cpu_flags_x86_avx avx)
- $(use_enable cpu_flags_x86_avx2 avx2)
- $(use_enable cpu_flags_x86_sse sse)
- $(use_enable cpu_flags_x86_sse2 sse2)
- $(use_enable neon)
- ${enable_mpi}
- )
- ;;
-
- double-*)
- myconf+=(
- $(use_enable cpu_flags_x86_avx avx)
- $(use_enable cpu_flags_x86_avx2 avx2)
- $(use_enable cpu_flags_x86_sse2 sse2)
- ${enable_mpi}
- )
- ;;
-
- longdouble-*)
- myconf+=(
- --enable-long-double
- ${enable_mpi}
- )
- ;;
-
- quad-*)
- #quad does not support mpi
- myconf+=(
- --enable-quad-precision
- )
- ;;
-
- *)
- die "${MULTIBUILD_ID%-*} precision not implemented in this ebuild"
- ;;
- esac
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-}
-
-src_configure() {
- multibuild_foreach_variant multilib-minimal_src_configure
-}
-
-src_compile() {
- multibuild_foreach_variant multilib-minimal_src_compile
-}
-
-multilib_src_test() {
- emake -C tests smallcheck
-}
-
-src_test() {
- # We want this to be a reasonably quick test, but that is still hard...
- ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
- # Do not increase the number of threads, it will not help your performance
- # local testbase="perl check.pl --nthreads=1 --estimate"
- # ${testbase} -${p}d || die "Failure: $n"
-
- multibuild_foreach_variant multilib-minimal_src_test
-}
-
-src_install() {
- DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
- HTML_DOCS=( doc/html/ )
-
- #workaroud for bug #590446
- my_abi_install() {
- pushd "${BUILD_DIR}" >/dev/null || die
- emake DESTDIR="${D}" install
- popd >/dev/null || die
- }
- multibuild_foreach_variant multilib_foreach_abi my_abi_install
-
- einstalldocs
-
- if use doc; then
- dodoc doc/*.pdf
- docinto faq
- dodoc -r doc/FAQ/fftw-faq.html/.
- else
- rm -r "${ED}"/usr/share/doc/${PF}/html || die
- fi
-
- local x
- for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
- local u
- for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
- sed -e "s|-lfftw3[flq]\?|&_${u} &|" "$x" > "${x%.pc}_${u}.pc" || die
- done
- done
-
- # fftw uses pkg-config to record its private dependencies
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/sci-libs/fftw/fftw-3.3.5-r2.ebuild b/sci-libs/fftw/fftw-3.3.5-r2.ebuild
deleted file mode 100644
index 07c2837181f1..000000000000
--- a/sci-libs/fftw/fftw-3.3.5-r2.ebuild
+++ /dev/null
@@ -1,177 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-
-inherit flag-o-matic fortran-2 toolchain-funcs versionator multibuild multilib-minimal
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
-else
- SRC_URI="http://www.fftw.org/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-fi
-
-LICENSE="GPL-2+"
-SLOT="3.0/3"
-IUSE="altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
-
-RDEPEND="
- mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/perl )"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- tc-check-openmp
- FORTRAN_NEED_OPENMP=1
- fi
-
- fortran-2_pkg_setup
-
- MULTIBUILD_VARIANTS=( single double longdouble )
- if use quad; then
- if tc-is-gcc && ! version_is_at_least 4.6 $(gcc-version); then
- ewarn "quad precision only available for gcc >= 4.6"
- die "need quad precision capable gcc"
- fi
- MULTIBUILD_VARIANTS+=( quad )
- fi
-}
-
-src_prepare() {
- default
-
- # fix info file for category directory
- if [[ ${PV} = *9999 ]]; then
- sed -i -e
- 's/Texinfo documentation system/Libraries/' \
- doc/fftw3."info" || die "failed to fix info file"
-
- eautoreconf
- fi
-}
-
-multilib_src_configure() {
- # jlec reported USE=quad on abi_x86_32 has too few registers
- # stub Makefiles
- if [[ ${MULTILIB_ABI_FLAG} == abi_x86_32 && ${MULTIBUILD_ID} == quad-* ]]; then
- mkdir -p "${BUILD_DIR}/tests" || die
- echo "all: ;" > "${BUILD_DIR}/Makefile" || die
- echo "install: ;" >> "${BUILD_DIR}/Makefile" || die
- echo "smallcheck: ;" > "${BUILD_DIR}/tests/Makefile" || die
- return 0
- fi
-
- local myconf=(
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
- $(use_enable fortran)
- $(use_enable zbus mips-zbus-timer)
- $(use_enable threads)
- $(use_enable openmp)
- )
- case "${MULTIBUILD_ID}" in
- single-*)
- # altivec, sse, single-paired only work for single
- myconf+=(
- --enable-single
- $(use_enable altivec)
- $(use_enable cpu_flags_x86_avx avx)
- $(use_enable cpu_flags_x86_avx2 avx2)
- $(use_enable cpu_flags_x86_sse sse)
- $(use_enable cpu_flags_x86_sse2 sse2)
- $(use_enable neon)
- $(use_enable mpi)
- )
- ;;
-
- double-*)
- myconf+=(
- $(use_enable cpu_flags_x86_avx avx)
- $(use_enable cpu_flags_x86_avx2 avx2)
- $(use_enable cpu_flags_x86_sse2 sse2)
- $(use_enable mpi)
- )
- ;;
-
- longdouble-*)
- myconf+=(
- --enable-long-double
- $(use_enable mpi)
- )
- ;;
-
- quad-*)
- # quad does not support mpi
- myconf+=(
- --enable-quad-precision
- )
- ;;
-
- *)
- die "${MULTIBUILD_ID%-*} precision not implemented in this ebuild"
- ;;
- esac
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC -lmpi)"
-}
-
-src_configure() {
- multibuild_foreach_variant multilib-minimal_src_configure
-}
-
-src_compile() {
- multibuild_foreach_variant multilib-minimal_src_compile
-}
-
-multilib_src_test() {
- emake -C tests smallcheck
-}
-
-src_test() {
- # We want this to be a reasonably quick test, but that is still hard...
- ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
- # Do not increase the number of threads, it will not help your performance
- # local testbase="perl check.pl --nthreads=1 --estimate"
- # ${testbase} -${p}d || die "Failure: $n"
-
- multibuild_foreach_variant multilib-minimal_src_test
-}
-
-src_install() {
- DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
- HTML_DOCS=( doc/html/ )
-
- multibuild_foreach_variant multilib-minimal_src_install
-
- if use doc; then
- dodoc doc/*.pdf
- docinto faq
- dodoc -r doc/FAQ/fftw-faq.html/.
- else
- rm -r "${ED}"usr/share/doc/${PF}/html || die
- fi
-
- local x
- for x in "${ED}"usr/lib*/pkgconfig/*.pc; do
- local u
- for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
- sed -e "s|-lfftw3[flq]\?|&_${u} &|" "$x" > "${x%.pc}_${u}.pc" || die
- done
- done
-
- # fftw uses pkg-config to record its private dependencies
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/sci-libs/fftw/fftw-3.3.6_p1.ebuild b/sci-libs/fftw/fftw-3.3.6_p1.ebuild
deleted file mode 100644
index 5b793c7a5ea2..000000000000
--- a/sci-libs/fftw/fftw-3.3.6_p1.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-
-inherit flag-o-matic fortran-2 toolchain-funcs versionator multibuild multilib-minimal
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
-
-MY_P=${PN}-${PV/_p/-pl}
-
-if [[ ${PV} = *9999 ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
-else
- SRC_URI="http://www.fftw.org/${PN}-${PV/_p/-pl}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-fi
-
-LICENSE="GPL-2+"
-SLOT="3.0/3"
-IUSE="altivec cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse cpu_flags_x86_sse2 doc fortran mpi neon openmp quad static-libs test threads zbus"
-
-RDEPEND="
- mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/perl )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- tc-check-openmp
- FORTRAN_NEED_OPENMP=1
- fi
-
- fortran-2_pkg_setup
-
- MULTIBUILD_VARIANTS=( single double longdouble )
- if use quad; then
- if tc-is-gcc && ! version_is_at_least 4.6 $(gcc-version); then
- ewarn "quad precision only available for gcc >= 4.6"
- die "need quad precision capable gcc"
- fi
- MULTIBUILD_VARIANTS+=( quad )
- fi
-}
-
-src_prepare() {
- default
-
- # fix info file for category directory
- if [[ ${PV} = *9999 ]]; then
- sed -i -e
- 's/Texinfo documentation system/Libraries/' \
- doc/fftw3."info" || die "failed to fix info file"
-
- eautoreconf
- fi
-}
-
-multilib_src_configure() {
- # jlec reported USE=quad on abi_x86_32 has too few registers
- # stub Makefiles
- if [[ ${MULTILIB_ABI_FLAG} == abi_x86_32 && ${MULTIBUILD_ID} == quad-* ]]; then
- mkdir -p "${BUILD_DIR}/tests" || die
- echo "all: ;" > "${BUILD_DIR}/Makefile" || die
- echo "install: ;" >> "${BUILD_DIR}/Makefile" || die
- echo "smallcheck: ;" > "${BUILD_DIR}/tests/Makefile" || die
- return 0
- fi
-
- local myconf=(
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
- $(use_enable fortran)
- $(use_enable zbus mips-zbus-timer)
- $(use_enable threads)
- $(use_enable openmp)
- )
- case "${MULTIBUILD_ID}" in
- single-*)
- # altivec, sse, single-paired only work for single
- myconf+=(
- --enable-single
- $(use_enable altivec)
- $(use_enable cpu_flags_x86_avx avx)
- $(use_enable cpu_flags_x86_avx2 avx2)
- $(use_enable cpu_flags_x86_sse sse)
- $(use_enable cpu_flags_x86_sse2 sse2)
- $(use_enable neon)
- $(use_enable mpi)
- )
- ;;
-
- double-*)
- myconf+=(
- $(use_enable cpu_flags_x86_avx avx)
- $(use_enable cpu_flags_x86_avx2 avx2)
- $(use_enable cpu_flags_x86_sse2 sse2)
- $(use_enable mpi)
- )
- ;;
-
- longdouble-*)
- myconf+=(
- --enable-long-double
- $(use_enable mpi)
- )
- ;;
-
- quad-*)
- # quad does not support mpi
- myconf+=(
- --enable-quad-precision
- )
- ;;
-
- *)
- die "${MULTIBUILD_ID%-*} precision not implemented in this ebuild"
- ;;
- esac
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}" MPICC="$(tc-getCC -lmpi)"
-}
-
-src_configure() {
- multibuild_foreach_variant multilib-minimal_src_configure
-}
-
-src_compile() {
- multibuild_foreach_variant multilib-minimal_src_compile
-}
-
-multilib_src_test() {
- emake -C tests smallcheck
-}
-
-src_test() {
- # We want this to be a reasonably quick test, but that is still hard...
- ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
- # Do not increase the number of threads, it will not help your performance
- # local testbase="perl check.pl --nthreads=1 --estimate"
- # ${testbase} -${p}d || die "Failure: $n"
-
- multibuild_foreach_variant multilib-minimal_src_test
-}
-
-src_install() {
- DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
- HTML_DOCS=( doc/html/ )
-
- multibuild_foreach_variant multilib-minimal_src_install
-
- if use doc; then
- dodoc doc/*.pdf
- docinto faq
- dodoc -r doc/FAQ/fftw-faq.html/.
- else
- rm -r "${ED}"usr/share/doc/${PF}/html || die
- fi
-
- local x
- for x in "${ED}"usr/lib*/pkgconfig/*.pc; do
- local u
- for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
- sed -e "s|-lfftw3[flq]\?|&_${u} &|" "$x" > "${x%.pc}_${u}.pc" || die
- done
- done
-
- # fftw uses pkg-config to record its private dependencies
- find "${ED}" -name '*.la' -delete || die
-}