summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libvpx/libvpx-1.7.0.ebuild3
-rw-r--r--media-libs/libvpx/libvpx-1.8.0-r1.ebuild3
-rw-r--r--media-libs/libvpx/libvpx-1.8.0.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/media-libs/libvpx/libvpx-1.7.0.ebuild b/media-libs/libvpx/libvpx-1.7.0.ebuild
index 877d221cedb9..752360e5cbe5 100644
--- a/media-libs/libvpx/libvpx-1.7.0.ebuild
+++ b/media-libs/libvpx/libvpx-1.7.0.ebuild
@@ -95,6 +95,9 @@ multilib_src_configure() {
x86_64*) export AS=yasm;;
esac
+ # powerpc toolchain is not recognized anymore, #694368
+ [[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
# Build with correct toolchain.
tc-export CC CXX AR NM
# Link with gcc by default, the build system should override this if needed.
diff --git a/media-libs/libvpx/libvpx-1.8.0-r1.ebuild b/media-libs/libvpx/libvpx-1.8.0-r1.ebuild
index 9c2b048cea49..f0bd95847496 100644
--- a/media-libs/libvpx/libvpx-1.8.0-r1.ebuild
+++ b/media-libs/libvpx/libvpx-1.8.0-r1.ebuild
@@ -84,6 +84,9 @@ multilib_src_configure() {
x86_64*) export AS=yasm;;
esac
+ # powerpc toolchain is not recognized anymore, #694368
+ [[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
# Build with correct toolchain.
tc-export CC CXX AR NM
# Link with gcc by default, the build system should override this if needed.
diff --git a/media-libs/libvpx/libvpx-1.8.0.ebuild b/media-libs/libvpx/libvpx-1.8.0.ebuild
index 5d7954ec89c1..a05ed4eb72ff 100644
--- a/media-libs/libvpx/libvpx-1.8.0.ebuild
+++ b/media-libs/libvpx/libvpx-1.8.0.ebuild
@@ -96,6 +96,9 @@ multilib_src_configure() {
x86_64*) export AS=yasm;;
esac
+ # powerpc toolchain is not recognized anymore, #694368
+ [[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
# Build with correct toolchain.
tc-export CC CXX AR NM
# Link with gcc by default, the build system should override this if needed.