summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild b/media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild
index fd83c1f2a838..e9669cc08246 100644
--- a/media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild
+++ b/media-fonts/arphicfonts/arphicfonts-0.2.20080216.1-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit font eutils
+inherit eutils font xdg-utils
DESCRIPTION="Chinese TrueType Arphic Fonts"
HOMEPAGE="http://www.arphic.com.tw/
@@ -59,6 +59,7 @@ src_prepare() {
find "${WORKDIR}" -mindepth 2 -maxdepth 2 -name '*.ttc' -exec mv {} . \;
find "${WORKDIR}" -name '*.conf' -exec mv "{}" . \;
epatch "${FILESDIR}"/${P}-fontconfig.patch
+ xdg_environment_reset
fontforge -script "${FILESDIR}"/${P}.pe b*.ttf || die
}
@@ -68,7 +69,7 @@ src_install() {
do
cd "${WORKDIR}"/${myfont}
docinto ${myfont}
- for doc in FONTLOG KNOWN_ISSUES TODO README README.Bitmap NEWS CONTRIBUTERS
+ for doc in FONTLOG KNOWN_ISSUES TODO README README.Bitmap NEWS CONTRIBUTERS
do
[ -f ${doc} ] && dodoc ${doc}
done