summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/znc/Manifest1
-rw-r--r--net-irc/znc/znc-1.4-r1.ebuild167
2 files changed, 0 insertions, 168 deletions
diff --git a/net-irc/znc/Manifest b/net-irc/znc/Manifest
index ba0bb07b773d..c159bff1ef8b 100644
--- a/net-irc/znc/Manifest
+++ b/net-irc/znc/Manifest
@@ -1,4 +1,3 @@
DIST googletest-release-1.7.0.tar.gz 468653 SHA256 f73a6546fdf9fce9ff93a5015e0333a8af3062a152a9ad6bcb772c96687016cc SHA512 c623d5720c4ed574e95158529872815ecff478c03bdcee8b79c9b042a603533f93fe55f939bcfe2cd745ce340fd626ad6d9a95981596f1a4d05053d874cd1dfc WHIRLPOOL e59e6aede05fd882c64586de7d204ed97fd02ec0f53abeb3130dcd18940ecefb59a43592ac5bd14dd28a8825845bd11359f637e28671554852573a4a43f8cd9c
-DIST znc-1.4.tar.gz 1239648 SHA256 86e98fd0ed182d39828c926809f8075d836ee3b70a6dd43dfbb434822f2a7b52 SHA512 0c33b05e8232084999812cbaa467dc7d37b80cafc1001b82e89c702b4303d8db9a27b948fe653e7090404eb1c66f5492f02f3524bc39efabade4be8bdb476671 WHIRLPOOL 420e665fa193b3f0284a070e021c4c467e3d40a0812eedeef9b2f65a6626a050b7af8bf15a754ac571d12261705832cfa18a0f7a7817cce96d220028a86230cf
DIST znc-1.6.3.tar.gz 1464200 SHA256 631c46de76fe601a41ef7676bc974958e9a302b72b25fc92b4a603a25d89b827 SHA512 777279b6c973310b4e78a0472bd1e355c2adf3e4fbe9ebedde3dd4706e5c0b208d4330eb2318a8d9e0d7d7146bee0a4a428cbe5a3f230c8f6aa692a477e86e2b WHIRLPOOL 2a41e0ac90038a8cc8f289d4ffc0494d29eda75450f650b8870c076fb809eb9c5829720bb39eb43d38ee4ac7f9bea6000ad90fcdd8c0eea461bf04f88cc17b52
DIST znc-1.6.5.tar.gz 1470681 SHA256 2f0225d49c53a01f8d94feea4619a6fe92857792bb3401a4eb1edd65f0342aca SHA512 d78603ac86d1fb92cdf591b1eb6d32fa19b0e39414bd69e1300c537051612ae590c43d3b8e4dd598cdff605bf3aa1d3d5d806edd428d15d50f733e1670f3e626 WHIRLPOOL b72585a2f11754bedb667ac078a617195aa718f9864e7e33b962d75387e7bc4c8c6c1465844f27b65a5af2d50cec7006ae325a43eb2ef930fc9c218bbaae60a1
diff --git a/net-irc/znc/znc-1.4-r1.ebuild b/net-irc/znc/znc-1.4-r1.ebuild
deleted file mode 100644
index e99e78596b20..000000000000
--- a/net-irc/znc/znc-1.4-r1.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_4 )
-inherit base python-single-r1 systemd user
-
-MY_PV=${PV/_/-}
-DESCRIPTION="An advanced IRC Bouncer"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/znc/znc.git"}
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://znc.in/releases/archive/${PN}-${MY_PV}.tar.gz"
- KEYWORDS="amd64 ~arm x86"
-fi
-
-HOMEPAGE="http://znc.in"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="daemon debug ipv6 perl python ssl sasl tcl"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- perl? ( >=dev-lang/perl-5.10 )
- python? ( ${PYTHON_DEPS} )
- sasl? ( >=dev-libs/cyrus-sasl-2 )
- ssl? ( >=dev-libs/openssl-0.9.7d:0 )
- tcl? ( dev-lang/tcl:0= )
-"
-DEPEND="
- virtual/pkgconfig
- perl? (
- >=dev-lang/swig-2.0.12
- )
- python? (
- >=dev-lang/swig-2.0.12
- )
- ${RDEPEND}
-"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.0-systemwideconfig.patch"
-)
-
-CONFDIR="/var/lib/znc"
-
-pkg_setup() {
- if use python; then
- python-single-r1_pkg_setup
- fi
- if use daemon; then
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /dev/null ${PN}
- fi
-}
-
-src_prepare() {
- if [[ ${PV} == *9999* ]]; then
- ./autogen.sh
- fi
-
- base_src_prepare
-}
-
-src_configure() {
- econf \
- --with-systemdsystemunitdir=$(systemd_get_unitdir) \
- $(use_enable debug) \
- $(use_enable ipv6) \
- $(use_enable perl) \
- $(use python && echo "--enable-python=python3") \
- $(use_enable sasl cyrus) \
- $(use_enable ssl openssl) \
- $(use_enable tcl tcl)
-}
-
-src_install() {
- emake install DESTDIR="${D}"
- dodoc NOTICE README.md
- if use daemon; then
- newinitd "${FILESDIR}"/znc.initd znc
- newconfd "${FILESDIR}"/znc.confd znc
- fi
-}
-
-pkg_postinst() {
- if use !daemon; then
- elog
- elog "Run 'znc --makeconf' as the user you want to run ZNC as"
- elog "to make a configuration file"
- elog
- else
- elog
- elog "An init-script was installed in /etc/init.d"
- elog "A config file was installed in /etc/conf.d"
- if [[ ! -d "${EROOT}${CONFDIR}" ]]; then
- elog
- elog "Run 'emerge --config znc' to configure ZNC"
- elog "as a system-wide daemon."
- elog
- elog "To generate a new SSL certificate, run:"
- elog " znc --system-wide-config-as znc --makepem -d ${CONFDIR}"
- elog "as root"
- elog
- elog "If migrating from a user-based install"
- elog "you can use your existing config files:"
- elog " mkdir ${CONFDIR}"
- elog " mv /home/\$USER/.znc/* ${CONFDIR}"
- elog " rm -rf /home/\$USER/.znc"
- elog " chown -R znc:znc ${CONFDIR}"
- elog
- elog "If you already have znc set up and want take advantage of the"
- elog "init script but skip of all the above, you can also edit"
- elog " /etc/conf.d/znc"
- elog "and adjust the variables to your current znc user and config"
- elog "location."
- if [[ -d "${EROOT}"/etc/znc ]]; then
- elog
- ewarn "/etc/znc exists on your system."
- ewarn "Due to the nature of the contents of that folder,"
- ewarn "we have changed the default configuration to use"
- ewarn " /var/lib/znc"
- ewarn "please move /etc/znc to /var/lib/znc"
- ewarn "or adjust /etc/conf.d/znc"
- fi
- else
- elog "Existing config detected in ${CONFDIR}"
- elog "You're good to go :)"
- fi
- elog
- fi
-}
-
-pkg_config() {
- if use daemon && ! [[ -d "${EROOT}${CONFDIR}" ]]; then
- einfo "Press ENTER to interactively create a new configuration file for znc."
- einfo "To abort, press Control-C"
- read
- mkdir -p "${EROOT}${CONFDIR}" || die
- chown -R ${PN}:${PN} "${EROOT}${CONFDIR}" ||
- die "Setting permissions failed"
- "${EROOT}"/usr/bin/znc --system-wide-config-as znc -c -r -d "${EROOT}${CONFDIR}" ||
- die "Config failed"
- echo
- einfo "To start znc, run '/etc/init.d/znc start'"
- einfo "or add znc to a runlevel:"
- einfo " rc-update add znc default"
- else
- if use daemon; then
- ewarn "${CONFDIR} already exists, aborting to avoid damaging"
- ewarn "any existing configuration. If you are sure you want"
- ewarn "to generate a new configuration, remove the folder"
- ewarn "and try again."
- else
- ewarn "To configure znc as a system-wide daemon you have to"
- ewarn "enable the 'daemon' use flag."
- fi
- fi
-}