summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/ldb/ldb-2.0.12-r1.ebuild (renamed from sys-libs/ldb/ldb-2.0.12.ebuild)9
-rw-r--r--sys-libs/ldb/ldb-2.1.4-r1.ebuild (renamed from sys-libs/ldb/ldb-2.1.4.ebuild)9
-rw-r--r--sys-libs/ldb/ldb-2.2.0-r1.ebuild (renamed from sys-libs/ldb/ldb-2.2.0.ebuild)9
3 files changed, 21 insertions, 6 deletions
diff --git a/sys-libs/ldb/ldb-2.0.12.ebuild b/sys-libs/ldb/ldb-2.0.12-r1.ebuild
index ef525af0a11a..22e302e558d5 100644
--- a/sys-libs/ldb/ldb-2.0.12.ebuild
+++ b/sys-libs/ldb/ldb-2.0.12-r1.ebuild
@@ -32,8 +32,8 @@ RDEPEND="
DEPEND="dev-libs/libxslt
doc? ( app-doc/doxygen )
+ python? ( ${PYTHON_DEPS} )
virtual/pkgconfig
- ${PYTHON_DEPS}
${RDEPEND}
"
@@ -50,7 +50,10 @@ PATCHES=(
)
pkg_setup() {
- python-single-r1_pkg_setup
+ # Package fails to build with distcc
+ export DISTCC_DISABLE=1
+
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
@@ -97,6 +100,8 @@ multilib_src_install() {
docinto html
dodoc -r apidocs/html/*
fi
+
+ use python && python_optimize #726454
}
pkg_postinst() {
diff --git a/sys-libs/ldb/ldb-2.1.4.ebuild b/sys-libs/ldb/ldb-2.1.4-r1.ebuild
index e1deb520305b..91e258a2a019 100644
--- a/sys-libs/ldb/ldb-2.1.4.ebuild
+++ b/sys-libs/ldb/ldb-2.1.4-r1.ebuild
@@ -32,8 +32,8 @@ RDEPEND="
DEPEND="dev-libs/libxslt
doc? ( app-doc/doxygen )
+ python? ( ${PYTHON_DEPS} )
virtual/pkgconfig
- ${PYTHON_DEPS}
${RDEPEND}
"
@@ -50,7 +50,10 @@ PATCHES=(
)
pkg_setup() {
- python-single-r1_pkg_setup
+ # Package fails to build with distcc
+ export DISTCC_DISABLE=1
+
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
@@ -97,6 +100,8 @@ multilib_src_install() {
docinto html
dodoc -r apidocs/html/*
fi
+
+ use python && python_optimize #726454
}
pkg_postinst() {
diff --git a/sys-libs/ldb/ldb-2.2.0.ebuild b/sys-libs/ldb/ldb-2.2.0-r1.ebuild
index e1deb520305b..91e258a2a019 100644
--- a/sys-libs/ldb/ldb-2.2.0.ebuild
+++ b/sys-libs/ldb/ldb-2.2.0-r1.ebuild
@@ -32,8 +32,8 @@ RDEPEND="
DEPEND="dev-libs/libxslt
doc? ( app-doc/doxygen )
+ python? ( ${PYTHON_DEPS} )
virtual/pkgconfig
- ${PYTHON_DEPS}
${RDEPEND}
"
@@ -50,7 +50,10 @@ PATCHES=(
)
pkg_setup() {
- python-single-r1_pkg_setup
+ # Package fails to build with distcc
+ export DISTCC_DISABLE=1
+
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
@@ -97,6 +100,8 @@ multilib_src_install() {
docinto html
dodoc -r apidocs/html/*
fi
+
+ use python && python_optimize #726454
}
pkg_postinst() {