summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/nnpy/nnpy-1.4.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/nnpy/nnpy-1.4.2.ebuild b/dev-python/nnpy/nnpy-1.4.2.ebuild
index 5f229a8e0b40..2f5fb5ec4614 100644
--- a/dev-python/nnpy/nnpy-1.4.2.ebuild
+++ b/dev-python/nnpy/nnpy-1.4.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
@@ -23,5 +23,5 @@ DEPEND="
RDEPEND="${DEPEND}"
python_test() {
- PYTHONPATH="${S}:${PYTHONPATH}" "${PYTHON}" "${S}/nnpy/tests.py" || die
+ PYTHONPATH="${S}:${PYTHONPATH}" "${PYTHON}" -m nnpy.tests || die
}