summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/llvm/llvm-6.0.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-6.0.0.ebuild b/sys-devel/llvm/llvm-6.0.0.ebuild
index e474af58c92d..f38524606bb8 100644
--- a/sys-devel/llvm/llvm-6.0.0.ebuild
+++ b/sys-devel/llvm/llvm-6.0.0.ebuild
@@ -75,6 +75,15 @@ S=${WORKDIR}/${P/_/}.src
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+pkg_pretend() {
+ if tc-is-gcc && [[ $(gcc-major-version) -ge 7 ]]; then
+ eerror "GCC 7 is known to cause mis-compilation that causes the build to hang."
+ eerror "Please use an older version to build LLVM until a good solution is found."
+ eerror "Bug report: https://bugs.gentoo.org/649880"
+ die "GCC-7+ is not supported"
+ fi
+}
+
src_prepare() {
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358