summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/construct/construct-2.8.21.ebuild1
-rw-r--r--dev-python/construct/construct-2.9.45.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/construct/construct-2.8.21.ebuild b/dev-python/construct/construct-2.8.21.ebuild
index a856d066558a..2e90888369a6 100644
--- a/dev-python/construct/construct-2.8.21.ebuild
+++ b/dev-python/construct/construct-2.8.21.ebuild
@@ -18,6 +18,7 @@ IUSE="test"
DEPEND="test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/scimath[${PYTHON_USEDEP}]' 'python2_7')
)"
python_test() {
diff --git a/dev-python/construct/construct-2.9.45.ebuild b/dev-python/construct/construct-2.9.45.ebuild
index b0b6c560e04b..d1968273fd4a 100644
--- a/dev-python/construct/construct-2.9.45.ebuild
+++ b/dev-python/construct/construct-2.9.45.ebuild
@@ -19,6 +19,7 @@ RESTRICT="test"
DEPEND="test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/scimath[${PYTHON_USEDEP}]' 'python2_7')
)"
python_test() {