summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/bson/Manifest1
-rw-r--r--dev-ruby/bson/bson-1.12.0.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/dev-ruby/bson/Manifest b/dev-ruby/bson/Manifest
index c77a4a1a0dc3..07ce404306c4 100644
--- a/dev-ruby/bson/Manifest
+++ b/dev-ruby/bson/Manifest
@@ -1,3 +1,2 @@
DIST bson-3.2.6.tar.gz 51846 SHA256 b7d848b93de622c32cc65cf6debf21aaa0e66d554d65cc7805dc8f76e56c55fb SHA512 da8d7c4e50bd5387a50f0ef471f1d854e0a1bf3f109bb793b16c8e4d110f6b98cb37aee126176eccb097c5d7814360ef85e96be4aa4704226a8490984a5dd3f2 WHIRLPOOL ece0e17aca10f684cdbea703702b5f886340fe93ede11045430c7711f2d546c5e2558003261d8252a29a55fc999664be0315f0ac693d02181a9dcf006d44a3c6
DIST bson-4.1.1.tar.gz 55417 SHA256 965d0da14886e795230686168676784c74117c705b262ee468205c0066166f64 SHA512 b98b568fe0a94e6430433a9bb57930c0a95c9b268d928a6fabb1ce6bd4343406e700de11db531f6a49bc270e449637c70ce0ad0a8f7f6cae7857f0ad627f1956 WHIRLPOOL b7f0735cb0d3e49d257f805398368e397a70f87dd38460ce04064ca34fc0f9b60f6e776403955be0e2db9360b94bb0b09f48d5c3e7036a10d8393b715c455b41
-DIST mongo-ruby-driver-1.12.0.tar.gz 360669 SHA256 84c87d26601c9bd91a6604bcb3630be50d239e471542f9b0a68379705dd03e11 SHA512 725110c527867379def85fde50b6825e94a320356f062e4403d9d55c223f2503676f83ae42916d6ab45afd90d30b2a4272519e070c4af2095c0965297fd72bb6 WHIRLPOOL c152aa579a0535707909560cc73fc878521aac95c034ec71bca6c2397754b5e057c1e7ca32f6b2b3393ce975f122e65926820cdde29aa5f5734fb9717bd980e0
diff --git a/dev-ruby/bson/bson-1.12.0.ebuild b/dev-ruby/bson/bson-1.12.0.ebuild
deleted file mode 100644
index ba97750249c2..000000000000
--- a/dev-ruby/bson/bson-1.12.0.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC="moot" # we do it manually, but still declare it
-RUBY_FAKEGEM_DOCDIR="html"
-RUBY_FAKEGEM_EXTRADOC=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="mongodb"
-GITHUB_PROJECT="mongo-ruby-driver"
-RUBY_S="${GITHUB_PROJECT}-${PV}"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
-HOMEPAGE="http://www.mongodb.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/${PV}.tar.gz -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-
-LICENSE="APSL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test doc"
-
-ruby_add_bdepend \
- "test? (
- dev-ruby/bundler
- >=dev-ruby/rake-10.1
- dev-ruby/sfl
- >=dev-ruby/shoulda-3.3.2
- dev-ruby/mocha
- dev-ruby/test-unit:2
- )
- doc? ( dev-ruby/rdoc )"
-
-all_ruby_prepare() {
- # remove the stuff that is actually part of dev-ruby/mongo
- rm -f bin/mongo* || die
-
- # Avoid test dependency on pry
- sed -i -e '/\(pry\|coverall\)/I s:^:#:' Gemfile tasks/testing.rake test/test_helper.rb || die
- # Avoid deployment dependencies and fix version issues
- sed -i -e '/rest-client/ s/1.6.8/~> 1.6/' \
- -e '/test-unit/ s/~>2.0/>= 2.0/' \
- -e '/rake/ s/10.1.1/~>10.1/' \
- -e '/:deploy/,/end/ s:^:#:' Gemfile || die
-
- # Don't clean up the compiled version after testing
- sed -i -e '/:cleanup/,/end/ s:lib/bson_ext::' tasks/testing.rake || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/cbson extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -C ext/cbson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- mkdir -p lib/bson_ext || die
- cp ext/cbson/*$(get_modname) lib/bson_ext || die
-}
-
-all_ruby_compile() {
- # Trying to get the Rakefile to build the sources is more trouble
- # than it's worth, do it manually instead.
- if use doc; then
- rdoc --op html --inline-source lib/**/*.rb || die "rdoc failed"
- fi
-}
-
-each_ruby_test() {
- C_EXT=true JENKINS_CI=true ${RUBY} -S rake test:bson || die "tests failed"
-}
-
-each_ruby_install() {
- # Remove remaining mongo code that will be installed as part of
- # dev-ruby/mongo. We do this here rather than in src_prepare so we
- # can bootstrap with tests enabled.
- rm -rf lib/mongo* || die
-
- # we have to set the library path here because the gemspec tries to
- # load bson itself, and would fail without that.
- RUBYLIB="lib" \
- each_fakegem_install
-
- # and now we create the simulated gem for bson_ext; we create a file
- # bson_ext.rb within ext so that we don't have to change the
- # bson_ext.gemspec file, and at the same time we ensure that bson
- # gem is loaded when loading bson_ext.
- dodir $(ruby_fakegem_gemsdir)/gems/bson_ext-${PV}/ext
- cat - <<EOF > "${D}/$(ruby_fakegem_gemsdir)/gems/bson_ext-${PV}/ext/bson_ext.rb"
-require 'bson'
-EOF
-
- RUBYLIB="lib" \
- RUBY_FAKEGEM_NAME=bson_ext \
- RUBY_FAKEGEM_GEMSPEC=bson_ext.gemspec \
- ruby_fakegem_install_gemspec
-}
-
-pkg_postinst() {
- elog "Unlike upstream setup, we do not split bson and bson_ext gem."
- elog "This means that for all the supported targets, the C-based extension"
- elog "is installed by this package, and is available transparently."
-}