summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/arborx/Manifest1
-rw-r--r--sci-libs/arborx/arborx-1.4.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/arborx/Manifest b/sci-libs/arborx/Manifest
index fdd46ae98bd0..4edaadde14e2 100644
--- a/sci-libs/arborx/Manifest
+++ b/sci-libs/arborx/Manifest
@@ -1 +1,2 @@
DIST arborx-1.2.tar.gz 380705 BLAKE2B eb0006e69edb6cfd1d402dfe5a58db76954c34f847ce8acd1c0f2bd2044a29a434fc01df67829fce4ec911f5c882c1625aa7a50bc39a5d33dfb2c26d6a4cbb4f SHA512 d48650b11fc26770c43f4821999647acb0c7675367e416ad025ab21eb50da66c732f03bc6decf840d25dac26ff7f1f5dca77b7514dffc619cef8d401e83a8795
+DIST arborx-1.4.1.tar.gz 408999 BLAKE2B 83e172f89ac8ff82d4add40fd036457d9c563b44c11b15d86aa884dc03742f3e22a13cc4b6f068ef377fcd8e63d239f704dd1821772079d2f9f8c169b1f31fae SHA512 3799deed5eae1e6092c19a62894207ac0ccd81ba84c8d42734fa3d0e5a3fc9d6a8f7b1442d2203b06f4e251970569f67506d419fb6695039c11e78dfd740e565
diff --git a/sci-libs/arborx/arborx-1.4.1.ebuild b/sci-libs/arborx/arborx-1.4.1.ebuild
new file mode 100644
index 000000000000..c27f694b4071
--- /dev/null
+++ b/sci-libs/arborx/arborx-1.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Library for performance portable algorithms for geometric search"
+HOMEPAGE="https://github.com/arborx/ArborX"
+
+SRC_URI="https://github.com/${PN}/ArborX/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="mpi"
+
+RDEPEND="dev-libs/boost:=
+ mpi? ( virtual/mpi[cxx] )
+ sci-libs/trilinos"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/ArborX-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DARBORX_ENABLE_MPI="$(usex mpi)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+}