summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/test-unit/Manifest3
-rw-r--r--dev-ruby/test-unit/test-unit-3.5.0.ebuild36
-rw-r--r--dev-ruby/test-unit/test-unit-3.5.1.ebuild36
-rw-r--r--dev-ruby/test-unit/test-unit-3.5.2.ebuild36
4 files changed, 0 insertions, 111 deletions
diff --git a/dev-ruby/test-unit/Manifest b/dev-ruby/test-unit/Manifest
index b7f3fe0346b9..fa040a7e6ad6 100644
--- a/dev-ruby/test-unit/Manifest
+++ b/dev-ruby/test-unit/Manifest
@@ -1,6 +1,3 @@
DIST test-unit-3.3.9.gem 121856 BLAKE2B f8ac1568aabc7d53c79715c6b141d3f2be0782e35dda36fc6184e7b7bbae419e883b94f163333e4e1a186c07f55cef181a2d86d4531e3968667e8c5fcfe8e36c SHA512 8e2a1516d33811793aacbf0b31b9609b43437ea6800cfe6c97b1c96395a8eea7c42f2788dd86b6decfda184a27e5818646bbe313d39ce3799a0869f62a0c4c32
DIST test-unit-3.4.9.tar.gz 161212 BLAKE2B 57c1932a1049300aad41eb8d0a72459c3eaecd5b5bc89fa9f981b6975be9b8b4d378dad8ff769bb1add54e28a6e84b54f791ab13c7bd31d042ae068e37c04f6c SHA512 dccfdbbeb5319cac36dec80d17428b593905c74d8644b19b938bc2cc15ceb598818e73d2f0a681142cba6395b16d404437821af72abc152ab20987a645faf001
-DIST test-unit-3.5.0.tar.gz 161244 BLAKE2B cbace253377c73d20e88a8457866084fb1914445d95c06e33c3dee72dd7302b12999eb9baf9402d78d6aad617b8c6c43709ae2ad2d7256d5b6c83fa374356956 SHA512 faf882d3a6faa528f3d4da0c78f7787cc43191dd6aff872c65ce172feb5f1e1169513a2ab6085fd2cf6f30716b50fcd538d88d60e669f724188adfed3ff5a76d
-DIST test-unit-3.5.1.tar.gz 161335 BLAKE2B 1b96e63934eb20d94474e25865f1631d1050383bbd8d41b851542b5fa08823e46f03792ee77a6d2d9172196c66a114001e33d54e8544a7286a31280f1c03d583 SHA512 de776d9b77a9eb4429813701ceaf5ac66346cdad05a2c79be428a7ca8e064a4191281e1a8f37bbddc736fae00e19a3fff9be8af93ba62042d11824da3c478d09
-DIST test-unit-3.5.2.tar.gz 161384 BLAKE2B 307f954bc2d8adc4ac8baf0e1adf626ff18be9eeb1dd00ae34fbd661e83ff0b0205585b3b542099343caffc33d6c1599e1eefd8469b1c0bc14a4f03244257711 SHA512 260b43458b3e993f51d255d9da21fa8308faff858f930f47c0ebaabed1a8e38543e1471cad6736ab52497e507d7aab80f75e78456202b883fcda77f5874d52eb
DIST test-unit-3.5.3.tar.gz 161397 BLAKE2B 1d52fa1eebf25a66e7036d6709a5410a5563f381d3a3eb05ef09702493e5990b93c6ae5a3167cc4d971174a08a2d2b884b860eeea0ea5f8a1fb76e9c42379e0b SHA512 e6960bdcc67c8667cc13f0a4cf8b412be767124b0e555294be71afff71e0ce9a34e7cfa7413e33ee3c8477928a479e9439ada9e50866c0e8890b4be8dd0b38a2
diff --git a/dev-ruby/test-unit/test-unit-3.5.0.ebuild b/dev-ruby/test-unit/test-unit-3.5.0.ebuild
deleted file mode 100644
index 496be5175274..000000000000
--- a/dev-ruby/test-unit/test-unit-3.5.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.md doc-install/text/*.md"
-
-RUBY_FAKEGEM_GEMSPEC="test-unit.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An xUnit family unit testing framework for Ruby"
-HOMEPAGE="https://rubygems.org/gems/test-unit"
-SRC_URI="https://github.com/test-unit/test-unit/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Ruby GPL-2 ) PSF-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend "dev-ruby/power_assert"
-
-all_ruby_prepare() {
- mv doc doc-install || die "moving doc directory out of the way failed"
-}
-
-each_ruby_test() {
- ${RUBY} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb-3 testrb-2
-}
diff --git a/dev-ruby/test-unit/test-unit-3.5.1.ebuild b/dev-ruby/test-unit/test-unit-3.5.1.ebuild
deleted file mode 100644
index 496be5175274..000000000000
--- a/dev-ruby/test-unit/test-unit-3.5.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.md doc-install/text/*.md"
-
-RUBY_FAKEGEM_GEMSPEC="test-unit.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An xUnit family unit testing framework for Ruby"
-HOMEPAGE="https://rubygems.org/gems/test-unit"
-SRC_URI="https://github.com/test-unit/test-unit/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Ruby GPL-2 ) PSF-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend "dev-ruby/power_assert"
-
-all_ruby_prepare() {
- mv doc doc-install || die "moving doc directory out of the way failed"
-}
-
-each_ruby_test() {
- ${RUBY} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb-3 testrb-2
-}
diff --git a/dev-ruby/test-unit/test-unit-3.5.2.ebuild b/dev-ruby/test-unit/test-unit-3.5.2.ebuild
deleted file mode 100644
index 496be5175274..000000000000
--- a/dev-ruby/test-unit/test-unit-3.5.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.md doc-install/text/*.md"
-
-RUBY_FAKEGEM_GEMSPEC="test-unit.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An xUnit family unit testing framework for Ruby"
-HOMEPAGE="https://rubygems.org/gems/test-unit"
-SRC_URI="https://github.com/test-unit/test-unit/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Ruby GPL-2 ) PSF-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend "dev-ruby/power_assert"
-
-all_ruby_prepare() {
- mv doc doc-install || die "moving doc directory out of the way failed"
-}
-
-each_ruby_test() {
- ${RUBY} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb-3 testrb-2
-}