summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/R/Manifest1
-rw-r--r--dev-lang/R/R-4.2.3.ebuild248
-rw-r--r--dev-lang/R/files/R-4.2.2-browser-pdf-prefs.patch95
-rw-r--r--dev-lang/R/files/R-4.2.2-isspace-without-readline.patch22
-rw-r--r--dev-lang/R/files/R-4.2.2-parallel-rmath-h-install.patch23
-rw-r--r--dev-lang/R/files/R-4.2.3-curl-8.patch59
6 files changed, 0 insertions, 448 deletions
diff --git a/dev-lang/R/Manifest b/dev-lang/R/Manifest
index 66ca1dcf1a07..92c9fed1a39b 100644
--- a/dev-lang/R/Manifest
+++ b/dev-lang/R/Manifest
@@ -1,3 +1,2 @@
-DIST R-4.2.3.tar.gz 34010655 BLAKE2B 688403c693de348bdc404c0ebc2df08d3415db216f6017beca8c0408dc70830239ba26ff89f020a249c8af6471363ed742f52c816da84aac8161ec4a522df405 SHA512 060bb4e1d1f1a5a0383a3b4372ac9247c0a20285020da17cebeb40ddc54da12d5f369ea243ea04d2c6970986fe22b3f9c37fbdfb3405cd8aa4f2353091ea9c5c
DIST R-4.3.0.tar.gz 34821768 BLAKE2B 3505c8357419355fddb8aadbf0952c492e3e38d649d6261478d6187c94ff71110089ec0933a31dd2f7258e58a1d0864a68cb4d7b6cdefc54e5add55d0d62db10 SHA512 7f9bc8360818d7fdf05e26a4213df01468669514a4c2ad62dee358f53dcfa05a71ee72241db91fed59574c26d7caee5d3e0717637e1666daec99446e42c07813
DIST R-78d6830e28ea90a046da79a9b4f70c39594bb6d6.bash_completion 13596 BLAKE2B 53338e4a1c4f68beb69247216e553dbcac47f660fbf032bfebf7a660e32d2cff5b11ed35411c52de7e1fd6e00bbf5b5ea19369a325fa0a38bd93d63dc3288cbd SHA512 9ccd19bb1b0c18a2f13035ccd6809447429e197e298fb4d1df808ef345d723b42f75a1b91c349f6dbb46e4a82e59ef33e11300c495d79b63d670d0c0f2b16a06
diff --git a/dev-lang/R/R-4.2.3.ebuild b/dev-lang/R/R-4.2.3.ebuild
deleted file mode 100644
index 9f94b563f46b..000000000000
--- a/dev-lang/R/R-4.2.3.ebuild
+++ /dev/null
@@ -1,248 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 autotools flag-o-matic fortran-2 toolchain-funcs
-
-# latest git commit for R bash completion:
-# https://github.com/deepayan/rcompletion
-BCPV=78d6830e28ea90a046da79a9b4f70c39594bb6d6
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="https://www.r-project.org/"
-SRC_URI="
- mirror://cran/src/base/R-4/${P}.tar.gz
- https://raw.githubusercontent.com/deepayan/rcompletion/${BCPV}/bash_completion/R -> ${PN}-${BCPV}.bash_completion"
-
-LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~hppa ~ia64 ~loong sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="cairo doc icu java jpeg lapack lto minimal nls openmp perl png prefix profile readline test tiff tk X"
-
-REQUIRED_USE="
- png? ( || ( cairo X ) )
- jpeg? ( || ( cairo X ) )
- tiff? ( || ( cairo X ) )"
-RESTRICT="
- minimal? ( test )
- !test? ( test )"
-
-# At least one package installation in the test suite requires TeX,
-# and will fail without it (bug #718056).
-DEPEND="
- app-arch/bzip2
- app-arch/xz-utils
- app-text/ghostscript-gpl
- dev-libs/libpcre2:=
- >=dev-libs/tre-0.8.0_p20210321[approx]
- net-misc/curl
- virtual/blas
- sys-libs/zlib[minizip]
- || (
- sys-apps/coreutils
- app-misc/realpath
- )
- cairo? (
- x11-libs/cairo:=[X=]
- x11-libs/pango:=
- )
- icu? ( dev-libs/icu:= )
- jpeg? ( media-libs/libjpeg-turbo:= )
- kernel_linux? ( net-libs/libtirpc )
- lapack? ( virtual/lapack )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng:= )
- readline? ( sys-libs/readline:= )
- tiff? ( media-libs/tiff:= )
- tk? ( dev-lang/tk:= )
- X? (
- x11-libs/libXmu
- x11-libs/libXt
- )"
-RDEPEND="${DEPEND}
- java? ( >=virtual/jre-1.8:* )"
-BDEPEND="
- virtual/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )
- test? ( virtual/latex-base )"
-
-PATCHES=(
- "${FILESDIR}"/R-3.4.1-parallel.patch
- "${FILESDIR}"/R-3.6.2-no-LDFLAGS-in-libR-pkg-config.patch
- "${FILESDIR}"/R-3.6.2-no-gzip-doc.patch
- "${FILESDIR}"/R-4.2.2-browser-pdf-prefs.patch
- "${FILESDIR}"/R-4.2.2-isspace-without-readline.patch
- "${FILESDIR}"/R-4.2.2-parallel-rmath-h-install.patch
- "${FILESDIR}"/R-4.2.3-curl-8.patch
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- tc-check-openmp
- FORTRAN_NEED_OPENMP=1
- fi
-
- fortran-2_pkg_setup
-
- # avoid using existing R installation
- unset R_HOME
-}
-
-src_prepare() {
- default
-
- # fix packages.html for doc (gentoo bug #205103)
- sed -e "s:../../../library:../../../../$(get_libdir)/R/library:g" \
- -i src/library/tools/R/Rd.R || die
-
- # fix Rscript path when installed (gentoo bug #221061)
- sed -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${EPREFIX}/usr/$(get_libdir)/${PN}\"':" \
- -i src/unix/Makefile.in || die "sed unix Makefile failed"
-
- # fix HTML links to manual (gentoo bug #273957)
- sed -e 's:\.\./manual/:manual/:g' \
- -i $(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
-
- use lapack &&
- export LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
-
- use perl &&
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
-
- # don't search /usr/local
- sed -i -e '/FLAGS=.*\/local\//c\: # removed by ebuild' configure.ac || die
-
- # Fix for Darwin (macOS)
- if use prefix; then
- if [[ ${CHOST} == *-darwin* ]] ; then
- sed -e 's:-install_name libR.dylib:-install_name ${libdir}/R/lib/libR.dylib:' \
- -e 's:-install_name libRlapack.dylib:-install_name ${libdir}/R/lib/libRlapack.dylib:' \
- -e 's:-install_name libRblas.dylib:-install_name ${libdir}/R/lib/libRblas.dylib:' \
- -e "/SHLIB_EXT/s/\.so/.dylib/" \
- -i configure.ac || die
- # sort of "undo" 2.14.1-rmath-shared.patch
- sed -e "s:-Wl,-soname=libRmath.so:-install_name ${EPREFIX}/usr/$(get_libdir)/libRmath.dylib:" \
- -i src/nmath/standalone/Makefile.in || die
- else
- append-ldflags -Wl,-rpath="${EPREFIX}/usr/$(get_libdir)/R/lib"
- fi
- fi
-
- AT_M4DIR=m4 eautoreconf
-}
-
-src_configure() {
- filter-ldflags -Wl,-Bdirect -Bdirect
-
- econf \
- --enable-byte-compiled-packages \
- --enable-R-shlib \
- --disable-R-framework \
- --disable-R-static-lib \
- --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
- rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
- --with-system-tre \
- $(use_enable java) \
- $(use_enable lto lto R) \
- $(use_enable nls) \
- $(use_enable openmp) \
- $(use_enable profile R-profiling) \
- $(use_enable profile memory-profiling) \
- $(use_with cairo) \
- $(use_with icu ICU) \
- $(use_with jpeg jpeglib) \
- $(use_with lapack) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with tiff libtiff) \
- $(use_with tk tcltk) \
- $(use_with tk tk-config "${ESYSROOT}"/usr/$(get_libdir)/tkConfig.sh) \
- $(use_with tk tcl-config "${ESYSROOT}"/usr/$(get_libdir)/tclConfig.sh) \
- $(use_with X x)
-}
-
-src_compile() {
- export VARTEXFONTS="${T}"/fonts
- emake AR="$(tc-getAR)"
- emake -C src/nmath/standalone shared AR="$(tc-getAR)"
- use doc && emake info pdf
-}
-
-src_install() {
- default
- emake -C src/nmath/standalone DESTDIR="${D}" install
-
- if use doc; then
- emake DESTDIR="${D}" install-info install-pdf
- dosym ../manual /usr/share/doc/${PF}/html/manual
- fi
-
- newenvd - 99R <<-_EOF_
- LDPATH="${EPREFIX}/usr/$(get_libdir)/${PN}/lib"
- R_HOME="${EPREFIX}/usr/$(get_libdir)/${PN}"
- _EOF_
-
- newbashcomp "${DISTDIR}"/${PN}-${BCPV}.bash_completion ${PN}
- # The buildsystem has a different understanding of install_names than
- # we require. Since it builds modules like shared objects (wrong), many
- # objects (all modules) get an incorrect install_name. Fixing the build
- # system here is not really trivial.
- if [[ ${CHOST} == *-darwin* ]] ; then
- local mod
- pushd "${ED}"/usr/$(get_libdir)/R >/dev/null || die
- for mod in $(find . -name "*.dylib") ; do
- mod=${mod#./}
- install_name_tool -id "${EPREFIX}/usr/$(get_libdir)/R/${mod}" "${mod}"
- done
- popd >/dev/null || die
- fi
-
- # Users are encouraged to access some of the the R documentation
- # interactively, through functions like "contributors()" that
- # tries to open the "AUTHORS" file. Other files can be accessed
- # by name with RShowDoc(), and the documentation for e.g. license()
- # and RShowDoc() suggests a few of these names. Here we try to
- # collect as many names as possible that a user might actually
- # try to view through R, because if we don't decompress them,
- # then R doesn't know what to do with 'em. Bug #556706.
- local INTERACTIVE_DOCS=(
- AUTHORS
- COPYING
- FAQ
- NEWS
- THANKS
- )
-
- # Other data sources that are shipped as "documentation," but which
- # need to be accessible via their original unmolested filenames.
- local INTERACTIVE_DATA=(
- BioC_mirrors.csv
- CRAN_mirrors.csv
- KEYWORDS.db
- NEWS.rds
- )
-
- local f NOCOMPRESS_DOCS=( "${INTERACTIVE_DOCS[@]}" "${INTERACTIVE_DATA[@]}" )
- for f in "${NOCOMPRESS_DOCS[@]}"; do
- docompress -x /usr/share/doc/${PF}/${f}
- done
-
- # Finally, an extra copy of this started showing up at some point...
- rm "${ED}"/usr/$(get_libdir)/R/COPYING || die
-}
-
-pkg_postinst() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/files/R-4.2.2-browser-pdf-prefs.patch b/dev-lang/R/files/R-4.2.2-browser-pdf-prefs.patch
deleted file mode 100644
index b5a953cb6057..000000000000
--- a/dev-lang/R/files/R-4.2.2-browser-pdf-prefs.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-From 6e48ab8b5006f3fdd8ef08f3f86406a02eabdc80 Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Mon, 12 Sep 2022 08:31:46 -0400
-Subject: [PATCH 1/3] m4/R.m4: prefer xdg-open for R_BROWSER and R_PDFVIEWER.
-
-The xdg-open utility (if it is present) will launch the user's
-preferred browsr or PDF viewer when fed an HTML page or a PDF
-document, respectively. It therefore makes sense to prefer it over
-(for example) firefox, which may be installed but not the user's
-preferred browser.
----
- m4/R.m4 | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/m4/R.m4 b/m4/R.m4
-index bdcfbea..c5052e7 100644
---- a/m4/R.m4
-+++ b/m4/R.m4
-@@ -237,7 +237,7 @@ fi])
- ## xdg-open is the freedesktop.org interface to kfmclient/gnome-open
- AC_DEFUN([R_PROG_BROWSER],
- [if test -z "${R_BROWSER}"; then
-- AC_PATH_PROGS(R_BROWSER, [firefox mozilla galeon opera xdg-open kfmclient gnome-moz-remote open])
-+ AC_PATH_PROGS(R_BROWSER, [xdg-open firefox mozilla galeon opera kfmclient gnome-moz-remote open])
- fi
- if test -z "${R_BROWSER}"; then
- warn_browser="I could not determine a browser"
-@@ -255,7 +255,7 @@ AC_SUBST(R_BROWSER)
- ## the FreeBSD acroread port.
- AC_DEFUN([R_PROG_PDFVIEWER],
- [AC_PATH_PROGS(R_PDFVIEWER,
-- [${R_PDFVIEWER} acroread acroread4 xdg-open evince xpdf gv gnome-gv ggv okular kpdf open gpdf kghostview])
-+ [${R_PDFVIEWER} xdg-open acroread acroread4 evince xpdf gv gnome-gv ggv okular kpdf open gpdf kghostview])
- if test -z "${R_PDFVIEWER}"; then
- warn_pdfviewer="I could not determine a PDF viewer"
- AC_MSG_WARN([${warn_pdfviewer}])
---
-2.35.1
-
-From 4e50ed9c976a4422a6d431d3d078164948f26bda Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Mon, 12 Sep 2022 08:36:41 -0400
-Subject: [PATCH 2/3] m4/R.m4: add epiphany, lynx, and links to the R_BROWSER
- search list.
-
-The epiphany browser is today one of the more popular ones, being the
-"official" GNOME browser. And lynx and links are nice text-based
-fallbacks.
----
- m4/R.m4 | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/m4/R.m4 b/m4/R.m4
-index c5052e7..e99b0f9 100644
---- a/m4/R.m4
-+++ b/m4/R.m4
-@@ -237,7 +237,7 @@ fi])
- ## xdg-open is the freedesktop.org interface to kfmclient/gnome-open
- AC_DEFUN([R_PROG_BROWSER],
- [if test -z "${R_BROWSER}"; then
-- AC_PATH_PROGS(R_BROWSER, [xdg-open firefox mozilla galeon opera kfmclient gnome-moz-remote open])
-+ AC_PATH_PROGS(R_BROWSER, [xdg-open firefox mozilla epiphany galeon opera kfmclient gnome-moz-remote open lynx links])
- fi
- if test -z "${R_BROWSER}"; then
- warn_browser="I could not determine a browser"
---
-2.35.1
-
-From 719294ed2548f79ab6a5861662716d853284f4d7 Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Mon, 12 Sep 2022 08:38:03 -0400
-Subject: [PATCH 3/3] m4/R.m4: add atril to the R_PDFVIEWER list.
-
-Atril is the PDF viewer for the MATE desktop, essentially a fork of
-the gnome-2.x evince viewer.
----
- m4/R.m4 | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/m4/R.m4 b/m4/R.m4
-index e99b0f9..7e04ced 100644
---- a/m4/R.m4
-+++ b/m4/R.m4
-@@ -255,7 +255,7 @@ AC_SUBST(R_BROWSER)
- ## the FreeBSD acroread port.
- AC_DEFUN([R_PROG_PDFVIEWER],
- [AC_PATH_PROGS(R_PDFVIEWER,
-- [${R_PDFVIEWER} xdg-open acroread acroread4 evince xpdf gv gnome-gv ggv okular kpdf open gpdf kghostview])
-+ [${R_PDFVIEWER} xdg-open acroread acroread4 evince atril xpdf gv gnome-gv ggv okular kpdf open gpdf kghostview])
- if test -z "${R_PDFVIEWER}"; then
- warn_pdfviewer="I could not determine a PDF viewer"
- AC_MSG_WARN([${warn_pdfviewer}])
---
-2.35.1
-
diff --git a/dev-lang/R/files/R-4.2.2-isspace-without-readline.patch b/dev-lang/R/files/R-4.2.2-isspace-without-readline.patch
deleted file mode 100644
index 0b32bef1352b..000000000000
--- a/dev-lang/R/files/R-4.2.2-isspace-without-readline.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 6e36141598b78add7fb841480260b0a57ae79330 Mon Sep 17 00:00:00 2001
-From: smeyer <smeyer@00db46b3-68df-0310-9c12-caf00c1e9a41>
-Date: Wed, 26 Oct 2022 08:22:41 +0000
-Subject: [PATCH] avoid implicit declaration of 'isspace' --without-readline
-
-git-svn-id: https://svn.r-project.org/R/trunk@83178 00db46b3-68df-0310-9c12-caf00c1e9a41
----
- src/unix/sys-std.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/unix/sys-std.c b/src/unix/sys-std.c
-index 7b93d63884a..f95ff0cf7b3 100644
---- a/src/unix/sys-std.c
-+++ b/src/unix/sys-std.c
-@@ -1339,6 +1339,7 @@ Rstd_ShowFiles(int nfile, /* number of files */
- */
-
-
-+#include <ctype.h> /* for isspace */
-
- int attribute_hidden Rstd_ChooseFile(int _new, char *buf, int len)
- {
diff --git a/dev-lang/R/files/R-4.2.2-parallel-rmath-h-install.patch b/dev-lang/R/files/R-4.2.2-parallel-rmath-h-install.patch
deleted file mode 100644
index 756ec8ff5428..000000000000
--- a/dev-lang/R/files/R-4.2.2-parallel-rmath-h-install.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From ee1428e77095e52a7396fa7b455f63b7c5b9495b Mon Sep 17 00:00:00 2001
-From: kalibera <kalibera@00db46b3-68df-0310-9c12-caf00c1e9a41>
-Date: Tue, 27 Dec 2022 11:21:33 +0000
-Subject: [PATCH] Declare dependency to ensure include dir exists (PR#17743).
-
-git-svn-id: https://svn.r-project.org/R/trunk@83504 00db46b3-68df-0310-9c12-caf00c1e9a41
----
- src/nmath/standalone/Makefile.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/nmath/standalone/Makefile.in b/src/nmath/standalone/Makefile.in
-index 68b45006155..946795a0439 100644
---- a/src/nmath/standalone/Makefile.in
-+++ b/src/nmath/standalone/Makefile.in
-@@ -151,7 +151,7 @@ install-strip: installdirs install-header install-pc
- fi
- @!(test -f libRmath.a) || $(SHELL) $(top_srcdir)/tools/copy-if-change libRmath.a $(DESTDIR)$(libdir)/libRmath.a
-
--install-header:
-+install-header: installdirs
- @(cd ../../include; $(MAKE) Rmath.h)
- @WANT_R_FRAMEWORK_FALSE@ @$(SHELL) $(top_srcdir)/tools/copy-if-change ../../include/Rmath.h $(DESTDIR)$(includedir)/Rmath.h
- @WANT_R_FRAMEWORK_TRUE@ @$(SHELL) $(top_srcdir)/tools/copy-if-change ../../include/Rmath.h $(R_FRAMEWORK_DIR)/Versions/$(FW_VERSION)/Resources/include/Rmath.h
diff --git a/dev-lang/R/files/R-4.2.3-curl-8.patch b/dev-lang/R/files/R-4.2.3-curl-8.patch
deleted file mode 100644
index 92ee3b0d5702..000000000000
--- a/dev-lang/R/files/R-4.2.3-curl-8.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-https://bugs.gentoo.org/902993
-
---- a/configure
-+++ b/configure
-@@ -48533,7 +48533,7 @@
- done
-
- if test "x${have_libcurl}" = "xyes"; then
--{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking if libcurl is version 7 and >= 7.28.0" >&5
-+{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking if libcurl is version 7 and >= 7.28.0 or version 8" >&5
- printf %s "checking if libcurl is version 7 and >= 7.28.0... " >&6; }
- if test ${r_cv_have_curl728+y}
- then :
-@@ -48551,8 +48551,10 @@
- int main(int argc, const char * argv[])
- {
- #ifdef LIBCURL_VERSION_MAJOR
--#if LIBCURL_VERSION_MAJOR > 7
-+#if LIBCURL_VERSION_MAJOR > 8
- exit(1);
-+#elif LIBCURL_VERSION_MAJOR == 8
-+ exit(0);
- #elif LIBCURL_VERSION_MAJOR == 7 && LIBCURL_VERSION_MINOR >= 28
- exit(0);
- #else
---- a/m4/R.m4
-+++ b/m4/R.m4
-@@ -4300,15 +4300,17 @@
- AC_CHECK_HEADERS(curl/curl.h, [have_libcurl=yes], [have_libcurl=no])
-
- if test "x${have_libcurl}" = "xyes"; then
--AC_CACHE_CHECK([if libcurl is version 7 and >= 7.28.0], [r_cv_have_curl728],
-+AC_CACHE_CHECK([if libcurl is version 7 and >= 7.28.0 or verion 8], [r_cv_have_curl728_8],
- [AC_RUN_IFELSE([AC_LANG_SOURCE([[
- #include <stdlib.h>
- #include <curl/curl.h>
- int main(int argc, const char * argv[])
- {
- #ifdef LIBCURL_VERSION_MAJOR
--#if LIBCURL_VERSION_MAJOR > 7
-+#if LIBCURL_VERSION_MAJOR > 8
- exit(1);
-+#elif LIBCURL_VERSION_MAJOR == 8
-+ exit(0);
- #elif LIBCURL_VERSION_MAJOR == 7 && LIBCURL_VERSION_MINOR >= 28
- exit(0);
- #else
-@@ -4318,9 +4320,9 @@
- exit(1);
- #endif
- }
--]])], [r_cv_have_curl728=yes], [r_cv_have_curl728=no], [r_cv_have_curl728=no])])
-+]])], [r_cv_have_curl728_8=yes], [r_cv_have_curl728_8=no], [r_cv_have_curl728_8=no])])
- fi
--if test "x${r_cv_have_curl728}" = xno; then
-+if test "x${r_cv_have_curl728_8}" = xno; then
- have_libcurl=no
- fi
-