summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest1
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index f8f12761fe71..a211a0320f5b 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1 +1,2 @@
DIST xfce4-panel-profiles-1.0.13.tar.bz2 86671 BLAKE2B 0bf2d39aa2d7d21a99a9a7245e5de9e717b628f0eded2736db70cc87c4f6e1e1d10aecdc6586c43c6355747e68a2ceb1920d5309bf38ede07c1167c590dc116f SHA512 648324e5dd95ab0a513829d7d816e2113ae677d9ad6ac9b01d73c6b4105b54d5e773150d5440ad35a37b4dc75478f40a24e0223decf940f3cf658241547ce75a
+DIST xfce4-panel-profiles-1.0.14.tar.bz2 101521 BLAKE2B 197ebba356e8d7661779531147b08454762a9b61beebd2323bc9e88b26381952c2caa58c6fb110680a5038fc19422852722d72dfde09addb68ec9424ecf16a23 SHA512 e316e9d4f0d27b16ce83a50adfe1a3fe2102b7f5c3ed9e9ceebf5968e265064b4d4ade1e0dbd84180758a9c1fa72d8df1fb4d06a631d07956ea8add0f66da984
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
new file mode 100644
index 000000000000..f7ba0bc11386
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-panel-profiles/start
+ https://gitlab.xfce.org/apps/xfce4-panel-profiles/
+"
+SRC_URI="
+ https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${BDEPEND}
+ dev-libs/gobject-introspection
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ xfce-base/libxfce4ui[introspection]
+ xfce-base/xfce4-panel
+"
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --python="${EPYTHON}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}