summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.0.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 500cb312d2be..823b07fa3f66 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-2.0.0.tar.gz 148326 BLAKE2B ea9e3fbe404dedd7e7290743da4dfe51196beaa7db7ce69ad47316c70afe044cbf3e32666d32786e0d68f225cc6d552b7bb5c79fc62132c6fbee502868d3a205 SHA512 cf2cda96cdbc8f1abc20f969355a9c07698c7c13d826482170f7114962cc683b3c9b8a39aa19b76b6ae1e6c6e8875407bb9fa04908a0b22c96d0b3cbd234fe0b
+DIST pyscard-2.0.1.tar.gz 149193 BLAKE2B f140e3e62635634de8125d88c69e4ac3657468eef04798b4ce5b20d73905189ced71f041ef7742233a185aff8b28cc0fcda5af175d6dff21afeff84f062afcce SHA512 c9292b9616f150e500b308c47b0d6ed6f869f2022149c99a7789f8fef8c145dec4db84d35b6df30fa31d4007dffff75fcc21c9846693eccd9bd3bc8ec77fce5a
diff --git a/dev-python/pyscard/pyscard-2.0.1.ebuild b/dev-python/pyscard/pyscard-2.0.1.ebuild
new file mode 100644
index 000000000000..f40381afb5e8
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig"
+
+distutils_enable_tests setup.py
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/pyro
+}