summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ocaml-ipaddr/Manifest1
-rw-r--r--dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.7.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ipaddr/Manifest b/dev-ml/ocaml-ipaddr/Manifest
index d6750d89d230..29172d5afbc7 100644
--- a/dev-ml/ocaml-ipaddr/Manifest
+++ b/dev-ml/ocaml-ipaddr/Manifest
@@ -1 +1,2 @@
DIST ocaml-ipaddr-2.7.1.tar.gz 23652 SHA256 0d1d5fe983ff02ed09a0f03e5f1048c575d621599b42b5685d56f4da61186888 SHA512 9f640f10614666f3a7cc578e934b0424c1d6fdcdd2dc5620f4a8b4fa7799a07fdd7c4bbe4e91c4899d45612ce8d2d4cafc8bcd19e51253c6da5d12c504820903 WHIRLPOOL 5be5846d98fbec95c5d3ba47c3b59bbdd3c44e41d04270d0b0ca2331eb7e6aac3d79c4833bf8dd20edb2d0c9f03b3bc72c53f12e0d27fb9980bcf73dea2c17f4
+DIST ocaml-ipaddr-2.7.2.tar.gz 23698 SHA256 2dc1dc07bb62fe43382181a13f33b7ff1c0dbbeb6b591b7ab17ea32c7be0d256 SHA512 fe477bcdae82f6a259d99cb4191f942ba7a38d11c575fcaa92c2973c9cd0b3b2b008a1efdca73e11d94f892be2f84547c386bbfca95cfa78d2fefd83d77ca876 WHIRLPOOL bca829ebf37d6275631dea24b3264ec5103a625366e9357851068d90fd9fd6e7de6ad930638fa9acbc19f446a9e74cc2eaf8083f62114d3ea8680e8039f1e936
diff --git a/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.7.2.ebuild b/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.7.2.ebuild
new file mode 100644
index 000000000000..fbb8988eb0e7
--- /dev/null
+++ b/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.7.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="OCaml library for manipulation of IP (and MAC) address representations"
+HOMEPAGE="https://github.com/mirage/ocaml-ipaddr"
+SRC_URI="https://github.com/mirage/ocaml-ipaddr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+RDEPEND="dev-ml/sexplib:=
+ dev-ml/ppx_sexp_conv:=
+ dev-lang/ocaml:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+ dev-ml/topkg
+ dev-ml/findlib
+ test? ( dev-ml/ounit )
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test "true" "false") || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ipaddr.install || die
+ dodoc CHANGES.md README.md
+}