summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild b/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild
index b6e871b2aee4..f570cba32eb2 100644
--- a/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild
+++ b/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -11,8 +10,7 @@ MY_P=${P/-/_}
DESCRIPTION="Easy-to-use Python module for text parsing"
HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
-# pypi releases and generated github tarballs lack tests
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+S=${WORKDIR}/${PN}-${MY_P}
LICENSE="MIT"
SLOT="0"
@@ -21,8 +19,6 @@ IUSE="examples"
distutils_enable_tests setup.py
-S=${WORKDIR}/${PN}-${MY_P}
-
python_install_all() {
if use examples; then
docompress -x /usr/share/doc/${PF}/examples