summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2022.11.11.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 6332bcded6a5..afb26369f9e8 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2022.10.4.tar.gz 2427017 BLAKE2B b3dfde252217ef7ed9f5b99351e956a1f30bfe7bf545e28bb262db90dc9b9cb5e44af7259a815f84cd4e821c8ae93f6372e9a5108483208cd8dec403cf194790 SHA512 286e219057505e4de2bb8af6dc334b43b4e46e7b998d98437f78e9cfa82294e2ac17432c22f741ad101dfe05fa0d2dc0111904be51f32ab3a002bda7b17a86b7
+DIST yt-dlp-2022.11.11.tar.gz 2470530 BLAKE2B 0d453d08678cccffccd7e4639fd66d08bead30d0cfae6f5a09d46d2a79a03a24b84b7c27d28a1f4b3bb03fdb96b8f9734e7f9910d02b9cd4a04bacdc3ff2c705 SHA512 be29154746f4c499eb25489be45ea759bf83f7aeb086a2a0e90a2bee6936c0d9362b1cd7af5eebed4f01f84a3542a9d5fa5746b647c349cad2e26b45cf4a861b
diff --git a/net-misc/yt-dlp/yt-dlp-2022.11.11.ebuild b/net-misc/yt-dlp/yt-dlp-2022.11.11.ebuild
new file mode 100644
index 000000000000..775abf17078d
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2022.11.11.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}