summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/wai-extra/Manifest1
-rw-r--r--dev-haskell/wai-extra/wai-extra-3.1.4.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-haskell/wai-extra/Manifest b/dev-haskell/wai-extra/Manifest
index 098458f7b5dc..0386b946363c 100644
--- a/dev-haskell/wai-extra/Manifest
+++ b/dev-haskell/wai-extra/Manifest
@@ -1 +1,2 @@
DIST wai-extra-3.0.31.tar.gz 63975 BLAKE2B e705142e48bac00d13d9ec42ecc02a646a081e69a5996794db34bea77b193dccfe9de2f9b89518b234adf226cfc79765c1d8eabcf7c990494e0d206f6a8de080 SHA512 71635f9acc44ffd19b76d7f1a5e43fa079dffe6e447be1c9df4b491cf96c226346788eb773923cf702d44d4620f2a5e7478be1c625b4c2332b9bed7e6e5391d2
+DIST wai-extra-3.1.4.1.tar.gz 67063 BLAKE2B d75f1425cf4c75596adb65c152c954a6005b085f3a290d7dea279a4417d85e359f6948fc8282cee63f2057b4dfe3e33b7a364667544c925582024e4255e71462 SHA512 c33b513bd6e627361007f285167235535ac4065e7198749c14d05cfcd89c5017b54896064c64ffdda9875d6363b684b9beed4098fdbefaba1058045ba3245af5
diff --git a/dev-haskell/wai-extra/wai-extra-3.1.4.1.ebuild b/dev-haskell/wai-extra/wai-extra-3.1.4.1.ebuild
new file mode 100644
index 000000000000..c923228ad142
--- /dev/null
+++ b/dev-haskell/wai-extra/wai-extra-3.1.4.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: build-example:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Provides some basic WAI handlers and middleware"
+HOMEPAGE="https://github.com/yesodweb/wai"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/ansi-terminal:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ dev-haskell/call-stack:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/fast-logger-2.4.5:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ dev-haskell/http2:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/iproute:=[profile?]
+ >=dev-haskell/network-2.6.1.0:=[profile?]
+ >=dev-haskell/old-locale-1.0.0.2:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/resourcet-0.4.6:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ >=dev-haskell/streaming-commons-0.2:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/vault:=[profile?]
+ >=dev-haskell/void-0.5:=[profile?]
+ >=dev-haskell/wai-3.0.3.0:=[profile?] <dev-haskell/wai-3.3:=[profile?]
+ >=dev-haskell/wai-logger-2.3.2:=[profile?]
+ dev-haskell/word8:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-8.2.1:=
+ examples? ( dev-haskell/warp:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0.0.2
+ test? ( >=dev-haskell/hspec-1.3 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples build-example)
+}