summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/deprecated/Manifest1
-rw-r--r--dev-python/deprecated/deprecated-1.2.10.ebuild23
-rw-r--r--dev-python/deprecated/files/deprecated-1.2.10-py39.patch57
3 files changed, 0 insertions, 81 deletions
diff --git a/dev-python/deprecated/Manifest b/dev-python/deprecated/Manifest
index 7c981b680703..8913bac94ff7 100644
--- a/dev-python/deprecated/Manifest
+++ b/dev-python/deprecated/Manifest
@@ -1,2 +1 @@
-DIST deprecated-1.2.10.gh.tar.gz 2967353 BLAKE2B 941fa81dd27940be4fde1219a9fe127777354aa2054b15178cade4a859b01f8dff426e0da8161bac580ff6446b44767f3207b474bb5f555826239db039085497 SHA512 4bd53b759d04ab15c74a4c147b2c69c73aed6e40555acf0e84cf0c5b7ffe248da234bd1311c5629f9357d50bc08e55e81363340dcfdabe88933525bcc7859a70
DIST deprecated-1.2.11.gh.tar.gz 2968469 BLAKE2B 5b1b8872e8786897a51ff96a659ceef0deed81b3cf02edc1f69b6ee504a3c4510621b56678dd28fa795231dfe8481daf3a77bb151ee117fe0541af1983412548 SHA512 343f62a7a658569de885ac923a1de7f7b4cc5bf63d27d1b13474795ca38cc52932e35133b45d05c1b42d498af56f5945fad5c49b3cbdebda70337294da5d84c4
diff --git a/dev-python/deprecated/deprecated-1.2.10.ebuild b/dev-python/deprecated/deprecated-1.2.10.ebuild
deleted file mode 100644
index d9befb9fe1a2..000000000000
--- a/dev-python/deprecated/deprecated-1.2.10.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Python @deprecated decorator to deprecate old API"
-HOMEPAGE="https://github.com/tantale/deprecated"
-SRC_URI="https://github.com/tantale/deprecated/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/wrapt[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-py39.patch
-)
diff --git a/dev-python/deprecated/files/deprecated-1.2.10-py39.patch b/dev-python/deprecated/files/deprecated-1.2.10-py39.patch
deleted file mode 100644
index 42ab81445b7a..000000000000
--- a/dev-python/deprecated/files/deprecated-1.2.10-py39.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 629e7b702ede03262afeb86cd7a6d42d739504d2 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 30 May 2020 09:30:58 +0200
-Subject: [PATCH] Update expected class method deprecation msgs in tests for
- py3.9
-
-Python 3.9 has fixed @classmethod combining with other decorators,
-making deprecated correctly report 'class method' (instead of function
-or static method). Update the tests to account for that.
-
-Fixes #29
----
- tests/test_deprecated.py | 6 +++++-
- tests/test_sphinx.py | 5 ++++-
- 2 files changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/tests/test_deprecated.py b/tests/test_deprecated.py
-index 3796640..e4c00ef 100644
---- a/tests/test_deprecated.py
-+++ b/tests/test_deprecated.py
-@@ -1,4 +1,5 @@
- # -*- coding: utf-8 -*-
-+import sys
- import warnings
-
- import pytest
-@@ -184,7 +185,10 @@ def test_classic_deprecated_class_method__warns(classic_deprecated_class_method)
- assert len(warns) == 1
- warn = warns[0]
- assert issubclass(warn.category, DeprecationWarning)
-- assert "deprecated function (or staticmethod)" in str(warn.message)
-+ if sys.version_info >= (3, 9):
-+ assert "deprecated class method" in str(warn.message)
-+ else:
-+ assert "deprecated function (or staticmethod)" in str(warn.message)
- assert warn.filename == __file__, 'Incorrect warning stackLevel'
-
-
-diff --git a/tests/test_sphinx.py b/tests/test_sphinx.py
-index 42f2460..efc8628 100644
---- a/tests/test_sphinx.py
-+++ b/tests/test_sphinx.py
-@@ -334,7 +334,10 @@ def test_sphinx_deprecated_class_method__warns(sphinx_deprecated_class_method):
- assert len(warns) == 1
- warn = warns[0]
- assert issubclass(warn.category, DeprecationWarning)
-- assert "deprecated function (or staticmethod)" in str(warn.message)
-+ if sys.version_info >= (3, 9):
-+ assert "deprecated class method" in str(warn.message)
-+ else:
-+ assert "deprecated function (or staticmethod)" in str(warn.message)
-
-
- def test_should_raise_type_error():
---
-2.26.2
-