summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/bino/bino-1.6.8.ebuild10
-rw-r--r--media-video/bino/files/bino-1.6.8-respect-AR.patch22
2 files changed, 31 insertions, 1 deletions
diff --git a/media-video/bino/bino-1.6.8.ebuild b/media-video/bino/bino-1.6.8.ebuild
index f0f6a54eb8d1..b304712373c8 100644
--- a/media-video/bino/bino-1.6.8.ebuild
+++ b/media-video/bino/bino-1.6.8.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils xdg
+inherit autotools flag-o-matic qmake-utils xdg
DESCRIPTION="Stereoscopic and multi-display media player"
HOMEPAGE="https://bino3d.org/"
@@ -32,8 +32,16 @@ BDEPEND="sys-devel/gettext
PATCHES=(
"${FILESDIR}"/${PN}-1.6.8-time-include.patch
+ "${FILESDIR}"/${PN}-1.6.8-respect-AR.patch
)
+src_prepare() {
+ default
+
+ # Needed for AR patch
+ eautoreconf
+}
+
src_configure() {
if use video_cards_nvidia; then
append-cppflags "-I${ESYSROOT}/usr/include/NVCtrl"
diff --git a/media-video/bino/files/bino-1.6.8-respect-AR.patch b/media-video/bino/files/bino-1.6.8-respect-AR.patch
new file mode 100644
index 000000000000..b4f9177affe1
--- /dev/null
+++ b/media-video/bino/files/bino-1.6.8-respect-AR.patch
@@ -0,0 +1,22 @@
+Sent upstream by email on 2022-09-02.
+
+From 66399974bec4cc3b9c7570b222bc778078f5dc7f Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 2 Sep 2022 02:04:00 +0100
+Subject: [PATCH 1/2] build: respect AR
+
+Search for AR using the normal mechanisms like e.g. CC
+to allow it to be easily overridden in the environment.
+
+Bug: https://bugs.gentoo.org/804486
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,6 +38,7 @@ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_RANLIB
+ AC_PROG_LN_S
++AM_PROG_AR
+ AC_LANG([C++])
+ AC_C_BIGENDIAN
+