summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/nagiosplugin/Manifest1
-rw-r--r--dev-python/nagiosplugin/metadata.xml13
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/nagiosplugin/Manifest b/dev-python/nagiosplugin/Manifest
new file mode 100644
index 000000000000..b018c5dd24bb
--- /dev/null
+++ b/dev-python/nagiosplugin/Manifest
@@ -0,0 +1 @@
+DIST nagiosplugin-1.2.3.tar.gz 37570 SHA256 9a1729d6479b71b1c7184e88a6214b00133953921df1be2d14ccb35a94a3c8dd SHA512 3f3045db181acc144cb41871f2f67090a7b096d600c9cda7e4f9b86648d47319dca7c42b74670ba307c0bc60955eb33aefcde9c895e544bbb4c7ca1f80e8919d WHIRLPOOL 2482a04ba7280973e9c4f8faedc4c54ca193bd1ff3d37c608dc4018dc2e39dd719e43edac7393c9102436ff8f5dacbeaa3df32c9523924aa6474ca20cdc83445
diff --git a/dev-python/nagiosplugin/metadata.xml b/dev-python/nagiosplugin/metadata.xml
new file mode 100644
index 000000000000..f5bafd539d7c
--- /dev/null
+++ b/dev-python/nagiosplugin/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">nagiosplugin</remote-id>
+ <remote-id type="bitbucket">flyingcircus/nagiosplugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild
new file mode 100644
index 000000000000..9359a4076a4d
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://bitbucket.org/flyingcircus/nagiosplugin/ https://pypi.python.org/pypi/nagiosplugin/"
+if [[ ${PV} == "9999" ]] ; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/flyingcircus/nagiosplugin/"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ZPL"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"