summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/sanlock/Manifest1
-rw-r--r--sys-cluster/sanlock/sanlock-3.8.2.ebuild95
2 files changed, 0 insertions, 96 deletions
diff --git a/sys-cluster/sanlock/Manifest b/sys-cluster/sanlock/Manifest
index 03cac489babf..27b197157c2d 100644
--- a/sys-cluster/sanlock/Manifest
+++ b/sys-cluster/sanlock/Manifest
@@ -1,2 +1 @@
-DIST sanlock-3.8.2.tar.gz 266780 BLAKE2B 5248d08225bcc2a19594a3dcd3872c8c69ca8b217d31f6263f2717e4594180d4ba4685c9679ce2f31b6a2dcb4fe9f3e6a5dd5ac3ed073aea02599e7bbc04390c SHA512 2fa92e16eee4d2f3dac452400522f7e90b93b71349d322564d5957e2d87fb4bd69f0b5617b05f4b296c272d6da9a404fccadbbfff106354a0e302c436593eaac
DIST sanlock-3.8.4.tar.gz 270031 BLAKE2B da011a15d488849d47fe1043df040580652558918dff9549bf4e6cb4077c03b4aaa8f8de5399dbb0e3f2301ae90c0d20599b25bd5e72bae5317b13f79a352333 SHA512 9fca2b18fd3bd504d5186de0b2626ea2c993997528de2384dc042afe52b2b68422a2e4bb79e2409c9e6eccbe5ea8d8939549eb25c5d16aa7fecf6c9a5798340c
diff --git a/sys-cluster/sanlock/sanlock-3.8.2.ebuild b/sys-cluster/sanlock/sanlock-3.8.2.ebuild
deleted file mode 100644
index 86fc96a44877..000000000000
--- a/sys-cluster/sanlock/sanlock-3.8.2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit linux-info python-r1 systemd
-
-DESCRIPTION="shared storage lock manager"
-HOMEPAGE="https://pagure.io/sanlock"
-SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2+ GPL-2 GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ~ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="
- acct-user/${PN}
- acct-group/${PN}
- dev-libs/libaio
- sys-apps/util-linux
- python? ( ${PYTHON_DEPS} )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/sanlock-fence_sanlock-LDFLAGS.patch
-)
-
-pkg_setup() {
- local warning="You need to have CONFIG_SOFT_WATCHDOG enabled in your kernel for wdmd"
- if linux_config_exists; then
- if ! linux_chkconfig_present SOFT_WATCHDOG; then
- ewarn ""
- ewarn "${warning}"
- ewarn ""
- fi
- else
- ewarn ""
- ewarn "Could not be checked automatically: $warning"
- ewarn ""
- fi
-}
-
-src_compile() {
- for d in wdmd src fence_sanlock reset; do
- cd ${d} || die
- emake
- cd .. || die
- done
-
- if use python; then
- cd python || die
- python_foreach_impl emake
- cd .. || die
- fi
-}
-
-src_install() {
- for d in wdmd src fence_sanlock reset; do
- cd ${d} || die
- emake DESTDIR="${D}" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
- cd .. || die
- done
-
- if use python; then
- cd python || die
- python_foreach_impl emake DESTDIR="${D}" install
- cd .. || die
- fi
-
- # config
- dodir /etc/wdmd.d
- dodir /etc/sanlock
- insinto /etc/sanlock
- doins src/sanlock.conf
-
- # init
- newconfd init.d/sanlock.sysconfig sanlock
- newconfd init.d/wdmd.sysconfig wdmd
- newinitd "${FILESDIR}"/sanlock.initd sanlock
- newinitd "${FILESDIR}"/wdmd.initd wdmd
- #doinitd ${FILESDIR}/sanlk-resetd.initd
- #doinitd ${FILESDIR}/fence_sanlockd.initd
-
- # systemd
- systemd_newunit init.d/sanlock.service.native sanlock.service
- sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native || die
- systemd_newunit init.d/wdmd.service.native wdmd.service
- systemd_dounit init.d/sanlk-resetd.service
- #systemd_dounit ${FILESDIR}/fence_sanlockd.service
-}