summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/btrbk/Manifest1
-rw-r--r--app-backup/btrbk/btrbk-0.32.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-backup/btrbk/Manifest b/app-backup/btrbk/Manifest
index 13227322b8cb..506f6feae57b 100644
--- a/app-backup/btrbk/Manifest
+++ b/app-backup/btrbk/Manifest
@@ -1,3 +1,4 @@
DIST btrbk-0.31.2.tar.xz 107124 BLAKE2B a05ef8a665d50b0f9637b1bc7026f0ca0f8364377b4165dae09cd27790dc139aaea1096a54719d948adda5050f91580650bf58db70a086cfdd14b73559fad9f3 SHA512 f953fe1a231f7a28c2d98cf124e3d52cc6d0810e6cb1673b90f335e07cd7473d0302ec227361f902c40a36dab5c075c675d2ee0543a23c37cb1e4baaf74efea0
DIST btrbk-0.31.3.tar.xz 109884 BLAKE2B 7f78d00815259e42bb3fd16ee48272717fe57913b7af83ca8a98f1dfd0de715cbf8b07177ea60b5b8bdcb9793ee0d5829b90b8327cd4810f6275611276a6e707 SHA512 62dee5430635b6a31edcdc9bed1829f549b60074ea09bb6f1fcd56d242d4215339846c8c2dbcd4bee05cd2a0cb32c1237ce7311d2b887885373c13fa15a6f476
DIST btrbk-0.32.0.tar.xz 110408 BLAKE2B d9627d0f0a258bba9412b37707c3e79ca8a65870148aa27f38e615c90d0e26adfc5ecf697cc34052916127a0a26be850f5874ff52ab6cb193093d591cb05dab1 SHA512 201dde5ea9bf459e5a837b520d3e76ef1077a1769ed2e06b9754e34a93e2abd513a0da2b18abbe13c09fc3a945117a4b022ad423f805056b62a2b2be9c0f768a
+DIST btrbk-0.32.1.tar.xz 110364 BLAKE2B 5d2860e182701ba6c407b9d0f41e476442bdf0ebc8491c3fa944860228d087d6bbe13084a4e950a24fc6ea1e251e2c4c6cbf17e9e3a4cb4f3f9b7ea9b85b2c11 SHA512 a44c1a50696793661fa6a06fafc6a7682ba5db57b511666a9b77d2df79b724855e91187e4d13e1dfe340077f550b0aced8923c6dec955d25ce46f7644ed802f3
diff --git a/app-backup/btrbk/btrbk-0.32.1.ebuild b/app-backup/btrbk/btrbk-0.32.1.ebuild
new file mode 100644
index 000000000000..29b1c6d3fc78
--- /dev/null
+++ b/app-backup/btrbk/btrbk-0.32.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/digint/btrbk.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+mbuffer +doc +lsbtr"
+
+DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"
+
+RDEPEND="dev-lang/perl
+ net-misc/openssh
+ mbuffer? ( >=sys-block/mbuffer-20180505 )
+ >=sys-fs/btrfs-progs-4.12"
+
+src_compile() {
+ emake clean
+ use doc && emake -C doc
+}
+src_install() {
+ local targets="install-bin install-etc install-share install-systemd"
+ use doc && targets="${targets} install-man install-doc"
+ use lsbtr && targets="${targets} install-bin-links"
+ emake \
+ DESTDIR="${D}" \
+ DOCDIR="/usr/share/doc/${PF}" \
+ SYSTEMDDIR="$(systemd_get_systemunitdir)" \
+ ${targets}
+}
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
+ upgrade_0_26_0_warning="1"
+ fi
+ if has_version "<${CATEGORY}/${PN}-0.27.0" ; then
+ upgrade_0_27_0_warning="1"
+ fi
+}
+pkg_postinst() {
+ if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
+ ewarn "If you are using raw targets, make sure to run the"
+ ewarn "\"raw_suffix2sidecar\" utility in each target directory."
+ fi
+ if [[ "${upgrade_0_27_0_warning}" == "1" ]]; then
+ ewarn 'Due to a bugfix in the scheduler [1] [2], previously preserved'
+ ewarn 'monthly/yearly backups could get deleted when upgrading to'
+ ewarn 'btrbk-0.27.0.'
+ ewarn ''
+ ewarn 'Before upgrading to btrbk-0.27.0, make sure to stop all cron jobs'
+ ewarn 'or systemd timers calling btrbk.'
+ ewarn ''
+ ewarn 'After upgrading, run "btrbk prune --dry-run --print-schedule" and'
+ ewarn 'check if any snapshots/backups would get deleted. If you want to'
+ ewarn 'forcibly preserve a snapshot/backup forever, rename it:'
+ ewarn ''
+ ewarn ' mv mysubvol.YYYYMMDD mysubvol.YYYYMMDD.keep_forever'
+ ewarn ''
+ ewarn 'Note that btrbk ignores subvolumes with unknown naming scheme, e.g.'
+ ewarn '(".keep_forever" suffix in the example above).'
+ ewarn ''
+ ewarn ' [1] https://github.com/digint/btrbk/issues/217'
+ ewarn ' [2] https://github.com/digint/btrbk/commit/719fb5f'
+ fi
+}