summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/shim/Manifest3
-rw-r--r--sys-boot/shim/shim-15.6.ebuild5
-rw-r--r--sys-boot/shim/shim-15.8.ebuild29
3 files changed, 34 insertions, 3 deletions
diff --git a/sys-boot/shim/Manifest b/sys-boot/shim/Manifest
index 954368dcbe49..b21e245961bc 100644
--- a/sys-boot/shim/Manifest
+++ b/sys-boot/shim/Manifest
@@ -1,3 +1,6 @@
DIST shim-aa64-15.6-2.aarch64.rpm 466804 BLAKE2B 706f31835be24fee7202b8f8eb49204741d7726f106fad993ff524f475434ab3f23bebcd427f8a2aa4cd9a9c2494fdec9c2a49c29025364f0ebe989786f74c2f SHA512 72c2a62f380e76c3ea0fe5b13ef4e4bcd5e62e1b26b0b277c6ed8dd5d5e76f0f92770497da09e8ce12e6c60ee57d679d134f960a10639644dd751811563f1f29
+DIST shim-aa64-15.8-3.aarch64.rpm 466590 BLAKE2B ebd77148d363020d14b418dbb3107981b213b39914daa80765cc2db16c7b365eaebcbcba19b88459364967f2764f417aeffd34754aa92c2efc7aaa4e9d45b712 SHA512 d9b879706f7f6c7f7bfea92a443191811d39835074b3b6db3979c707b406b00884baff66ac79bf9bd66869240f668c6e6f987f8954a570d648933c85ea0da1c2
DIST shim-ia32-15.6-2.x86_64.rpm 419081 BLAKE2B f7160dd1330bfd7ad2d64cfe370750f576f1e3291aa8bc8313d52869f3dd23228db8514e7578c2609428479e430a1d39c1992450f4f42197216c00c420a0a150 SHA512 045325802474f53c6e86eff1166f1a966268c9ad706fac4c08966f211dbc32fba21ed3a07c46445ec579ac1e2819a1313ff54d6169737806954962945c61bdc2
+DIST shim-ia32-15.8-3.x86_64.rpm 422489 BLAKE2B 00aa14d10ac0351e39f2b7bb2da6b31e048757ee9413b73f5a1638688e2b242c161b39b5d897c9414e435caab13456763dbe2c6bc46061ab3c29e14ab487e587 SHA512 10ef47014637f9df9f199d90e3869e96341723c23628cfd22465638028cc38b006a003c41ea7fd7f1885e4cb573a2f23034a237ea03ba231f8f0d37573bb2e23
DIST shim-x64-15.6-2.x86_64.rpm 479835 BLAKE2B 7d12b97275c25659f94a8dd4c8678eb7df9e11fd3258966cb65c762467f28744b9403e13d5b5c98d6d6a5244ce4d81ef31b9d802040be99da03c1bb56be21275 SHA512 971978bddee95a6a134ef05c4d88cf5df41926e631de863b74ef772307f3e106c82c8f6889c18280d47187986abd774d8671c5be4b85b1b0bb3d1858b65d02cf
+DIST shim-x64-15.8-3.x86_64.rpm 478432 BLAKE2B cf1a032af75fc17e09444aae488c2921a8f0868d91ceb427835cd0378f6c7369e223b7fc08f0a596774b374e3f800b9ec941792e522d8c5281a395cf800c642a SHA512 4c3635d82980ccb604b568f072f30ac0c0055c6ed2985dade6a28c9070852a240bb33f15f9ef42c83fa46d212c18ae6f17abca9f3adda0a332b908ceda537e87
diff --git a/sys-boot/shim/shim-15.6.ebuild b/sys-boot/shim/shim-15.6.ebuild
index c4f33913bd22..fc117bf9f5c5 100644
--- a/sys-boot/shim/shim-15.6.ebuild
+++ b/sys-boot/shim/shim-15.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,13 +12,12 @@ SRC_URI="amd64? ( https://kojipkgs.fedoraproject.org/packages/shim/${PV}/2/x86_6
x86? ( https://kojipkgs.fedoraproject.org/packages/shim/${PV}/2/x86_64/shim-x64-${PV}-2.x86_64.rpm
https://kojipkgs.fedoraproject.org/packages/shim/${PV}/2/x86_64/shim-ia32-${PV}-2.x86_64.rpm )
arm64? ( https://kojipkgs.fedoraproject.org/packages/shim/${PV}/2/aarch64/shim-aa64-${PV}-2.aarch64.rpm )"
+S="${WORKDIR}/boot/efi/EFI"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 x86"
-S="${WORKDIR}/boot/efi/EFI"
-
src_install() {
insinto /usr/share/${PN}
doins BOOT/BOOT*.EFI
diff --git a/sys-boot/shim/shim-15.8.ebuild b/sys-boot/shim/shim-15.8.ebuild
new file mode 100644
index 000000000000..cc0241858af6
--- /dev/null
+++ b/sys-boot/shim/shim-15.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm secureboot
+
+DESCRIPTION="Fedora's signed UEFI shim"
+HOMEPAGE="https://src.fedoraproject.org/rpms/shim"
+SRC_URI="amd64? ( https://kojipkgs.fedoraproject.org/packages/shim/${PV}/3/x86_64/shim-x64-${PV}-3.x86_64.rpm
+ https://kojipkgs.fedoraproject.org/packages/shim/${PV}/3/x86_64/shim-ia32-${PV}-3.x86_64.rpm )
+ x86? ( https://kojipkgs.fedoraproject.org/packages/shim/${PV}/3/x86_64/shim-x64-${PV}-3.x86_64.rpm
+ https://kojipkgs.fedoraproject.org/packages/shim/${PV}/3/x86_64/shim-ia32-${PV}-3.x86_64.rpm )
+ arm64? ( https://kojipkgs.fedoraproject.org/packages/shim/${PV}/3/aarch64/shim-aa64-${PV}-3.aarch64.rpm )"
+S="${WORKDIR}/boot/efi/EFI"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins BOOT/BOOT*.EFI
+ doins fedora/mm*.efi
+
+ # Shim is already signed with Microsoft keys, but MokManager still needs
+ # signing with our key otherwise we have to enrol the Fedora key in Mok list
+ secureboot_auto_sign --in-place
+}