summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.4.0.ebuild2
-rw-r--r--dev-python/bandit/bandit-1.5.1.ebuild46
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index a4bd1693e21e..079e059ff896 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -4,3 +4,4 @@ DIST bandit-1.1.0.tar.gz 135333 BLAKE2B 828356ddff316879c0d7a308b0e1545a20ddeb83
DIST bandit-1.2.0.tar.gz 138040 BLAKE2B d2eb2d36fa80f7e2873454ceb043ae2aad5a7df09f250f0f5d5b13852ce38e848e5ea34f93df647ccec125c847b2184cfbb3dc72f20228d808364f1c09312fac SHA512 f2119bb7b920ca7b4254fed433ee0e41bbbde51a45cd88283fac1a9ac8f60ce621fffecca676bdb8db7ea5cb925851e50176014405425c30b5991e17f57f294a
DIST bandit-1.3.0.tar.gz 139075 BLAKE2B 870481b4ef9932ce9bae2e6563cd7007d5f2afe3abf2b4e03b3da5f8c719c6792f1dc0a9f9c252b922324ef8369d4265f0b81426a6db67ce52595dedcb5f1042 SHA512 24341cc837fa6a8bb095c7fdc684a81b3c06834b408c6328c6b3425d5cc5c63dcb119cadf54c8cea302a108923638839626f1f8c6d401ce66cd112a776a8363f
DIST bandit-1.4.0.tar.gz 138019 BLAKE2B 1a7aee62aa44fca533d02bdb6e5d44fe136038b9ee8ab462d6af6af84a4111ae341bd791b142d5e090e90f639cd5968419b2a9fa3b51e664dda971af13d52959 SHA512 e5ae412e3b13c89f8c4a85d318b0504c2d5b9aa4ca81652266a13d96f859705c2d0112dc534373cd7fd1020790369e3fe6b55da57773fa7821e663c37fe98817
+DIST bandit-1.5.1.tar.gz 480856 BLAKE2B f8a1a7dc1d93a1b6c8d3eb5bcbecda895b29dfebe055ac358b9437bd0c9ab5562e6d25a658bc2092cff6bddfd0245e71bf39ee88b2718e3a0c7376fa50293ae1 SHA512 e6f596e73af45ca2ff4d200fad63d37adf44efd5de52f8061f5a349b66457a39eb442ad442d5fb57b2e0e98c8bae0eb0879b958ff619b4e26c0183bc8b928e36
diff --git a/dev-python/bandit/bandit-1.4.0.ebuild b/dev-python/bandit/bandit-1.4.0.ebuild
index a15457cb08fd..0b4564fb7018 100644
--- a/dev-python/bandit/bandit-1.4.0.ebuild
+++ b/dev-python/bandit/bandit-1.4.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
inherit distutils-r1
diff --git a/dev-python/bandit/bandit-1.5.1.ebuild b/dev-python/bandit/bandit-1.5.1.ebuild
new file mode 100644
index 000000000000..2057f9a8a933
--- /dev/null
+++ b/dev-python/bandit/bandit-1.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="https://openstack.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~s390 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-1.0.0
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.4.5[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/git-python-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ stestr init
+ stestr run || die
+}