summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/asciidoctor/Manifest1
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-1.5.7.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
index 3c9776ccbcc7..874e3ee261b6 100644
--- a/dev-ruby/asciidoctor/Manifest
+++ b/dev-ruby/asciidoctor/Manifest
@@ -1,3 +1,4 @@
DIST asciidoctor-1.5.5.tar.gz 543437 BLAKE2B ff3530825a495ee222634aa871f828069fd5c1ec1ab3c4513f7b0e74af3c4a78ee4ab0f0764f8d7dc698484d2acb962dc4fa8ae6a2c7f6c365c08a65a3044afa SHA512 6a95c2e48314a1f44d6398d83c490231baeb4ebea8d8c0e0ef361c884251fe054d48afceccadfb6c34947946920731e0194fc3e398b8dd8b8b320ea9d37f1f66
DIST asciidoctor-1.5.6.1.tar.gz 528614 BLAKE2B acca343f39143b6a9b0dd84ebb1e356f7dcb960154cec4524778e37aac6aabcfdb2c4952cdfaf0aa065203c91188ac006555bebab22d46b75b2705155038ddb4 SHA512 ed700f8ae7ca04700cb1814f819c0f29098266e0b457edb0ade413ae231388f7d217f929e6dff26daaafd6ad8d4c2f1de5debb49cd841fc493aa9d94a9069549
DIST asciidoctor-1.5.6.2.tar.gz 529372 BLAKE2B 8c43628fe78b4e06ef5c431862a8bb04ad911d73043f395645b14c0165a9a69880d82a39329f77ea6a7418da4331a7d64a0fbe163cac30e38a296523fd184769 SHA512 38b3bce03c54f43514bc51c4302d8177ef22ee2d178b4909764da92a091a958ef8f003c477eae125e399309f18198d0fe17c01b8064f658045b8bd9fd37f16e9
+DIST asciidoctor-1.5.7.1.tar.gz 565182 BLAKE2B c697ea1b371a9ec26ec3277e043275ed3672bad104d34553aa442723797df3cc4e5a48447f806dba53fb3a142760f514bff74b189058260f621c8b63f8ad02b1 SHA512 4819aef93fb301e5378871935370fe37671446ecdedf76853cc0c19a6a5f3f0e2debbf2afb8ba7287f866fb57903abdfe6d845e1ccf24dda4347ec9c92624c3d
diff --git a/dev-ruby/asciidoctor/asciidoctor-1.5.7.1.ebuild b/dev-ruby/asciidoctor/asciidoctor-1.5.7.1.ebuild
new file mode 100644
index 000000000000..3fa9aa24ae76
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-1.5.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/slim
+ dev-ruby/thread_safe
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}