summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-11.0-r1.ebuild (renamed from dev-util/include-what-you-use/include-what-you-use-11.0.ebuild)10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-util/include-what-you-use/include-what-you-use-11.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-11.0-r1.ebuild
index 19caadf0f6ca..dc5b3760f2ca 100644
--- a/dev-util/include-what-you-use/include-what-you-use-11.0.ebuild
+++ b/dev-util/include-what-you-use/include-what-you-use-11.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,8 +20,8 @@ KEYWORDS="~amd64 ~x86"
LLVM_MAX_SLOT=11
-RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-devel/clang:${LLVM_MAX_SLOT}
+RDEPEND="
+ sys-devel/clang:${LLVM_MAX_SLOT}=
${PYTHON_DEPS}
"
DEPEND="${RDEPEND}"
@@ -30,6 +30,10 @@ REQUIRED_USE=${PYTHON_REQUIRED_USE}
S=${WORKDIR}/${PN}-${UPSTREAM_PV}
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
pkg_setup() {
llvm_pkg_setup
python-single-r1_pkg_setup