summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jsonpatch/Manifest1
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.31.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index 3c16852f055a..af7f0c014ff5 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,2 +1,3 @@
DIST jsonpatch-1.28.tar.gz 26829 BLAKE2B 1dee89500be23c49e5d7fdcaacb05da7ea089b691e133c5187c9558d378ae3714ad7fc6f164d0b7eea7b3cf1afefa39b7748a4637b0456051fab086e0e8f15d0 SHA512 2884cb95307cb607c8cd80e688491b4449f953e43e5b232d4d57d7249c590652ecae0856806ade6bf2807a04180e992fd2cdf61590ac058d573d653382bf7a28
DIST jsonpatch-1.30.tar.gz 27787 BLAKE2B f3294e3382baac604c31c12a790b0836732a66fdf3b6cbfbab58fcee4558140dc84a408af94f2f5861aaa17fcff49ac254f42364e5d0ba1039af0a2fd518da93 SHA512 190507eb6d6b4a81e7e804690672863d5070c140a47090b70df36d8180644618395ffc179dabf6ba24e44268b74f670abdfd260c54dc3251b12ef4b7ad17d093
+DIST jsonpatch-1.31.tar.gz 27910 BLAKE2B dbcadbe3b3937b8a543cbf871516ee047937c1a53897c535c93ee01ab301970048f4f584d1f4e96b5780c95c64a94263ee55f52efd5ba0d0c0147680ee8f9ef7 SHA512 9f08014f311d18b97f0f0cfcc931f2615e0ba5079ff5994e9ba674e079be715c3c8de3ce1c1958235b34dcbe87dee09b103295655880273ce91652d2191704c0
diff --git a/dev-python/jsonpatch/jsonpatch-1.31.ebuild b/dev-python/jsonpatch/jsonpatch-1.31.ebuild
new file mode 100644
index 000000000000..9b885b42ed8d
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.31.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="https://github.com/stefankoegl/python-json-patch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-json-patch-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )
+"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}