summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/tangram/Manifest1
-rw-r--r--www-client/tangram/files/tangram-2.0-dont-validate-appstream.patch11
-rw-r--r--www-client/tangram/files/tangram-2.0-meson-blueprint-compiler.patch11
-rw-r--r--www-client/tangram/metadata.xml18
-rw-r--r--www-client/tangram/tangram-2.0.ebuild51
5 files changed, 92 insertions, 0 deletions
diff --git a/www-client/tangram/Manifest b/www-client/tangram/Manifest
new file mode 100644
index 000000000000..0bac93610a6a
--- /dev/null
+++ b/www-client/tangram/Manifest
@@ -0,0 +1 @@
+DIST tangram-2.0.tar.xz 991180 BLAKE2B 1f51b8218a2d7bec9581335319448548765c26f6057ce2be0c5862324fe6659637040f8c878829505550c9c49707987c3f12b707b549f087805bb1adae12ae3d SHA512 e851153f1621e7e14dd4c5445de108126adbb0f56396331b8c2d3354ba49c1ea77b5053e5557d02f1ba817d04c2553f68ab18a9afbc4842a258e0bf9e6a798d6
diff --git a/www-client/tangram/files/tangram-2.0-dont-validate-appstream.patch b/www-client/tangram/files/tangram-2.0-dont-validate-appstream.patch
new file mode 100644
index 000000000000..4f636213c70b
--- /dev/null
+++ b/www-client/tangram/files/tangram-2.0-dont-validate-appstream.patch
@@ -0,0 +1,11 @@
+--- a/data/appdata/meson.build
++++ b/data/appdata/meson.build
+@@ -7,7 +7,7 @@ appstream_file = i18n.merge_file(
+ )
+
+ appstream_util = find_program('appstream-util', required: false)
+-if appstream_util.found()
++if false
+ test('Validate appstream file', appstream_util,
+ args: ['validate', appstream_file]
+ )
diff --git a/www-client/tangram/files/tangram-2.0-meson-blueprint-compiler.patch b/www-client/tangram/files/tangram-2.0-meson-blueprint-compiler.patch
new file mode 100644
index 000000000000..1ea82d214aee
--- /dev/null
+++ b/www-client/tangram/files/tangram-2.0-meson-blueprint-compiler.patch
@@ -0,0 +1,11 @@
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -5,7 +5,7 @@ blueprint_compiler = find_program(
+ # Flatpak
+ '/app/bin/blueprint-compiler',
+ # host
+- '../blueprint-compiler/blueprint-compiler.py'
++ 'blueprint-compiler'
+ )
+
+ gjspack = find_program('../troll/gjspack/bin/gjspack')
diff --git a/www-client/tangram/metadata.xml b/www-client/tangram/metadata.xml
new file mode 100644
index 000000000000..3cbb62a8129a
--- /dev/null
+++ b/www-client/tangram/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Tangram is a new kind of browser. It is designed to organize and run your
+ Web applications. Each tab is persistent and independent. You can set
+ multiple tabs with different accounts for the same application.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/sonnyp/Tangram/issues</bugs-to>
+ <remote-id type="github">sonnyp/Tangram</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-client/tangram/tangram-2.0.ebuild b/www-client/tangram/tangram-2.0.ebuild
new file mode 100644
index 000000000000..22985cb29ff6
--- /dev/null
+++ b/www-client/tangram/tangram-2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+DESCRIPTION="Web browser designed to organize and run Web applications"
+HOMEPAGE="https://apps.gnome.org/app/re.sonny.Tangram/
+ https://github.com/sonnyp/Tangram/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sonnyp/${PN^}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/gjs
+ gui-libs/gtk:4
+ gui-libs/libadwaita:1
+ net-libs/webkit-gtk:5
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/blueprint-compiler
+ dev-util/desktop-file-utils
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-dont-validate-appstream.patch
+ "${FILESDIR}"/${PN}-2.0-meson-blueprint-compiler.patch
+)
+
+DOCS=( README.md TODO.md )
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}