summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/libunwind/Manifest3
-rw-r--r--sys-libs/libunwind/libunwind-1.8.0.ebuild (renamed from sys-libs/libunwind/libunwind-1.8.0_rc1.ebuild)22
-rw-r--r--sys-libs/libunwind/libunwind-9999.ebuild5
3 files changed, 11 insertions, 19 deletions
diff --git a/sys-libs/libunwind/Manifest b/sys-libs/libunwind/Manifest
index 6accc5696763..96acf6f74e03 100644
--- a/sys-libs/libunwind/Manifest
+++ b/sys-libs/libunwind/Manifest
@@ -3,4 +3,5 @@ DIST libunwind-1.6.2-loong.patch.xz 122756 BLAKE2B 1d369d18e71c4b9faa79a31a917a0
DIST libunwind-1.6.2.tar.gz 901392 BLAKE2B 3d0313f7e92cbc3e1a84ad3831a5170f21cdf772f1697ca0a59dea63cdd47da382e9f1fd77325d9ff8bcd47559a425dc883a820c646c628cd00faed82cb0f83f SHA512 1d17dfb14f99a894a6cda256caf9ec481c14068aaf8f3a85fa3befa7c7cca7fca0f544a91a3a7c2f2fc55bab19b06a67ca79f55ac9081151d94478c7f611f8f7
DIST libunwind-1.7.1-docs.tar.xz 27248 BLAKE2B 0905f49ce72e6cafbb185828a4adf7eb5a88ede335104b1b0679e66199079e3dad9d83815d10a864b4480d88abd82b73bb71181962b1fea39ec41f534d78d549 SHA512 d786572e7fbd5ef7852712f592bd17d4110951083991c5ffcff2bb4ae91e4519b42743f848fe7f2cc9f72d8a0240531ec3d27806972c2c309d06a9048284b97b
DIST libunwind-1.7.2.tar.gz 912590 BLAKE2B 519570a02d06ce4a174ca226941e493499054112de1c92938434e9fb56fabc8446f699a886ea8beee672ac5e28acd03d16169257a43e2ee1bab084fb331ef4cf SHA512 903f7e26c7d4c22e6ef4fe8954ca0f153fdf346cec40e1e8f7ab966d251110f4deb0a84d1fd150aee194ed966b5c1e01ee27c821cd043859852da33a94faae1f
-DIST libunwind-1.8.0-rc1.tar.gz 977482 BLAKE2B 0cf4dde187b68a2ba642fc588fcb020bf3e631584d4cac888972f714e7c4ce7a88e10a4c816eadec2051f318a196c61f6c3b4ba5e8ebf17ce4e10ff61e6cd0c5 SHA512 0d9cd896a90ea6e36a9a8aeb049ce71ec3a893fcf991533a79bb663c54b0f4b1f04c7b306c06c56e809f829a42284655d52c9fec3d88c60c37f06681dd99d9e3
+DIST libunwind-1.8.0-docs.tar.xz 29280 BLAKE2B 260c5011cf23422ec04449126259c9960b5549b94def8ffa3821ccc67809b5da06be22fb0b465fcee2f0ec89faebab71d2bf3316dc68315a27e0913856513b0a SHA512 6969c8426dc5d79a78a9dae366a9e7b6f1d9a7ce307357913d4f5b8867a540ab8225b5342ee0e06e77b832ef76336fba41dadf12effa5236a076e6bfe72ec548
+DIST libunwind-1.8.0.tar.gz 949829 BLAKE2B 5e88f13365673d7abc6b1fd797250598fa45a5887675dd1b6d2ea553c66bdcb88104d549c029162dd127ba83e02247de4b2118235e0737fac29206a71c75725f SHA512 ecbcfacacbcc4f7e4326397af448c92253f88b8f57c14c31b9b82b3a2951eb67b164b2a137b2800a2ada933a07a5bdd75f0198d3e4c6a2d8d740559e3a76f1b2
diff --git a/sys-libs/libunwind/libunwind-1.8.0_rc1.ebuild b/sys-libs/libunwind/libunwind-1.8.0.ebuild
index a8d8ee1b3c83..7ddf3fd67d2c 100644
--- a/sys-libs/libunwind/libunwind-1.8.0_rc1.ebuild
+++ b/sys-libs/libunwind/libunwind-1.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2005-2023 Gentoo Authors
+# Copyright 2005-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,14 +6,14 @@ EAPI=8
# Generate using https://github.com/thesamesam/sam-gentoo-scripts/blob/main/niche/generate-libunwind-docs
# Set to 1 if prebuilt, 0 if not
# (the construct below is to allow overriding from env for script)
-: ${LIBUNWIND_DOCS_PREBUILT:=0}
+: ${LIBUNWIND_DOCS_PREBUILT:=1}
LIBUNWIND_DOCS_PREBUILT_DEV=sam
-LIBUNWIND_DOCS_VERSION=1.7.1
+LIBUNWIND_DOCS_VERSION=1.8.0
# Default to generating docs (inc. man pages) if no prebuilt; overridden later
LIBUNWIND_DOCS_USEFLAG="+doc"
-inherit autotools multilib-minimal
+inherit multilib-minimal
DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
@@ -74,21 +74,14 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/libunwind-x86_64.h
)
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.0_rc1-configure-bashism.patch
-)
-
src_prepare() {
default
chmod +x src/ia64/mk_cursor_i || die
- #if [[ ${PV} == 9999 ]] ; then
- # eautoreconf
- #fi
-
- # temporarily for bashism patch
- eautoreconf
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
}
multilib_src_configure() {
@@ -124,7 +117,6 @@ multilib_src_compile() {
}
multilib_src_test() {
- # Explicitly allow parallel build of tests.
# Sandbox causes some tests to freak out.
SANDBOX_ON=0 emake check
}
diff --git a/sys-libs/libunwind/libunwind-9999.ebuild b/sys-libs/libunwind/libunwind-9999.ebuild
index a3d63d421da6..7ddf3fd67d2c 100644
--- a/sys-libs/libunwind/libunwind-9999.ebuild
+++ b/sys-libs/libunwind/libunwind-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2005-2023 Gentoo Authors
+# Copyright 2005-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,7 +9,7 @@ EAPI=8
: ${LIBUNWIND_DOCS_PREBUILT:=1}
LIBUNWIND_DOCS_PREBUILT_DEV=sam
-LIBUNWIND_DOCS_VERSION=1.7.1
+LIBUNWIND_DOCS_VERSION=1.8.0
# Default to generating docs (inc. man pages) if no prebuilt; overridden later
LIBUNWIND_DOCS_USEFLAG="+doc"
@@ -117,7 +117,6 @@ multilib_src_compile() {
}
multilib_src_test() {
- # Explicitly allow parallel build of tests.
# Sandbox causes some tests to freak out.
SANDBOX_ON=0 emake check
}