summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/mate-themes/Manifest1
-rw-r--r--x11-themes/mate-themes/mate-themes-3.22.19.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-themes/mate-themes/Manifest b/x11-themes/mate-themes/Manifest
index 0682ae37eec4..1021b83470a7 100644
--- a/x11-themes/mate-themes/Manifest
+++ b/x11-themes/mate-themes/Manifest
@@ -1 +1,2 @@
DIST mate-themes-3.22.18.tar.xz 6103368 BLAKE2B 35cb77fc40d364e19d4e7cf25e7a168773bd8c33e256d97b4cbea91368b38c17201480f21f74c107b5c47fa6254042bdd64e4186dc1b87e00dab89e6b26ad439 SHA512 0851dee8ddb7495b43cbb7590ca3ecd1b3fa5a474f66806cb644462a70324c8221630d1d555e84beb8fa7025c080edc9524f244e47ac42c9843cc9eccc78dd74
+DIST mate-themes-3.22.19.tar.xz 5567828 BLAKE2B 8eeead9b097e2a9e76aac849e6b6fe93382a6ff6dbdf4bd3b032167744fdf35ff047cdb85d1480474e1f0fc0f06ceda04e7d9e4a6ae573b04cd78c4e4ca858f7 SHA512 3e8a5a37bb6755c65da3307957569e84cce546c9786396f5eb8cb5f84ddf64e04260b87f67cb0b03c7c7dc13b4f75790fb9afe8b971101f3556ee6c015bb585d
diff --git a/x11-themes/mate-themes/mate-themes-3.22.19.ebuild b/x11-themes/mate-themes/mate-themes-3.22.19.ebuild
new file mode 100644
index 000000000000..ea3fd9b5779a
--- /dev/null
+++ b/x11-themes/mate-themes/mate-themes-3.22.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+MATE_GTK_V="$(ver_cut 1-2)"
+
+HOMEPAGE="http://mate-desktop.org"
+DESCRIPTION="A set of MATE themes, with sets for users with limited or low vision"
+SRC_URI="http://pub.mate-desktop.org/releases/themes/${MATE_GTK_V}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0/${MATE_GTK_V}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=x11-libs/gdk-pixbuf-2:2
+ >=x11-libs/gtk+-2:2
+ >=x11-themes/gtk-engines-2.15.3:2
+ x11-themes/gtk-engines-murrine
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ >=sys-devel/autoconf-2.53
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ virtual/pkgconfig
+"
+
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ default
+ eautoreconf
+}