summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/prboom-plus/Manifest1
-rw-r--r--games-fps/prboom-plus/files/prboom-plus-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch33
-rw-r--r--games-fps/prboom-plus/metadata.xml33
-rw-r--r--games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild68
4 files changed, 135 insertions, 0 deletions
diff --git a/games-fps/prboom-plus/Manifest b/games-fps/prboom-plus/Manifest
new file mode 100644
index 000000000000..74314aab3b53
--- /dev/null
+++ b/games-fps/prboom-plus/Manifest
@@ -0,0 +1 @@
+DIST prboom-plus-2.5.1.4.tar.gz 3007237 BLAKE2B 3dce8aad6fb521d13cf3e6b48a261f010b545bafa853860b284be0d0772f65b4fa0bfa965f7cb1869cc0d0eb21a4237e1873d08ff56d439cb3eed00f82bf12fb SHA512 625b75c5fe663bb3ba54bcd90f914ad7461c0860448f6f179180de26bea0a4d766739c50f96a8245687bc213742ec53bf6ffa26cde09772b3ae0bba91662213e
diff --git a/games-fps/prboom-plus/files/prboom-plus-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch b/games-fps/prboom-plus/files/prboom-plus-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch
new file mode 100644
index 000000000000..c64bd135937d
--- /dev/null
+++ b/games-fps/prboom-plus/files/prboom-plus-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch
@@ -0,0 +1,33 @@
+From d0aaa51e05da23c2b0ad46901c2f4b3cd0500681 Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Fri, 21 Jun 2019 17:31:01 +0900
+Subject: [PATCH] Remove nonstandard gamesdir variable
+
+The Autotools canonical method of configuring the program installation
+directory is via the bindir variable (e.g. "--bindir=/usr/games/doom").
+---
+ src/Makefile.am | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index c20da98..9b3ab13 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -8,12 +8,10 @@
+
+ SUBDIRS = SDL POSIX MAC PCSOUND TEXTSCREEN MUSIC
+
+-gamesdir=$(prefix)/games
+-
+ if BUILD_SERVER
+-games_PROGRAMS = prboom-plus prboom-plus-game-server
++bin_PROGRAMS = prboom-plus prboom-plus-game-server
+ else
+-games_PROGRAMS = prboom-plus
++bin_PROGRAMS = prboom-plus
+ endif
+
+ CFLAGS = @CFLAGS@ @SDL_CFLAGS@
+--
+2.22.0
+
diff --git a/games-fps/prboom-plus/metadata.xml b/games-fps/prboom-plus/metadata.xml
new file mode 100644
index 000000000000..c05b6d7832b5
--- /dev/null
+++ b/games-fps/prboom-plus/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ PrBoom+ is a Doom source port developed from the original PrBoom project.
+ </longdescription>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="dumb">Enable support for various tracker-style music formats via <pkg>media-libs/dumb</pkg></flag>
+ <flag name="fluidsynth">Enable support for MIDI via <pkg>media-sound/fluidsynth</pkg></flag>
+ <flag name="net">Enable support for network play</flag>
+ <flag name="nonfree">Enable non-free components</flag>
+ <flag name="portmidi">Enable support for MIDI via <pkg>media-libs/portmidi</pkg></flag>
+ <flag name="sdl-image">Enable support for high-resolution texture support via <pkg>media-libs/sdl-image</pkg></flag>
+ <flag name="sdl-mixer">Enable support for MIDI via <pkg>media-libs/sdl-mixer</pkg></flag>
+ </use>
+ <upstream>
+ <bugs-to>https://sourceforge.net/p/prboom-plus/bugs</bugs-to>
+ <doc lang="en">https://prboom-plus.sourceforge.net</doc>
+ <remote-id type="sourceforge">prboom-plus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild b/games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild
new file mode 100644
index 000000000000..29196ddfd2ea
--- /dev/null
+++ b/games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop xdg
+
+DESCRIPTION="A Doom source port developed from the original PrBoom project"
+HOMEPAGE="https://prboom-plus.sourceforge.net"
+# We are using a github mirror here because the upstream tarball is missing the
+# free dog assets; we should update SRC_URI to point to the upstream tarball
+# once the free assets are present as expected
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/coelckers/prboom-plus/archive/f96f891d068dcc5ec52ed91056b46d27e9a8462d.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+
+ nonfree? ( freedist )
+ !nonfree? ( BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dumb fluidsynth mad net nonfree +opengl pcre +png portmidi sdl-image +sdl-mixer vorbis"
+REQUIRED_USE="sdl-image? ( opengl )"
+
+DEPEND="
+ media-libs/libsdl[opengl?,joystick,sound,video]
+ dumb? ( media-libs/dumb )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ mad? ( media-libs/libmad )
+ net? ( media-libs/sdl-net )
+ sdl-image? ( media-libs/sdl-image )
+ pcre? ( dev-libs/libpcre:3 )
+ png? ( media-libs/libpng:0= )
+ portmidi? ( media-libs/portmidi )
+ sdl-mixer? ( media-libs/sdl-mixer[midi] )
+ vorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/prboom-plus-f96f891d068dcc5ec52ed91056b46d27e9a8462d/prboom2"
+PATCHES="${FILESDIR}/${P}-Remove-nonstandard-gamesdir-variable.patch"
+
+src_prepare() {
+ xdg_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-cpu-opt \
+ $(use_enable nonfree nonfree-graphics) \
+ $(use_enable opengl gl) \
+ $(use_with dumb) \
+ $(use_with fluidsynth) \
+ $(use_with mad) \
+ $(use_with net) \
+ $(use_with pcre) \
+ $(use_with png) \
+ $(use_with portmidi) \
+ $(use_with sdl-image image) \
+ $(use_with sdl-mixer mixer) \
+ $(use_with vorbis vorbisfile) \
+ --with-waddir="${EPREFIX}/usr/share/doom"
+}
+
+src_install() {
+ default
+ newicon ICONS/prboom-plus.svg ${PN}.svg
+ make_desktop_entry "${PN}" "PrBoom+"
+}