summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/tntnet/Manifest1
-rw-r--r--dev-libs/tntnet/files/tntnet-2.0-zlib-minizip.patch65
-rw-r--r--dev-libs/tntnet/files/tntnet.initd29
-rw-r--r--dev-libs/tntnet/tntnet-2.2.1-r3.ebuild92
-rw-r--r--dev-libs/tntnet/tntnet-2.2.1.ebuild87
5 files changed, 0 insertions, 274 deletions
diff --git a/dev-libs/tntnet/Manifest b/dev-libs/tntnet/Manifest
index c0186637b7eb..923dfd8c213f 100644
--- a/dev-libs/tntnet/Manifest
+++ b/dev-libs/tntnet/Manifest
@@ -1,2 +1 @@
-DIST tntnet-2.2.1.tar.gz 1127500 BLAKE2B bdb55c879ed00afdde1bfe1560ad4228effaa05b35996df3860631c90c93e57096f590b5ddfd8e8ff0356837e839e2f6ed8f4f6fe8ed478275926dd1143b2051 SHA512 78a26713498fd6eabb0b4a247bb20c130ce967ed22ce5c54da4b1300534dd40155aa62a2dc770be4eca720cadeceac283978a5dc3ce418728994af72e4d8eac1
DIST tntnet-3.0.tar.gz 879598 BLAKE2B 34cbabc52eb28be051da8593eb32d66aa701785be4002056d9be34d28871ae886a87eb1d66e71393a9f9d96110a3d826acead6c6db5c6f2829db797ac449b82e SHA512 5fe1f8750e10537919174e953be92b73e12a9227c50a02dcf2f23a266304ad3ad77d29823e8cdd3e2fa92dba936c2624f140943d021790e8137609bbeb0d3d81
diff --git a/dev-libs/tntnet/files/tntnet-2.0-zlib-minizip.patch b/dev-libs/tntnet/files/tntnet-2.0-zlib-minizip.patch
deleted file mode 100644
index 5e0465060898..000000000000
--- a/dev-libs/tntnet/files/tntnet-2.0-zlib-minizip.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -18,6 +18,7 @@
-
- AC_PROG_CXX
- AC_PROG_LIBTOOL
-+PKG_PROG_PKG_CONFIG
-
- AC_LANG(C++)
- ACX_PTHREAD
-@@ -40,6 +41,12 @@
- AC_CHECK_FUNCS([fopen64], ,[AM_CFLAGS=-DUSE_FILE32API])
- AC_SUBST(AM_CFLAGS)
-
-+PKG_CHECK_MODULES([MINIZIP], [minizip],
-+ [HAVE_MINIZIP=true], [HAVE_MINIZIP=false])
-+AC_SUBST([MINIZIP_CFLAGS])
-+AC_SUBST([MINIZIP_LIBS])
-+AM_CONDITIONAL([HAVE_MINIZIP], [test $HAVE_MINIZIP = true])
-+
- AC_ARG_WITH([epoll],
- AS_HELP_STRING([--with-epoll=yes|no|probe], [use epoll]),
- [epoll_option=$withval],
---- a/framework/common/Makefile.am
-+++ b/framework/common/Makefile.am
-@@ -23,7 +23,6 @@
- httpparser.cpp \
- httprequest.cpp \
- httpreply.cpp \
-- ioapi.c \
- job.cpp \
- langlib.cpp \
- listener.cpp \
-@@ -40,16 +39,13 @@
- stringlessignorecase.cpp \
- tntconfig.cpp \
- tntnet.cpp \
-- unzip.c \
- unzipfile.cpp \
- urlescostream.cpp \
- urlmapper.cpp \
- util.cpp \
- worker.cpp \
- zdata.cpp \
-- crypt.h \
-- ioapi.h \
-- unzip.h
-+ crypt.h
-
- nobase_include_HEADERS = \
- tnt/applicationunlocker.h \
-@@ -144,3 +140,13 @@
- tnt/stressjob.h
- endif
-
-+if HAVE_MINIZIP
-+libtntnet_la_CXXFLAGS += $(MINIZIP_CFLAGS)
-+libtntnet_la_LDFLAGS += $(MINIZIP_LIBS)
-+else
-+libtntnet_la_SOURCES += \
-+ ioapi.c \
-+ ioapi.h \
-+ unzip.c \
-+ unzip.h
-+endif
diff --git a/dev-libs/tntnet/files/tntnet.initd b/dev-libs/tntnet/files/tntnet.initd
deleted file mode 100644
index 54982bddd6e6..000000000000
--- a/dev-libs/tntnet/files/tntnet.initd
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-PIDFILE="/var/run/tntnet.pid"
-
-depend() {
- use net
-}
-
-start() {
- ebegin "Starting tntnet"
- start-stop-daemon --start --quiet --pidfile $PIDFILE --exec /usr/bin/tntnet
- eend $?
-}
-
-stop() {
- ebegin "Stopping tntnet"
- start-stop-daemon --stop --pidfile $PIDFILE --exec /usr/bin/tntnet
- eend $?
-}
-
-reload() {
- # FIXME: Remove --stop and --oknodo as soon as baselayout-1 has been removed...
- # finally...
- ebegin "Reloading tntnet configuration"
- start-stop-daemon --stop --oknodo --pidfile $PIDFILE --signal HUP --exec /usr/bin/tntnet
- eend $?
-}
diff --git a/dev-libs/tntnet/tntnet-2.2.1-r3.ebuild b/dev-libs/tntnet/tntnet-2.2.1-r3.ebuild
deleted file mode 100644
index bb9f702a21ea..000000000000
--- a/dev-libs/tntnet/tntnet-2.2.1-r3.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="Modular, multithreaded web application server extensible with C++"
-HOMEPAGE="http://www.tntnet.org/"
-SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="gnutls server ssl examples"
-
-RDEPEND="
- >=dev-libs/cxxtools-2.2.1
- sys-libs/zlib[minizip]
- ssl? (
- gnutls? (
- net-libs/gnutls:0=
- dev-libs/libgcrypt:0
- )
- !gnutls? (
- dev-libs/openssl:0=
- )
- )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/zip
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.0-zlib-minizip.patch )
-
-src_prepare() {
- # Both fixed in the next release
- default
- rm framework/common/{ioapi,unzip}.[ch] || die
-
- # bug 426262
- mv configure.{in,ac} || die
-
- # bug 423697
- sed -e "s:unzip.h:minizip/unzip.h:" -i framework/defcomp/unzipcomp.cpp || die
-
- eautoreconf
-
- sed -i -e 's:@localstatedir@:/var:' etc/tntnet/tntnet.xml.in || die
-}
-
-src_configure() {
- # default enabled, will not compile without sdk
- local myconf=( --with-sdk )
-
- # Prefer gnutls over SSL
- if use gnutls; then
- einfo "Using gnutls for ssl support."
- myconf+=( --with-ssl=gnutls )
- elif use ssl; then
- einfo "Using openssl for ssl support."
- myconf+=( --with-ssl=openssl )
- else
- myconf+=( --with-ssl=no )
- fi
-
- econf \
- --disable-static \
- $(use_with server) \
- "${myconf[@]}"
-}
-
-src_install() {
- default
- dodoc doc/tntnet.pdf
-
- if use examples; then
- emake -C sdk/demos maintainer-clean
- rm -r sdk/demos/{Makefile*,*/Makefile*,*/*.{la,lo},*/.libs} || die
-
- docinto examples
- dodoc -r sdk/demos/.
- fi
-
- if use server; then
- rm -f "${ED}"/etc/init.d/tntnet || die
- newinitd "${FILESDIR}"/tntnet.initd tntnet
- fi
-
- # bug 737184
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/dev-libs/tntnet/tntnet-2.2.1.ebuild b/dev-libs/tntnet/tntnet-2.2.1.ebuild
deleted file mode 100644
index ec2ac1e5af66..000000000000
--- a/dev-libs/tntnet/tntnet-2.2.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools epatch
-
-DESCRIPTION="Modular, multithreaded web application server extensible with C++"
-HOMEPAGE="http://www.tntnet.org/"
-SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~sparc x86"
-IUSE="doc gnutls server ssl examples"
-
-RDEPEND=">=dev-libs/cxxtools-2.2.1
- sys-libs/zlib[minizip]
- ssl? (
- gnutls? (
- >=net-libs/gnutls-1.2.0
- dev-libs/libgcrypt:0
- )
- !gnutls? ( dev-libs/openssl:0= )
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- app-arch/zip"
-
-src_prepare() {
- # Both fixed in the next release
- epatch "${FILESDIR}"/${PN}-2.0-zlib-minizip.patch
- rm framework/common/{ioapi,unzip}.[ch] || die
-
- # bug 423697
- sed -e "s:unzip.h:minizip/unzip.h:" -i framework/defcomp/unzipcomp.cpp
-
- eautoreconf
-
- sed -i -e 's:@localstatedir@:/var:' etc/tntnet/tntnet.xml.in || die
-}
-
-src_configure() {
- local myconf=""
-
- # Prefer gnutls above SSL
- if use gnutls; then
- einfo "Using gnutls for ssl support."
- myconf="${myconf} --with-ssl=gnutls"
- elif use ssl; then
- einfo "Using openssl for ssl support."
- myconf="${myconf} --with-ssl=openssl"
- else
- myconf="${myconf} --with-ssl=no"
- fi
-
- # default enabled, will not compile without sdk
- myconf="${myconf} --with-sdk"
-
- econf \
- $(use_with server) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS ChangeLog README TODO
- if use doc; then
- dodoc doc/*.pdf
- fi
-
- if use examples; then
- cd "${S}/sdk/demos"
- emake clean
- rm -rf .deps */.deps .libs */.libs
- cd "${S}"
-
- insinto /usr/share/doc/${PF}/examples
- doins -r sdk/demos/*
- fi
-
- if use server; then
- rm -f "${D}/etc/init.d/tntnet"
- newinitd "${FILESDIR}/tntnet.initd" tntnet
- fi
-}