summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/fwupd/Manifest1
-rw-r--r--sys-apps/fwupd/files/fwupd-1.3.9-logind_plugin.patch13
-rw-r--r--sys-apps/fwupd/fwupd-1.3.9.ebuild167
3 files changed, 181 insertions, 0 deletions
diff --git a/sys-apps/fwupd/Manifest b/sys-apps/fwupd/Manifest
index 4d30214b4a0f..df0d2dcc6dcf 100644
--- a/sys-apps/fwupd/Manifest
+++ b/sys-apps/fwupd/Manifest
@@ -2,3 +2,4 @@ DIST fwupd-1.2.11.tar.gz 1945646 BLAKE2B 4eb6d5008d0e515880147a94b2632ed70b5f7ab
DIST fwupd-1.3.6.tar.gz 2207849 BLAKE2B 465055d90576d4c0a7812f2554d2bc3298a12030816a2469ce653d28f9ea81e363c401355191d41b200975a615cfc64b954e0cced6b6f6bbfbbf26f63163a25e SHA512 20a5f346563b1cb8296f31ea448f336d8b54df2e5296524e2fa040a31001838b0de4a88f0d4aad9f5eeaeb4acc46919c0effb254ce681556db00cec5a4a1bc78
DIST fwupd-1.3.7.tar.gz 2223704 BLAKE2B e86603542dc76ec355912fae86721b8e60cea8bef34224cf5f157d3a91058deafc2804761ece472f0264ef42d7fa2b77d935a1638c9db3a6c0722c0659ce6a59 SHA512 6734533193be40051a565609905097c76d9f53c53075e37f560408be698774be0867383877b2acbcd2e5a92c817afdd30532f3d94465b27311b31c825a38481e
DIST fwupd-1.3.8.tar.gz 2246170 BLAKE2B b55df322c64947bcccc7bf05daaec2c5b2f646a4e53d757482dcd4d33e94d725315e6456bf69d5dbca3ef870437e1cc2a861537fc7af9b059497f119f08477de SHA512 0f0aa380adc5e167e49db4261b50bee9c905786afcd44b5fe221f42a77306219d40888989e0b16448535eaf077baed12de56b6cca42f91fca09c4a8384f243e4
+DIST fwupd-1.3.9.tar.gz 2254260 BLAKE2B ead64be3eca00fd2d045fb6c5ccd42d8913fa056736e6ae039feef70b6edababe50fb0552db39bf057750d3f0d2224b18b7ecf5a5a408a1f1ac3023d89687f68 SHA512 b81ef1f683082e4c49ab8acd8848118fed1383d4e3e73967daaa68927e553a5bc4973004d3dd26b268b901c5deb1f9238a98537d24cfd957162f508c9622e1e4
diff --git a/sys-apps/fwupd/files/fwupd-1.3.9-logind_plugin.patch b/sys-apps/fwupd/files/fwupd-1.3.9-logind_plugin.patch
new file mode 100644
index 000000000000..526fe7700ed0
--- /dev/null
+++ b/sys-apps/fwupd/files/fwupd-1.3.9-logind_plugin.patch
@@ -0,0 +1,13 @@
+Enable logind plugin when -Delogind=true is set as well
+
+--- fwupd-1.3.9/plugins/meson.build
++++ fwupd-1.3.9/plugins/meson.build
+@@ -27,7 +27,7 @@
+ subdir('wacom-raw')
+ endif
+
+-if get_option('systemd')
++if get_option('systemd') or get_option('elogind')
+ subdir('logind')
+ endif
+
diff --git a/sys-apps/fwupd/fwupd-1.3.9.ebuild b/sys-apps/fwupd/fwupd-1.3.9.ebuild
new file mode 100644
index 000000000000..a10af44195ea
--- /dev/null
+++ b/sys-apps/fwupd/fwupd-1.3.9.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit linux-info meson python-single-r1 vala xdg toolchain-funcs
+
+DESCRIPTION="Aims to make updating firmware on Linux automatic, safe and reliable"
+HOMEPAGE="https://fwupd.org"
+SRC_URI="https://github.com/hughsie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="agent amt consolekit dell gtk-doc elogind minimal +gpg introspection +man nvme pkcs7 redfish synaptics systemd test thunderbolt tpm uefi"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ^^ ( consolekit elogind minimal systemd )
+ dell? ( uefi )
+ minimal? ( !introspection )
+"
+RESTRICT="!test? ( test )"
+
+BDEPEND="$(vala_depend)
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+ man? (
+ app-text/docbook-sgml-utils
+ sys-apps/help2man
+ )
+ test? (
+ thunderbolt? ( dev-util/umockdev )
+ net-libs/gnutls[tools]
+ )
+"
+DEPEND="${PYTHON_DEPS}
+ >=app-arch/gcab-1.0
+ app-arch/libarchive:=
+ dev-db/sqlite
+ >=dev-libs/glib-2.45.8:2
+ dev-libs/json-glib
+ dev-libs/libgpg-error
+ dev-libs/libgudev:=
+ >=dev-libs/libgusb-0.2.9[introspection?]
+ >=dev-libs/libxmlb-0.1.13
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_MULTI_USEDEP}]
+ ')
+ >=net-libs/libsoup-2.51.92:2.4[introspection?]
+ virtual/libelf:0=
+ virtual/udev
+ consolekit? ( >=sys-auth/consolekit-1.0.0 )
+ dell? (
+ sys-libs/efivar
+ >=sys-libs/libsmbios-2.4.0
+ )
+ elogind? ( sys-auth/elogind )
+ gpg? (
+ app-crypt/gpgme
+ dev-libs/libgpg-error
+ )
+ !minimal? (
+ >=sys-auth/polkit-0.103
+ )
+ nvme? ( sys-libs/efivar )
+ pkcs7? ( >=net-libs/gnutls-3.4.4.1:= )
+ redfish? ( sys-libs/efivar )
+ systemd? ( >=sys-apps/systemd-211 )
+ thunderbolt? (
+ sys-apps/thunderbolt-software-user-space
+ )
+ tpm? ( app-crypt/tpm2-tss )
+ uefi? (
+ app-crypt/tpm2-tss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-boot/gnu-efi
+ sys-boot/efibootmgr
+ >=sys-libs/efivar-33
+ x11-libs/cairo
+ )
+"
+# Block sci-chemistry/chemical-mime-data for bug #701900
+RDEPEND="
+ !<sci-chemistry/chemical-mime-data-0.1.94-r4
+ ${DEPEND}
+ sys-apps/dbus
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.9-logind_plugin.patch"
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ if use nvme; then
+ kernel_is -ge 4 4 || die "NVMe support requires kernel >= 4.4"
+ fi
+}
+
+src_prepare() {
+ default
+ # c.f. https://github.com/fwupd/fwupd/issues/1414
+ sed -e "/test('thunderbolt-self-test', e, env: test_env, timeout : 120)/d" \
+ -i plugins/thunderbolt/meson.build || die
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ --localstatedir "${EPREFIX}"/var
+ -Dbuild="$(usex minimal standalone all)"
+ $(meson_use agent)
+ $(meson_use amt plugin_amt)
+ $(meson_use consolekit)
+ $(meson_use dell plugin_dell)
+ $(meson_use elogind)
+ $(meson_use gpg)
+ $(meson_use gtk-doc gtkdoc)
+ $(meson_use man)
+ $(meson_use nvme plugin_nvme)
+ $(meson_use pkcs7)
+ $(meson_use redfish plugin_redfish)
+ $(meson_use synaptics plugin_synaptics)
+ $(meson_use systemd)
+ $(meson_use test tests)
+ $(meson_use thunderbolt plugin_thunderbolt)
+ $(meson_use tpm plugin_tpm)
+ $(meson_use uefi plugin_uefi)
+ # Requires libflashrom which our sys-apps/flashrom
+ # package does not provide
+ -Dplugin_flashrom="false"
+ # Dependencies are not available (yet?)
+ -Dplugin_modem_manager="false"
+ )
+ export CACHE_DIRECTORY="${T}"
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use minimal ; then
+ sed "s@%SEAT_MANAGER%@$(usex elogind elogind consolekit)@" \
+ "${FILESDIR}"/${PN}-r1 \
+ > "${T}"/${PN} || die
+ doinitd "${T}"/${PN}
+
+ if ! use systemd ; then
+ # Don't timeout when fwupd is running (#673140)
+ sed '/^IdleTimeout=/s@=[[:digit:]]\+@=0@' \
+ -i "${ED}"/etc/${PN}/daemon.conf || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "In case you are using openrc as init system"
+ elog "and you're upgrading from <fwupd-1.1.0, you"
+ elog "need to start the fwupd daemon via the openrc"
+ elog "init script that comes with this package."
+}