summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dialup/picocom/Manifest1
-rw-r--r--net-dialup/picocom/picocom-2.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-dialup/picocom/Manifest b/net-dialup/picocom/Manifest
index df6fb7cc414a..66403dabfe29 100644
--- a/net-dialup/picocom/Manifest
+++ b/net-dialup/picocom/Manifest
@@ -1 +1,2 @@
DIST picocom-1.7.tar.gz 42857 SHA256 d0f31c8f7a215a76922d30c81a52b9a2348c89e02a84935517002b3bc2c1129e SHA512 a222cc61be1e3e9759d8d6269348f6ac13159089e41b5a6aade3dc15abab8d76571a91c970f14af89244055f8bb9adf1ad5b336d7a9b4db5a9449558b86577ec WHIRLPOOL 1bb3b05e2fa111a55611e2586d93b16adeca397f368f1c6f3309f36490405afabbc9875dce262e548aa105c5f128ee004eaa7ec47772908e69689ff1ef68838f
+DIST picocom-2.1.tar.gz 89281 SHA256 6b152fc5f816eaef6b86336a4cec7cf1496b7c712061e5aea5a36f143a0b09ed SHA512 0df692118e3cfa27edd8ff9d5abbde8a9dc02fb015476ab1469337d616eb69411db125a967107276fb50bc58e7b9748429b9ded4943712a082a10827d595c03e WHIRLPOOL 6c0a3e1080dd49ad2fd9863fd3c5cb21d9bbaca4b580145ffd20b76566109a4a18ee6b837bd192254848370206319e963cd07fe93955f85a2459297ad228c641
diff --git a/net-dialup/picocom/picocom-2.1.ebuild b/net-dialup/picocom/picocom-2.1.ebuild
new file mode 100644
index 000000000000..9fb2b2291201
--- /dev/null
+++ b/net-dialup/picocom/picocom-2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="minimal dumb-terminal emulation program"
+HOMEPAGE="https://github.com/npat-efault/picocom"
+SRC_URI="https://github.com/npat-efault/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+src_compile() {
+ # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
+ # C++ file, and the pre-processor is never called directly, this
+ # is easier than patching it out.
+ emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin picocom pc{asc,xm,ym,zm}
+ doman picocom.1
+ dodoc CHANGES.old CONTRIBUTORS README.md
+}