summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/fuse-python/Manifest1
-rw-r--r--dev-python/fuse-python/fuse-python-1.0.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/fuse-python/Manifest b/dev-python/fuse-python/Manifest
index 32f0432f7503..0f5279c79634 100644
--- a/dev-python/fuse-python/Manifest
+++ b/dev-python/fuse-python/Manifest
@@ -1 +1,2 @@
DIST fuse-python-1.0.0.tar.gz 46275 BLAKE2B 109202ed60df82a1a637a02627657c27ef48e55225c099385ec4d74554912d89dfd6238922a7588ff8de27e4c700a3b3832e204455997375dc67f6ca36590ae7 SHA512 d5e91be3e43065988053390d97ca6483ce38924bf9a49f694bf911080b7e75c836224e83d09dcbc6fab8d63781b4cd3ae016d66b65b88dd53106b06f91a6ad5c
+DIST python-fuse-1.0.4.tar.gz 46571 BLAKE2B b839043343e5abda2725545c696afd4da847e33a77647d910bc7ea71d17480536770d99899ae8f949734304ea6b4b591934f34476ea84aad1adbe39ee5897fa7 SHA512 48fffc02aa7125df03cf2a5819449a5e10a772ecc737bc8a19199beca6a2f8181b98c91cf05fedd06fc258d846c8d67d073dc1e8620c336a3ae09320688dc389
diff --git a/dev-python/fuse-python/fuse-python-1.0.4.ebuild b/dev-python/fuse-python/fuse-python-1.0.4.ebuild
new file mode 100644
index 000000000000..a79e2094d4d4
--- /dev/null
+++ b/dev-python/fuse-python/fuse-python-1.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-fuse-${PV}
+DESCRIPTION="Python FUSE bindings"
+HOMEPAGE="https://github.com/libfuse/python-fuse"
+SRC_URI="
+ https://github.com/libfuse/python-fuse/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"