summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/yamlpath/Manifest3
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.4.ebuild50
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.5.ebuild50
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.6.ebuild52
4 files changed, 0 insertions, 155 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
index 25aa199e16b7..a562dc54191e 100644
--- a/dev-python/yamlpath/Manifest
+++ b/dev-python/yamlpath/Manifest
@@ -1,4 +1 @@
-DIST yamlpath-3.6.4.gh.tar.gz 216016 BLAKE2B fc6537b7c80ecfb9f69c646970e43935374bb105df007c123cf837eb1de6827ac2cc443294b69500c966ea6bc5d7f56498aec13340238c7660118f17cc6685e5 SHA512 eb1ac0d5861818f4f4b57b07f9fa7f758846982abbb3ac4ec58a1adaca8ec36deba1e21ce3e13916e74a946512f4d66e341a9d45392ef7133d0293e5fd6f66c9
-DIST yamlpath-3.6.5.gh.tar.gz 216508 BLAKE2B df1d849840356eb75d9e19a5b53ec94ce140d7474be2fde19ab7f438229d347f247ee3c0f25cef4948f71d95d6935aebc0f8e58bc869083849820f9d641d7f22 SHA512 1d80514516eb573b0c644af7eaab7211714e271cc4334db5d965e2da58f06d26b3cdcb8c1412d03151a196e1b48aeb0c0d5038364a09907bb2af1efa71dd71f3
-DIST yamlpath-3.6.6.gh.tar.gz 222605 BLAKE2B b8e4345e68bb03b9aa48f31813ead149a1e547bab36deacfc255b6d8bb62148ed11bed6495e3e8db14b48859717ee87386e6d740c8b33dbf16bf4923bc19bbcf SHA512 3699cd2af82c77b29de60d0912dd5fc858a7b10ac960a8944dd0566073a7bdf5bccc6378d5aa6e52498482e51aa00cb2cae53f2a089308617d1358d744b5efcc
DIST yamlpath-3.6.7.gh.tar.gz 219770 BLAKE2B 779b94f6aff7e6430c89508145d85d2b7b5ddb4bc1070fd68d402e27b7bf596c7e68f1bfb8683791ea2572ef6d01fe5f2de4fd646be32b8ab266747371f61f36 SHA512 7313d3eaa9268d4c2acb1bc87052068498840943be503fa160833c03f372e5c6d7604572d277b70c551784fd8c9507e084f12dd651b5c4f600f69e8ee7cefb62
diff --git a/dev-python/yamlpath/yamlpath-3.6.4.ebuild b/dev-python/yamlpath/yamlpath-3.6.4.ebuild
deleted file mode 100644
index caea22ecdf53..000000000000
--- a/dev-python/yamlpath/yamlpath-3.6.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Command-line processors for YAML/JSON/Compatible data"
-HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
-SRC_URI="
- https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-ruby/hiera-eyaml
- )
-"
-
-distutils_enable_tests --install pytest
-
-python_prepare_all() {
- sed -e '/ruamel\.yaml/d' \
- -e '/pytest-cov/d' \
- -e "/find_packages/s/()/(exclude=\['tests'\])/" \
- -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install
-
- # install and optimize yamlpath/patches/aliasstyle.py
- local sitedir=$(python_get_sitedir)
- [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
- insinto "${sitedir}/yamlpath"
- doins -r "${S}/yamlpath/patches"
- python_optimize "${D}${sitedir}"
-}
diff --git a/dev-python/yamlpath/yamlpath-3.6.5.ebuild b/dev-python/yamlpath/yamlpath-3.6.5.ebuild
deleted file mode 100644
index e236b9aeee0e..000000000000
--- a/dev-python/yamlpath/yamlpath-3.6.5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="Command-line processors for YAML/JSON/Compatible data"
-HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
-SRC_URI="
- https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-ruby/hiera-eyaml
- )
-"
-
-distutils_enable_tests --install pytest
-
-python_prepare_all() {
- sed -e '/ruamel\.yaml/d' \
- -e '/pytest-cov/d' \
- -e "/find_packages/s/()/(exclude=\['tests'\])/" \
- -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install
-
- # install and optimize yamlpath/patches/aliasstyle.py
- local sitedir=$(python_get_sitedir)
- [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
- insinto "${sitedir}/yamlpath"
- doins -r "${S}/yamlpath/patches"
- python_optimize "${D}${sitedir}"
-}
diff --git a/dev-python/yamlpath/yamlpath-3.6.6.ebuild b/dev-python/yamlpath/yamlpath-3.6.6.ebuild
deleted file mode 100644
index 1517368d7013..000000000000
--- a/dev-python/yamlpath/yamlpath-3.6.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="Command-line processors for YAML/JSON/Compatible data"
-HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
-SRC_URI="
- https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-ruby/hiera-eyaml
- )
-"
-
-distutils_enable_tests --install pytest
-
-python_prepare_all() {
- sed -e '/ruamel\.yaml/d' \
- -e '/pytest-cov/d' \
- -e "/find_packages/s/()/(exclude=\['tests'\])/" \
- -i setup.py || die
-
- touch yamlpath/patches/__init__.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install
-
- # install and optimize yamlpath/patches/aliasstyle.py
- local sitedir=$(python_get_sitedir)
- [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
- insinto "${sitedir}/yamlpath"
- doins -r "${S}/yamlpath/patches"
- python_optimize "${D}${sitedir}"
-}