summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/tboot/tboot-1.10.3.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-boot/tboot/tboot-1.10.3.ebuild b/sys-boot/tboot/tboot-1.10.3.ebuild
index cdb682a949ff..4cedba3fabfc 100644
--- a/sys-boot/tboot/tboot-1.10.3.ebuild
+++ b/sys-boot/tboot/tboot-1.10.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,6 +28,16 @@ PATCHES=( "${FILESDIR}/${PN}-1.10.3-disable-Werror.patch"
"${FILESDIR}/${PN}-1.10.3-disable-strip.patch"
"${FILESDIR}/${PN}-1.10.3-dont-call-toolchain-directly.patch" )
+pkg_setup() {
+ if tc-is-clang; then
+ eerror "tboot is a freestanding application that uses gcc"
+ eerror "extensions in fundemental ways, include VLAIS"
+ eerror "(Variable Length Arrays in Structs) and will not"
+ eerror "compile with clang witout upstream action"
+ die "Cannot compile with clang. See bug #832020"
+ fi
+}
+
src_configure() {
tc-export AS LD CC CPP AR RANLIB NM OBJCOPY OBJDUMP STRIP