summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/plumbum/plumbum-1.7.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/plumbum/plumbum-1.7.0.ebuild b/dev-python/plumbum/plumbum-1.7.0.ebuild
deleted file mode 100644
index 94fc5fa66446..000000000000
--- a/dev-python/plumbum/plumbum-1.7.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="A library for shell script-like programs in python"
-HOMEPAGE="https://plumbum.readthedocs.io/en/latest/ https://github.com/tomerfiliba/plumbum"
-SRC_URI="https://files.pythonhosted.org/packages/ed/ba/431d7f420cd93c4b8ccb15ed8f1c6c76c81965634fd70345af0b19c2b7bc/${P}.tar.gz"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/paramiko"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-PATCHES=( "${FILESDIR}"/${PN}-1.7.0-test.patch )
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # Need sshd running
- rm tests/test_remote.py || die "rm test_remote.py failed"
- rm tests/test_utils.py || die "rm test_utils.py failed"
- rm tests/test_putty.py || die "rm test_putty.py failed"
- # Need sudo without password
- rm tests/test_sudo.py || die "rm test_sudo.py failed"
-}
-
-pkg_postinst() {
- elog "To get additional features, optional runtime dependencies may be installed:"
- optfeature "Progress bars in jupyter" dev-python/ipywidgets
- optfeature "Colored output in jupyter" dev-python/ipython
- optfeature "Images on the command line" dev-python/pillow
- elog ""
-}